4b288bd
diff --git a/pip/utils/outdated.py b/pip/utils/outdated.py
4b288bd
index 2164cc3..c71539f 100644
4b288bd
--- a/pip/utils/outdated.py
4b288bd
+++ b/pip/utils/outdated.py
4b288bd
@@ -92,6 +92,21 @@ def load_selfcheck_statefile():
4b288bd
         return GlobalSelfCheckState()
4b288bd
 
4b288bd
 
4b288bd
+def pip_installed_by_pip():
4b288bd
+    """Checks whether pip was installed by pip
4b288bd
+
4b288bd
+    This is used not to display the upgrade message when pip is in fact
4b288bd
+    installed by system package manager, such as dnf on Fedora.
4b288bd
+    """
4b288bd
+    import pkg_resources
4b288bd
+    try:
4b288bd
+        dist = pkg_resources.get_distribution('pip')
4b288bd
+        return (dist.has_metadata('INSTALLER') and
4b288bd
+                'pip' in dist.get_metadata_lines('INSTALLER'))
4b288bd
+    except pkg_resources.DistributionNotFound:
4b288bd
+        return False
4b288bd
+
4b288bd
+
4b288bd
 def pip_version_check(session):
4b288bd
     """Check for an update for pip.
4b288bd
 
4b288bd
@@ -141,7 +156,8 @@ def pip_version_check(session):
4b288bd
 
4b288bd
         # Determine if our pypi_version is older
4b288bd
         if (pip_version < remote_version and
4b288bd
-                pip_version.base_version != remote_version.base_version):
4b288bd
+                pip_version.base_version != remote_version.base_version and
4b288bd
+                pip_installed_by_pip()):
4b288bd
             # Advise "python -m pip" on Windows to avoid issues
4b288bd
             # with overwriting pip.exe.
4b288bd
             if WINDOWS: