%global srcname pytest-shutil
%global sum A goodie-bag of unix shell and environment tools for py.test
Name: python-%{srcname}
Version: 1.2.6
Release: 6%{?dist}
Summary: %{sum}
License: MIT
URL: https://pypi.python.org/pypi/%{srcname}
Source0: https://files.pythonhosted.org/packages/source/p/%{srcname}/%{srcname}-%{version}.tar.gz
# reported upstream in https://github.com/manahl/pytest-plugins/issues/67
# use /etc instead of /bin for chdir test as that links to /usr/bin on fedora
Patch1: pytest-shutil-use-etc-dir.patch
BuildArch: noarch
BuildRequires: python2-devel python3-devel
BuildRequires: python2-pytest python3-pytest
BuildRequires: python2-six python3-six
BuildRequires: python2-setuptools-git python3-setuptools_git
BuildRequires: python2-mock python3-mock
BuildRequires: python2-path python3-path
BuildRequires: python2-contextlib2 python3-contextlib2
BuildRequires: python2-execnet python3-execnet
%description
This library is a goodie-bag of Unix shell and
environment management tools for automated tests.
%package -n python2-%{srcname}
Summary: %{sum}
%{?python_provide:%python_provide python2-%{srcname}}
Requires: python2-pytest
%description -n python2-%{srcname}
This library is a goodie-bag of Unix shell and
environment management tools for automated tests.
%package -n python3-%{srcname}
Summary: %{sum}
%{?python_provide:%python_provide python3-%{srcname}}
Requires: python3-pytest
%description -n python3-%{srcname}
This library is a goodie-bag of Unix shell and
environment management tools for automated tests.
%prep
%autosetup -n %{srcname}-%{version} -p1
%build
%py2_build
%py3_build
%install
%py2_install
%py3_install
%check
%{__python2} setup.py test
%{__python3} setup.py test
%files -n python2-%{srcname}
%doc README.md CHANGES.md
%{python2_sitelib}/*
%files -n python3-%{srcname}
%doc README.md CHANGES.md
%{python3_sitelib}/*
%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.6-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon Jun 18 2018 Miro HronĨok <mhroncok@redhat.com> - 1.2.6-4
- Rebuilt for Python 3.7
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Sat Jan 27 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.2.6-2
- Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Thu Jul 27 2017 Kevin Fenzi <kevin@scrye.com> - 1.2.11-2
- Add Requires for pytest
* Wed Jul 26 2017 Kevin Fenzi <kevin@scrye.com> - 1.2.11-1
- Initial version.