churchyard / rpms / python3

Forked from rpms/python3 3 years ago
Clone

Blame 00184-ctypes-should-build-with-libffi-multilib-wrapper.patch

001a277
--- Python-3.3.2/setup.py.orig	2013-07-01 15:23:24.377711044 +0200
001a277
+++ Python-3.3.2/setup.py	2013-07-01 15:23:34.094676496 +0200
001a277
@@ -1882,7 +1882,8 @@
001a277
                     if not line:
001a277
                         ffi_inc = None
001a277
                         break
001a277
-                    if line.startswith('#define LIBFFI_H'):
001a277
+                    if line.startswith('#define LIBFFI_H') or \
001a277
+                       line.startswith('#define ffi_wrapper_h'):
001a277
                         break
001a277
         ffi_lib = None
001a277
         if ffi_inc is not None: