svashisht / rpms / bash

Forked from rpms/bash 2 years ago
Clone

91692f Rebase to bash-5.0

Authored and Committed by svashisht 8 months ago
47 files changed. 409 lines added. 2099 lines removed.
.gitignore
file modified
+1 -0
bash-2.02-security.patch
file removed
-11
bash-2.05a-interpreter.patch
file modified
+16 -22
bash-2.05b-manso.patch
file removed
-10
bash-2.05b-xcc.patch
file removed
-19
bash-4.1-defer-sigchld-trap.patch
file removed
-11
bash-4.2-coverity.patch
file modified
+17 -13
bash-4.2-trap.patch
file removed
-60
bash-4.3-here-doc-ps2-comsub.patch
file removed
-47
bash-4.3-lastpipe-nested-pipe-segfault.patch
file removed
-24
bash-4.3-noecho.patch
file modified
+10 -10
bash-4.3-parse-time-keyword.patch
file removed
-28
bash-4.3-readline-revert-lines.patch
file removed
-18
bash-4.4-assignment-error.patch
file removed
-31
bash-4.4-case-in-command-subst.patch
file removed
-18
bash-4.4-coverity.patch
file removed
-203
bash-4.4-patch-1.patch
file removed
-49
bash-4.4-patch-10.patch
file removed
-39
bash-4.4-patch-11.patch
file removed
-39
bash-4.4-patch-12.patch
file removed
-119
bash-4.4-patch-13.patch
file removed
-38
bash-4.4-patch-14.patch
file removed
-85
bash-4.4-patch-15.patch
file removed
-38
bash-4.4-patch-16.patch
file removed
-68
bash-4.4-patch-17.patch
file removed
-41
bash-4.4-patch-18.patch
file removed
-38
bash-4.4-patch-19.patch
file removed
-40
bash-4.4-patch-2.patch
file removed
-59
bash-4.4-patch-20.patch
file removed
-136
bash-4.4-patch-21.patch
file removed
-48
bash-4.4-patch-22.patch
file removed
-47
bash-4.4-patch-23.patch
file removed
-47
bash-4.4-patch-3.patch
file removed
-52
bash-4.4-patch-4.patch
file removed
-81
bash-4.4-patch-5.patch
file removed
-42
bash-4.4-patch-6.patch
file removed
-50
bash-4.4-patch-7.patch
file removed
-114
bash-4.4-patch-8.patch
file removed
-71
bash-4.4-patch-9.patch
file removed
-80
bash-4.4-unset-nonblock-stdin.patch
file removed
-11
bash-4.5-test-modification-time.patch
file removed
-11
bash-5.0-patch-1.patch
file added
+150
bash-5.0-patch-2.patch
file added
+96
bash-requires.patch
file modified
+68 -72
bash-tty-tests.patch
file modified
+5 -5
bash.spec
file modified
+45 -53
sources
file modified
+1 -1
    Rebase to bash-5.0
    
    - Remove 'bash-2.02-security.patch' patch as it does not seem to be
    needed.
    - Remove 'bash-2.05b-xcc.patch' as this change is already in upstream.
    - Remove 'bash-4.1-defer-sigchld-trap.patch' as this patch was doing
    nothing and this bug that it tried to solve should be fixed in upstream
    https://lists.gnu.org/archive/html/bug-bash/2012-03/msg00045.html
    - Remove 'bash-4.4-coverity.patch' as it has been upstreamed.
    - Delete several other patches that were not removed while rebasing to
    bash-4.4.
    
    Resolves: #1675080
    
        
file modified
+1 -0
file modified
+16 -22
file removed
-10
file removed
-19
file modified
+17 -13
file removed
-60
file modified
+10 -10
file removed
-203
file removed
-49
file removed
-39
file removed
-39
file removed
-119
file removed
-38
file removed
-85
file removed
-38
file removed
-68
file removed
-41
file removed
-38
file removed
-40
file removed
-59
file removed
-136
file removed
-48
file removed
-47
file removed
-47
file removed
-52
file removed
-81
file removed
-42
file removed
-50
file removed
-114
file removed
-71
file removed
-80
file added
+150
file modified
+68 -72
file modified
+5 -5
file modified
+45 -53
file modified
+1 -1