Blob Blame History Raw
# Provenpackagers are welcome to modify this package, but please don't obsolete
# additional packages without a corresponding bugzilla ticket being filed.

# Please remember to add all of the necessary information.  See below the
# Source0: line for a description of the format.  It is important that
# everything be included; yanking packages from an end-user system is "serious
# business" and should not be done lightly or without making everything as
# clear as possible.

Name:       fedora-obsolete-packages
# Please keep the version equal to the targeted Fedora release
Version:    35
Release:    %autorelease
Summary:    A package to obsolete retired packages

# This package has no actual content; there is nothing to license.
License:    Public Domain
URL:        https://docs.fedoraproject.org/en-US/packaging-guidelines/#renaming-or-replacing-existing-packages
BuildArch:  noarch

Source0:    README

# ===============================================================================
# Skip down below these convenience macros
%define obsolete_ticket() %{lua:
    local ticket = rpm.expand('%1')

    -- May need to declare the master structure
    if type(obs) == 'nil' then
        obs = {}
    end

    if ticket == '%1' then
        rpm.expand('%{error:No ticket provided to obsolete_ticket}')
    end

    if ticket == 'Ishouldfileaticket' then
        ticket = nil
    end

    -- Declare a new set of obsoletes
    local index = #obs+1
    obs[index] = {}
    obs[index].ticket = ticket
    obs[index].list = {}
}

%define obsolete() %{lua:
    local pkg = rpm.expand('%1')
    local ver = rpm.expand('%2')
    local pkg_
    local ver_
    local i
    local j

    if pkg == '%1' then
        rpm.expand('%{error:No package name provided to obsolete}')
    end
    if ver == '%2' then
        rpm.expand('%{error:No version provided to obsolete}')
    end

    if not string.find(ver, '-') then
        rpm.expand('%{error:You must provide a version-release, not just a version.}')
    end

    print('Obsoletes: ' .. pkg .. ' < ' .. ver)

    -- Check if the package wasn't already obsoleted
    for i = 1,#obs do
        for j = 1,#obs[i].list do
            pkg_, ver_ = table.unpack(obs[i].list[j])
            if pkg == pkg_ then
                rpm.expand('%{error:' .. pkg ..' obsoleted multiple times (' .. ver_ .. ' and ' .. ver ..').}')
            end
        end
    end

    -- Append this obsolete to the last set of obsoletes in the list
    local list = obs[#obs].list
    list[#list+1] = {pkg, ver}
}

%define list_obsoletes %{lua:
    local i
    local j
    for i = 1,#obs do
        for j = 1,#obs[i].list do
            pkg, ver = table.unpack(obs[i].list[j])
            print('  ' .. pkg .. ' < ' .. ver .. '\\n')
        end
        if obs[i].ticket == nil then
            print('  (No ticket was provided!)\\n\\n')
        else
            print('  (See ' .. obs[i].ticket .. ')\\n\\n')
        end
    end
}

# ===============================================================================
# Add calls to the obsolete_ticket and obsolete macros below, along with a note
# indicating the Fedora version in which the entries can be removed.  This is
# generally three releases beyond whatever release Rawhide is currently.  The
# macros make this easy, and will automatically update the package description.

# The ticket information is important.  Please don't add things here without
# having a filed ticket, preferrably in bugzilla.

# All Obsoletes: entries MUST be versioned (including the release), with the
# version being higher (!) than the last version-release of the obsoleted package.
# This allows the package to return to the distribution later. The best possible
# thing to do is to find the last version-release which was in the distribution,
# add one to the release, and add that version without using a dist tag.
# This allows a rebuild with a bumped Release: to be installed.

# And don't forget to update the package description!


# Template:
# Remove in F37
# %%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1234567
# %%obsolete foo 3.5-7

# Remove in F36
# Removed packages with broken dependencies on Python 3.8
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1856098
%obsolete manuale 1.1.0-12
%obsolete python3-dionaea 0.7.0-9
%obsolete python3-radicale 2.1.11-4

# Remove in F37
# Removed packages with broken dependencies on Python 3.9
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1980460
%obsolete autoarchive 1.4.1-3
%obsolete cura-lulzbot 1:3.6.22-4
%obsolete custodia 0.6.0-16
%obsolete execdb 0.1.0-8
%obsolete flatcam 8.5-23
%obsolete git-up 2.0.1-4
%obsolete glom 1.30.4-24
%obsolete glom-devel 1.30.4-24
%obsolete glom-libs 1.30.4-24
%obsolete gnome-gmail 2.4.1-14
%obsolete gr-fcdproplus-devel 3.8.0-4
%obsolete gr-fcdproplus-doc 3.8.0-4
%obsolete koschei-admin 2.4.0-11
%obsolete koschei-backend 2.4.0-11
%obsolete koschei-backend-copr 2.4.0-11
%obsolete koschei-backend-fedora 2.4.0-11
%obsolete koschei-common 2.4.0-11
%obsolete koschei-common-copr 2.4.0-11
%obsolete koschei-common-fedora 2.4.0-11
%obsolete koschei-frontend 2.4.0-11
%obsolete koschei-frontend-copr 2.4.0-11
%obsolete koschei-frontend-fedora 2.4.0-11
%obsolete lcm-devel 1.4.0-2
%obsolete libstoragemgmt-netapp-plugin 1.8.5-4
%obsolete libstoragemgmt-nfs-plugin-clibs 1.8.5-4
%obsolete lulzbot-marlin-firmware 1:1.1.9.34-14
%obsolete lulzbot-marlin-firmware-bio 1:2.0.0.174-14
%obsolete lulzbot-marlin-firmware-pro 1:2.0.0.144-14
%obsolete mozilla-iot-gateway-addon-python 0.9.0-5
%obsolete pipsi 0.9-18
%obsolete python-bna 4.1.0-17
%obsolete python3-MDAnalysis 0.20.1-6
%obsolete python3-XStatic-jQuery 3.4.1.0-4
%obsolete python3-XStatic-jquery-ui 1.12.0.1-13
%obsolete python3-abclient 0.2.3-16
%obsolete python3-aiostream 0.4.1-6
%obsolete python3-aiozmq 0.9.0-2
%obsolete python3-aiozmq+rpc 0.9.0-2
%obsolete python3-ansible-review 0.13.9-7
%obsolete python3-arcus-lulzbot 3.6.21-12
%obsolete python3-blindspin 2.0.1-12
%obsolete python3-cliapp 1.20180121-10
%obsolete python3-cocotb 1.5.2-2
%obsolete python3-congressclient 2.0.1-3
%obsolete python3-congressclient-tests 2.0.1-3
%obsolete python3-couchbase 2.5.5-9
%obsolete python3-coverage-test-runner 1.15-11
%obsolete python3-custodia 0.6.0-16
%obsolete python3-databay 0.1.6-3
%obsolete python3-descartes 1.1.0-17
%obsolete python3-diskcache 5.2.1-3
%obsolete python3-django-helpdesk 0.2.22-3
%obsolete python3-django-nose 1.4.7-4
%obsolete python3-django-post_office 3.4.0-6
%obsolete python3-django-registration 2.1.2-17
%obsolete python3-django-storages+azure 1.8-5
%obsolete python3-django-storages+boto 1.8-5
%obsolete python3-flask-assets 0.10-23
%obsolete python3-flask-autoindex 0.6.6-5
%obsolete python3-flask-babelex 0.9.4-5
%obsolete python3-flask-gravatar 0.5.0-13
%obsolete python3-flask-oauth 0.13-18
%obsolete python3-flask-paranoid 0.2.0-14
%obsolete python3-flask-principal 0.4.0-27
%obsolete python3-flask-pymongo 2.3.0-3
%obsolete python3-flask-rstpages 0.3-25
%obsolete python3-flask-script 2.0.6-11
%obsolete python3-flask-security 3.0.0-13
%obsolete python3-flask-silk 0.2-15
%obsolete python3-flask-sphinx-themes 1.0.2-13
%obsolete python3-fn 0.4.3-23
%obsolete python3-furl 1.2-12
%obsolete python3-glusterfs-api 1.2-10
%obsolete python3-gntp 1.0.3-16
%obsolete python3-google-compute-engine 2.8.12-10
%obsolete python3-holidays 0.10.4-2
%obsolete python3-iptables 0.12.0-12
%obsolete python3-jabberpy 0.5-0.50
%obsolete python3-jose+pycrypto 3.2.0-5
%obsolete python3-jsonfield 3.1.0-6
%obsolete python3-jsonrpcserver 4.0.5-6
%obsolete python3-jsons 1.3.0-3
%obsolete python3-kyotocabinet 1.22-4
%obsolete python3-langdetect 1.0.8-2
%obsolete python3-lcm 1.4.0-2
%obsolete python3-libtaskotron 0.10.4-5
%obsolete python3-losant-rest 1.11.0-3
%obsolete python3-lzo 1.09-21
%obsolete python3-mdp 3.5-20
%obsolete python3-meld3 2.0.0-7
%obsolete python3-minibelt 0.1.1-19
%obsolete python3-mtg 1.6.1-18
%obsolete python3-neo4j-driver 1.6.2-12
%obsolete python3-neotime 1.0.0-13
%obsolete python3-nnpy 1.4.2-8
%obsolete python3-nose-cov 1.6-23
%obsolete python3-nose-exclude 0.5.0-12
%obsolete python3-nose-progressive 1.5.1-24
%obsolete python3-npyscreen 4.10.5-7
%obsolete python3-nss 1.0.1-24
%obsolete python3-openexr 2.5.5-2
%obsolete python3-openstack-doc-tools 1.8.0-13
%obsolete python3-opentelemetry-ext-zipkin 0.8.0-6
%obsolete python3-orderedmultidict 1.0-12
%obsolete python3-pika-pool 0.1.3-22
%obsolete python3-positional 1.1.1-19
%obsolete python3-pyinsane2 2.0.13-11
%obsolete python3-pykafka 2.6.0-0.14
%obsolete python3-pyqtrailer 0.6.2-26
%obsolete python3-pysctp 0.6-27
%obsolete python3-pysendfile 2.0.1-18
%obsolete python3-pytest-catchlog 1.2.2-20
%obsolete python3-pytest-faulthandler 1.6.0-7
%obsolete python3-pytest-helpers-namespace 2019.1.8-10
%obsolete python3-pytest-relaxed 1.1.5-12
%obsolete python3-pytest4 4.6.11-4
%obsolete python3-pytoml 0.1.18-12
%obsolete python3-pytrailer 0.6.1-18
%obsolete python3-qhexedit2 0.8.9-4
%obsolete python3-qhexedit2-devel 0.8.9-4
%obsolete python3-rdkit 2019.03.3-15
%obsolete python3-ryu 4.29-11
%obsolete python3-schedule 0.6.0-4
%obsolete python3-setuptools-lint 0.6.0-10
%obsolete python3-setuptools_hg 0.4-17
%obsolete python3-shadowsocks 2.9.1-16
%obsolete python3-shortuuid 1.0.1-5
%obsolete python3-simplepam 0.1.5-21
%obsolete python3-siosocks 0.1.0-7
%obsolete python3-soco 0.19-3
%obsolete python3-sphinxcontrib-adadomain 0.2-15
%obsolete python3-sphinxcontrib-issuetracker 0.11-24
%obsolete python3-tinycss 0.3-28
%obsolete python3-transitions 0.8.7-2
%obsolete python3-twilio 6.32.0-6
%obsolete python3-txamqp 0.8.1-15
%obsolete python3-uranium-lulzbot 3.6.21-6
%obsolete python3-urlobject 2.4.3-16
%obsolete python3-uwsgidecorators 2.0.18-17
%obsolete python3-vcversioner 2.16.0.0-3
%obsolete python3-vrpn 07.33-24
%obsolete python3-webassets 0.12.1-20
%obsolete pyxtrlock 0.2-26
%obsolete qtile 0.14.2-5
%obsolete rdkit 2019.03.3-15
%obsolete rdkit-devel 2019.03.3-15
%obsolete rdkit-doc 2019.03.3-15
%obsolete rdkit-postgresql 2019.03.3-15
%obsolete regindexer 0.6.2-4
%obsolete taskotron-runner 0.10.4-5
%obsolete taskotron-trigger 0.7.0-9
%obsolete uwsgi-plugin-python3 2.0.18-17
%obsolete uwsgi-plugin-python3-gevent 2.0.18-17
%obsolete uwsgi-plugin-python3-greenlet 2.0.18-17

# Remove in F36
# Remove packages incompatible with Xfce 4.16
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1911945
%obsolete orage 4.12.1-17
%obsolete thunar-vfs 1.2.0-28
%obsolete thunar-vfs-devel 1.2.0-28
%obsolete xfbib 0.1.0-14
%obsolete xfce4-embed-plugin 1.6.0-13
%obsolete xfce4-cellmodem-plugin 0.0.5-29
%obsolete xfce4-kbdleds-plugin 0.0.6-20
%obsolete xfce4-hardware-monitor-plugin 1.6.0-11

# Remove in F36
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1680068
%obsolete empathy 1:3.12.14-9

# Remove in F36
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1940930
%obsolete gnome-documents 3.34.0-7
%obsolete gnome-documents-libs 3.34.0-7

# Remove in F36
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1912736
%obsolete gedit-code-assistance 3.16.0-15
%obsolete gedit-code-assistance-devel 3.16.0-15

# Remove in F36
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1964864
%obsolete ekiga 4.0.1-51

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1889065
%obsolete eclipse-mylyn 3.25.0-4
%obsolete ocaml-ppxfind 1.4-12
%obsolete ocaml-ppx-tools-versioned 5.4.0-11
%obsolete ocaml-ppx-tools-versioned-devel 5.4.0-11

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1964647
%obsolete perl-Debug-Client 0.31-14

# Remove in F37
%obsolete_ticket Ishouldfileaticket
%obsolete perl-Mozilla-LDAP 1.5.3-37

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1964651
%obsolete perl-Padre 0.90-35

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1973623
%obsolete perl-RDF-Trine-redland 1.019-14

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1965446
%obsolete texlive-einfuehrung-doc 9:svn54080-39
%obsolete texlive-einfuehrung2-doc 9:svn54080-39
%obsolete texlive-knuth-doc 9:svn32899.0-39
%obsolete texlive-latex-bib-ex-doc 9:svn25831.0-39
%obsolete texlive-latex-bib2-ex-doc 9:svn40098-39
%obsolete texlive-latex-referenz-doc 9:svn36671.2-39
%obsolete texlive-latex-tabellen-doc 9:svn16979.0-39
%obsolete texlive-latex-tds-doc 9:svn54758-39
%obsolete texlive-math-e-doc 9:svn20062.0-39
%obsolete texlive-presentations-doc 9:svn43949-39
%obsolete texlive-presentations-en-doc 9:svn29803.0-39
%obsolete texlive-tabulars-e-doc 9:svn21191.1.0-39
%obsolete texlive-texlive-docindex 9:svn54903-39
%obsolete texlive-texlive-docindex-doc 9:svn54903-39
%obsolete texlive-updmap-map 9:svn56618-39

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=2002234
%obsolete cbi-plugins 1.1.7-11
%obsolete eclipse-cdt 2:9.11.1-11
%obsolete eclipse-cdt-arduino 2:9.11.1-11
%obsolete eclipse-cdt-llvm 2:9.11.1-11
%obsolete eclipse-cdt-native 2:9.11.1-11
%obsolete eclipse-cdt-qt 2:9.11.1-11
%obsolete eclipse-cdt-sdk 2:9.11.1-11
%obsolete eclipse-cdt-terminal 2:9.11.1-11
%obsolete eclipse-ecf-core 3.14.19-3
%obsolete eclipse-egit 5.11.0-2
%obsolete eclipse-emf-core 1:2.25.0-2
%obsolete eclipse-emf-runtime 1:2.25.0-2
%obsolete eclipse-emf-xsd 1:2.25.0-2
%obsolete eclipse-equinox-osgi 1:4.19-4
%obsolete eclipse-findbugs 3.0.1-24
%obsolete eclipse-findbugs-contrib 7.4.7-7
%obsolete eclipse-gef 3.11.0-17
%obsolete eclipse-jdt 1:4.19-4
%obsolete eclipse-jgit 5.11.0-2
%obsolete eclipse-license1 1.0.1-14
%obsolete eclipse-license2 2.0.2-4
%obsolete eclipse-m2e-core 1.17.2-2
%obsolete eclipse-m2e-workspace 0.4.0-18
%obsolete eclipse-m2e-workspace-javadoc 0.4.0-18
%obsolete eclipse-mpc 1.9.1-2
%obsolete eclipse-p2-discovery 1:4.19-4
%obsolete eclipse-pde 1:4.19-4
%obsolete eclipse-platform 1:4.19-4
%obsolete eclipse-pydev 1:8.0.0-3
%obsolete eclipse-remote 3.0.1-7
%obsolete eclipse-subclipse 4.3.3-3
%obsolete eclipse-swt 1:4.19-4
%obsolete eclipse-webtools-common 3.21.0-2
%obsolete eclipse-webtools-servertools 3.21.0-2
%obsolete eclipse-webtools-sourceediting 3.21.0-2
%obsolete tycho 2.2.0-5

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=2001906
%obsolete glassfish-hk2-class-model 2.5.0-7

# Remove in F37
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=2001333
%obsolete arduino 1.8.13-6
%obsolete arduino-core 1.8.13-6
%obsolete arduino-devel 1.8.13-6

# This package won't be installed, but will obsolete other packages
Provides: libsolv-self-destruct-pkg()

%description
This package exists only to obsolete other packages which need to be removed
from the distribution for some reason.

Currently obsoleted packages:

%list_obsoletes


%prep
%autosetup -c -T
cp %SOURCE0 .


%files
%doc README


%changelog
%autochangelog