#3 dist-git retirement of obsolete module stream rsyslog:f28
Merged 3 months ago by humaton. Opened 2 years ago by merlinm.
modules/ merlinm/rsyslog f28  into  f28

file removed
-2
@@ -1,2 +0,0 @@ 

- .mbs_local_build.db

- ~/*

file added
+1
@@ -0,0 +1,1 @@ 

+ Obsolete

file removed
-144
@@ -1,144 +0,0 @@ 

- document: modulemd

- version: 1

- data:

-     summary: Enhanced system logging and kernel message trapping daemon

-     description: >-

-         Rsyslog is an enhanced, multi-threaded syslog daemon. It supports MySQL,

-         syslog/TCP, RFC 3195, permitted sender lists, filtering on any message part,

-         and fine grain output format control. It is compatible with stock sysklogd

-         and can be used as a drop-in replacement. Rsyslog is simple to set up, with

-         advanced features suitable for enterprise-class, encryption-protected syslog

-         relay chains.

-     license:

-         module: [ MIT ]

-     dependencies:

-         buildrequires:

-             #uncomment all of these once we get rid of bootstrap

-             #autotools: f27

-             #perl: master

-             #python2: master

-             #python3: master

-             networking-base: f27  # provides net-snmp and mariabd-client

-             #!!TEMPORARY!! - switch to master/upstream/etc. branch once varnish module gets updated !!

-             #varnish: f26  # provides jemalloc

-             #!!TEMPORARY!! - replace once - swig(boost) modularization is completed !!

-             bootstrap: f27

-             mariadb-connector-c: 3.0

-         requires:

-             platform: f27

-             mongodb: 3.4

-             #mariadb: 10.2

-             postgresql: 9.6

-     references:

-         community: http://www.rsyslog.com/

-         documentation: http://www.rsyslog.com/doc/master/index.html

-         tracker: https://github.com/rsyslog/rsyslog/issues

-     profiles:

-         default:

-             rpms:

-                 - rsyslog

-                 - rsyslog-gnutls

-                 - rsyslog-relp

-         minimal:

-             rpms:

-                 - rsyslog

-         full:

-             rpms:

-                 - rsyslog

-                 - rsyslog-crypto

-                 - rsyslog-doc

-                 - rsyslog-elasticsearch

-                 - rsyslog-gnutls

-                 - rsyslog-gssapi

-                 - rsyslog-hiredis

-                 - rsyslog-kafka

-                 - rsyslog-libdbi

-                 - rsyslog-mmaudit

-                 - rsyslog-mmjsonparse

-                 - rsyslog-mmnormalize

-                 - rsyslog-mmsnmptrapd

-                 - rsyslog-mongodb

-                 - rsyslog-mysql

-                 - rsyslog-omamqp1

-                 - rsyslog-pgsql

-                 - rsyslog-rabbitmq

-                 - rsyslog-relp

-                 - rsyslog-snmp

-                 - rsyslog-udpspoof

-         buildroot:

-             rpms:

-                 - rsyslog

-         srpm-buildroot:

-             rpms:

-                 - rsyslog

-     api:

-             rpms:

-                 - rsyslog

-     components:

-         rpms:

-             rsyslog:

-                 rationale: Base package of this module.

-                 buildorder: 5 

-             #bison:

-                 #rationale: Dependency of rsyslog base.

-                 #buildorder: 4 

-             hiredis:

-                 rationale: Dependency of rsyslog-hiredis rpm.

-                 buildorder: 4 

-             #redis:

-                 #rationale: Dependency of hiredis.

-                 #buildorder: 3 

-             libdbi:

-                 rationale: Dependency of rsyslog-libdbi rpm.

-                 buildorder: 4

-             #openjade:

-                 #rationale: Dependency of libdbi

-                 #buildorder: 3

-             #opensp:

-                 #rationale: Dependency of openjade

-                 #buildorder: 2

-             libee:

-                 rationale: Dependency of rsyslog base.

-                 buildorder: 4 

-             libestr:

-                 rationale: Dependency of liblognorm.

-                 buildorder: 3 

-             libfastjson:

-                 rationale: Dependency of liblognorm.

-                 buildorder: 3 

-             liblogging:

-                 rationale: Dependency of rsyslog base.

-                 buildorder: 4 

-             #dos2unix:

-                 #rationale: Dependency of liblogging and rsyslog base.

-                 #buildorder: 3 

-             liblognorm:

-                 rationale: Dependency of rsyslog-mmnormalize.

-                 buildorder: 4 

-             libnet:

-                 rationale: Dependency of rsyslog base.

-                 buildorder: 4 

-             librabbitmq:

-                 rationale: Dependency of rsyslog-rabbitmq.

-                 buildorder: 4 

-             #xmlto:

-                 #rationale: Dependency of librabbitmq.

-                 #buildorder: 3 

-             librdkafka:

-                 rationale: Dependency of rsyslog-kafka.

-                 buildorder: 4 

-             librelp:

-                 rationale: Dependency of rsyslog-relp.

-                 buildorder: 4 

-             libmongo-client:

-                 rationale: Dependency of rsyslog-mongodb.

-                 buildorder: 4 

-             #python-sphinx:

-                 rationale: Dependency of librelp.

-                 buildorder: 3 

-             #python-docutils:

-                 #rationale: Dependency of rsyslog base.

-                 #buildorder: 4 

-             qpid-proton:

-                 rationale: Dependency of rsyslog base.

-                 buildorder: 4 

file removed

This PR is part of an effort to retire obsolete modules in dist-git.

rsyslog:f28 has never had any attempted builds in Fedora Module Build Service.

Note: this PR is for a branch corresponding to a Fedora release that is no longer supported, so it will need to be merged by Release Engineering. See https://pagure.io/releng/issue/8887.

Pull-Request has been merged by humaton

3 months ago