#1 update to version 1.2.2
Merged 4 years ago by decathorpe. Opened 4 years ago by decathorpe.
Unknown source master  into  master

file modified
+4
@@ -1,1 +1,5 @@

+ /results_*

+ /*.src.rpm

+ 

  /aalto-xml-1.0.0.tar.gz

+ /aalto-xml-1.2.2.tar.gz

file modified
+9 -3
@@ -1,6 +1,6 @@

  Name:          aalto-xml

- Version:       1.0.0

- Release:       8%{?dist}

+ Version:       1.2.2

+ Release:       1%{?dist}

  Summary:       Ultra-high performance non-blocking XML processor (Stax/Stax2, SAX/SAX2)

  # Source files without license headers https://github.com/FasterXML/aalto-xml/issues/38

  # See https://github.com/FasterXML/jackson-modules-base/issues/18, from main developer:
@@ -13,6 +13,7 @@

  

  BuildRequires: maven-local

  BuildRequires: mvn(com.fasterxml:oss-parent:pom:)

+ BuildRequires: mvn(com.fasterxml.woodstox:woodstox-core)

  BuildRequires: mvn(junit:junit)

  BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)

  BuildRequires: mvn(org.codehaus.woodstox:stax2-api)
@@ -56,8 +57,10 @@

  

  %mvn_file : %{name}

  

- %build

+ # Java 9 module support isn't needed

+ %pom_remove_plugin :moditect-maven-plugin

  

+ %build

  %mvn_build

  

  %install
@@ -71,6 +74,9 @@

  %license LICENSE NOTICE

  

  %changelog

+ * Fri Oct 04 2019 Fabio Valentini <decathorpe@gmail.com> - 1.2.2-1

+ - Update to version 1.2.2.

+ 

  * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-8

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

  

file modified
+1 -1
@@ -1,1 +1,1 @@

- ddf09a40be0c93b1df62c24512377bf0  aalto-xml-1.0.0.tar.gz

+ SHA512 (aalto-xml-1.2.2.tar.gz) = 15407b59d586dcfdfe0cccd168f20fcbd588fa63ca50226a70b76cc609e66620e360c9a5707602dfe8b36c40694283d7a1ac339c16760b36ee1bb7f1a1d64ec0

  • update to version 1.2.2
  • add missing BR
  • disable unnecessary plugin for Java 9 Module support

Test rebuilds of dependent packages were successful:

https://copr.fedorainfracloud.org/coprs/decathorpe/aalto-xml-pr/monitor/

I love me some Woodstox.

Just one clarification:

+ # Java 9 module support isn't needed
+ %pom_remove_plugin :moditect-maven-plugin

In the hypothetical future where JDK 11 comes down on us, we could go and package moditect-maven-plugin and then get JDK9+ support nicely?

Anyhow, +1 from me.

@cipherboy thanks!

By the way, I recently got a report that xmvn (which is the thing that builds almost all java packages in fedora) crashes on OpenJDK 11. So I'd not hold my breath ...

Pull-Request has been merged by decathorpe

4 years ago