Blob Blame History Raw
%global        with_python3 1

Name:          bpython
Summary:       Fancy curses interface to the Python interactive interpreter
Version:       0.15
Release:       1%{?dist}
URL:           http://www.bpython-interpreter.org/
Group:         Development/Libraries
License:       MIT
Source0:       http://www.bpython-interpreter.org/releases/bpython-%{version}.tar.gz
BuildArch:     noarch
BuildRequires: python-devel
BuildRequires: python-setuptools
BuildRequires: python-sphinx
BuildRequires: desktop-file-utils
%if 0%{?with_python3}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%endif # if with_python3
Requires:      python-curtsies >= 0.1.18
Requires:      python-greenlet
Requires:      python-pygments
Requires:      python-requests > 1.2.3
Requires:      python-six >= 1.5
Requires:      python-urwid
Requires:      python-watchdog
Obsoletes:     bpython-gtk < 0.14

%description
bpython is a fancy interface to the Python interpreter for Unix-like
operating systems. It has the following features:
 o in-line syntax highlighting
 o readline-like autocomplete with suggestions displayed as you type
 o expected parameter list for any Python function.
 o eewind function to pop the last line of code from memory and
   re-evaluate.
 o send the code you've entered off to a pastebin and display the
   pastebin URL for copying, etc.
 o save the code you've entered to a file
 o auto indentation

%if 0%{?with_python3}
%package -n    python3-bpython
Summary:       Fancy curses interface to the Python 3 interactive interpreter 
Group:         Development/Languages
Provides:      bpython3 = %{version}-%{release}
Requires:      python3-curtsies >= 0.1.18
Requires:      python3-greenlet
Requires:      python3-pygments
Requires:      python3-requests > 1.2.3
Requires:      python3-six >= 1.5
#Requires:      python3-urwid
Requires:      python3-watchdog

%description -n python3-bpython
bpython is a fancy interface to the Python interpreter for Unix-like
operating systems. It has the following features:
 o in-line syntax highlighting
 o readline-like autocomplete with suggestions displayed as you type
 o expected parameter list for any Python function.
 o eewind function to pop the last line of code from memory and
   re-evaluate.
 o send the code you've entered off to a pastebin and display the
   pastebin URL for copying, etc.
 o save the code you've entered to a file
 o auto indentation

This is the Python 3 build of bpython
%endif # if with_python3

%prep
%setup -q

%build
%{py2_build}

%if 0%{?with_python3}
%{py3_build}
%endif

%install
# Install python 3 first, so that python 2 gets precedence:
%if 0%{?with_python3}
%{py3_install}
# python3-urwid ok, however python3 twisted also needed
rm -f %{buildroot}%{_bindir}/bpython-urwid
# Move python3
mv %{buildroot}/%{_bindir}/bpython %{buildroot}/%{_bindir}/bpython3
mv %{buildroot}/%{_bindir}/bpython-curses %{buildroot}/%{_bindir}/bpython3-curses
mv %{buildroot}/%{_bindir}/bpdb %{buildroot}%{_bindir}/bpdb3
# Create symlink for compat reasons
ln -s bpython3 %{buildroot}%{_bindir}/python3-bpython
%endif # with_python3

%{py2_install}


%files
%license LICENSE
%doc AUTHORS CHANGELOG README.rst
%doc light.theme sample.theme
%{_bindir}/bpdb
%{_bindir}/bpython
%{_bindir}/bpython-curses
%{_bindir}/bpython-urwid
%{python_sitelib}/bpython*
%{python_sitelib}/bpdb
%{_mandir}/man1/bpython.1*
%{_mandir}/man5/bpython-config.5*
%{_datadir}/pixmaps/bpython.png
%{_datadir}/appdata/bpython.appdata.xml
%{_datadir}/applications/bpython.desktop

%if 0%{?with_python3}
%files -n python3-bpython
%license LICENSE
%doc AUTHORS CHANGELOG README.rst
%doc light.theme sample.theme
%{_bindir}/bpdb3
%{_bindir}/bpython3
%{_bindir}/bpython3-curses
%{_bindir}/python3-bpython
%{python3_sitelib}/bpython*
%{python3_sitelib}/bpdb
%endif # with_python3

%changelog
* Sun Jan 17 2016 Terje Rosten <terje.rosten@ntnu.no> - 0.15-1
- 0.15

* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.2-3
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5

* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Tue Jun 02 2015 Terje Rosten <terje.rosten@ntnu.no> - 0.14.2-1
- 0.14.2

* Thu Mar 26 2015 Terje Rosten <terje.rosten@ntnu.no> - 0.14.1-1
- 0.14.1
- gtk gone upstream, remove sub package and add obsolete
- appdata, desktop file and png upstream
- new deps
- curtsies now default

* Thu Mar 26 2015 Richard Hughes <rhughes@redhat.com> - 0.13.2-2
- Add an AppData file for the software center

* Mon Jan 12 2015 Terje Rosten <terje.rosten@ntnu.no> - 0.13.2-1
- 0.13.2
- Swap bpython3 symlinks
- Add bpython3 provide
- Python requests package required

* Sun Jan 11 2015 Terje Rosten <terje.rosten@ntnu.no> - 0.13.1-3
- Add bpython3 symlink

* Sat Jan 10 2015 Terje Rosten <terje.rosten@ntnu.no> - 0.13.1-2
- Move bpython-gtk to subpackage (bz #1178996)

* Mon Aug 11 2014 Terje Rosten <terje.rosten@ntnu.no> - 0.13.1-1
- 0.13.1

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Tue May 27 2014 Kalev Lember <kalevlember@gmail.com> - 0.12-5
- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4

* Mon Nov 18 2013 Terje Rosten <terje.rosten@ntnu.no> - 0.12-4
- Add patch to fix resize crash (bz #667934)

* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Wed Mar 06 2013 Terje Rosten <terje.rosten@ntnu.no> - 0.12-2
- Add patch to fix import crash (bz #823662)

* Wed Jan 30 2013 Terje Rosten <terje.rosten@ntnu.no> - 0.12-1
- 0.12

* Sat Aug 04 2012 David Malcolm <dmalcolm@redhat.com> - 0.11-4
- rebuild for https://fedoraproject.org/wiki/Features/Python_3.3

* Fri Aug  3 2012 David Malcolm <dmalcolm@redhat.com> - 0.11-3
- remove rhel logic from with_python3 conditional

* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

* Mon May 07 2012 Terje Rosten <terje.rosten@ntnu.no> - 0.11-1
- 0.11

* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

* Mon Oct 17 2011 Terje Rosten <terje.rosten@ntnu.no> - 0.10.1-2
- Add python-urwid to buildreq

* Mon Oct 17 2011 Terje Rosten <terje.rosten@ntnu.no> - 0.10.1-1
- 0.10.1

* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.7.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

* Thu Sep 02 2010 Terje Rosten <terje.rosten@ntnu.no> - 0.9.7.1-1
- 0.9.7.1

* Wed Aug 25 2010 Thomas Spura <tomspur@fedoraproject.org> - 0.9.6.2-7
- rebuild with python3.2
  http://lists.fedoraproject.org/pipermail/devel/2010-August/141368.html

* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.6.2-6
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild

* Sun May 30 2010 Terje Rosten <terje.rosten@ntnu.no> - 0.9.6.2-5
- Add patch to fix suspend

* Sun May 09 2010 Terje Rosten <terje.rosten@ntnu.no> - 0.9.6.2-4
- bpython don't use pyparsing

* Fri May 07 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.6.2-3
- Add python3 subpackage (bz #590107)

* Fri Apr 09 2010 Terje Rosten <terje.rosten@ntnu.no> - 0.9.6.2-2
- Fix man page (bz #561800)

* Fri Apr 09 2010 Terje Rosten <terje.rosten@ntnu.no> - 0.9.6.2-1
- 0.9.6.2

* Thu Nov 05 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.9.5.2-1
- 0.9.5.2

* Fri Jul 31 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.9.4-1
- 0.9.4
- Update urls

* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Mon May 18 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.8.0-1
- 0.8.0

* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Mon Jan  5 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.7.1-2
- Add setuptools to buildreq

* Mon Jan  5 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.7.1-1
- 0.7.1

* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.7.0-2
- Rebuild for Python 2.6

* Mon  Sep 1 2008 Terje Rosten <terje.rosten@ntnu.no> - 0.7.0-1
- 0.7.0

* Tue Aug 12 2008 Terje Rosten <terje.rosten@ntnu.no> - 0.6.3-1
- 0.6.3

* Mon May  5 2008 Terje Rosten <terje.rosten@ntnu.no> - 0.3.1-2
- fix summary
- remove desktop file and optflags

* Wed Apr 30 2008 Terje Rosten <terje.rosten@ntnu.no> - 0.3.1-1
- 0.3.1
- drop patch

* Sun Apr 27 2008 Terje Rosten <terje.rosten@ntnu.no> - 0.2.3-1
- random fixes

* Sun Apr 27 2008 Pascal Bleser <guru@unixtech.be> 0.2.3
- new package