Blob Blame History Raw
--- cubegui-4.4/src/GUI-qt/display/utils/VersionCheckWidget.cpp~	2018-05-08 14:39:56.336543142 +0100
+++ cubegui-4.4/src/GUI-qt/display/utils/VersionCheckWidget.cpp	2018-05-11 15:44:20.168536703 +0100
@@ -56,19 +56,8 @@
     url              = QUrl( UPDATE_CHECK_URL );
     download         = NULL;
     update_Available = false;
-    bool no_http = env_str2bool( getenv( "CUBE_DISABLE_HTTP_DOCS" ) );
-    if ( !no_http )
     {
-        updateDescription =   tr( "Check for update is not performed yet." );
-        Globals::setStatusMessage( tr( "Check for new version...(I)" ) );
-        download = new DownloadThread( url );
-        connect( download, SIGNAL( downloadFinished( QUrl, QByteArray ) ),
-                 this, SLOT( check( QUrl, QByteArray ) ) );
-        QTimer::singleShot( 10000, download, SLOT( loadList() ) );
-    }
-    else
-    {
-        QString _status = tr( "Check for new version is disabled via environment variable CUBE_DISABLE_HTTP_DOCS=\"" ) + QString( getenv( "CUBE_DISABLE_HTTP_DOCS" ) ) + "\"";
+        QString _status = tr( "Check for new version is disabled" );
         updateDescription =   _status;
         Globals::setStatusMessage( _status );
     }