#2 relax Perl CGI/Gtk3/Net::LDAP dependencies into Suggests
Closed a year ago by sergiomb. Opened 2 years ago by duck.
rpms/ duck/debconf relax_deps  into  master

file modified
+15 -3
@@ -1,11 +1,13 @@ 

+ %global __requires_exclude ^perl\\((CGI|Gtk3|Net::LDAP)

+ 

  Name:           debconf

  Version:        1.5.73

- Release:        3%{?dist}

+ Release:        4%{?dist}

  Summary:        Debian configuration management system

  

  License:        BSD

  URL:            https://tracker.debian.org/pkg/debconf

- Source0:        http://ftp.de.debian.org/debian/pool/main/d/%{name}/%{name}_%{version}.tar.xz

+ Source0:        https://snapshot.debian.org/archive/debian/20190803T152032Z/pool/main/d/%{name}/%{name}_%{version}.tar.xz

  BuildArch:      noarch

  

  #Build-Depends: debhelper (>= 9~), dh-exec, po-debconf, po4a (>= 0.23)
@@ -16,7 +18,6 @@ 

  BuildRequires:  perl-generators

  BuildRequires:  perl-interpreter

  BuildRequires:  perl-libintl-perl

- BuildRequires:  perl-Gtk3

  # Not actual requirements, although listed at

  # http://ftp.de.debian.org/debian/pool/main/d/debconf/debconf_1.5.32.dsc

  BuildRequires:  debhelper >= 7.0.50
@@ -25,6 +26,11 @@ 

  Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

  # to test frontends : dpkg-reconfigure --frontend=kde tzdata

  Requires:       perl-Text-Iconv

+ %if 0%{?fedora} || 0%{?rhel} > 7

+ Suggests:       perl(CGI)

+ Suggests:       perl(Gtk3)

+ Suggests:       perl(Net::LDAP)

+ %endif

  Obsoletes:      debconf-kde < 1.5.69-5

  Obsoletes:      debconf-gnome < 1.5.69-5

  
@@ -233,6 +239,12 @@ 

  %{python3_sitelib}/__pycache__/debconf.*

  

  %changelog

+ * Fri May 15 2020 Marc Dequènes (Duck) <duck@redhat.com> - 1.5.73-4

+ - Downgrade Perl dependencies on CGI/Gtk3/Net::LDAP to Suggests as

+   they are not often used and drag lots of dependencies; this follows

+   Debian's choices

+ - Fix source URL and switch to HTTS

+ 

  * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.73-3

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

  

This fixes #1836083.

Please make it available on EL7/8 too.

I had to fix the Source URL since it was not working anymore and Copr (which I use for my tests) does not allow insecure links.

It has been built properly on all supported Fedora and EL7/8 too: https://copr.fedorainfracloud.org/coprs/duck/osas-infra-team-rpm-repo/build/1386418/

It has been tested with needrestart and works fine.

http://ftp.de.debian.org/debian/pool/main/d/debconf/ still works

they are not often used and drag lots of dependencies;
ok but why you don't want the dependencies , a lots are what ?

this follows Debian's choices
in el7 not even suggests ?

So why I should consider downgrading some deps to recommends and eliminated deps on el 7 ?

Pull-Request has been closed by sergiomb

a year ago