Blob Blame Raw
--- digikam-4.2.0/core/CMakeLists.txt	2014-08-04 02:25:59.000000000 +0300
+++ digikam-4.2.0/core/CMakeLists.txt	2014-08-05 18:12:32.189542242 +0300
@@ -103,7 +103,7 @@
 
 INCLUDE(MacroUtils)
 INCLUDE(MacroOpenCV)
-DETECT_OPENCV(2.4.6 core highgui imgproc)
+DETECT_OPENCV(2.4.9 core highgui objdetect contrib legacy imgproc)
 
 # check the libkdcraw version
 
--- digikam-4.2.0/extra/kipi-plugins/CMakeLists.txt	2014-08-04 02:26:07.000000000 +0300
+++ digikam-4.2.0/extra/kipi-plugins/CMakeLists.txt	2014-08-05 18:09:46.758224538 +0300
@@ -119,7 +119,7 @@
 
 INCLUDE(MacroUtils)
 INCLUDE(MacroOpenCV)
-DETECT_OPENCV(2.4.6 core highgui objdetect contrib)
+DETECT_OPENCV(2.4.9 core highgui objdetect contrib legacy imgproc)
 
 # OpenMP detection requires CMake >= 2.6.3
 
--- digikam-4.2.0/extra/libkface/CMakeLists.txt	2014-08-04 02:26:00.000000000 +0300
+++ digikam-4.2.0/extra/libkface/CMakeLists.txt	2014-08-05 18:10:22.216863850 +0300
@@ -47,7 +47,7 @@
 SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
 
 INCLUDE(MacroOpenCV)
-DETECT_OPENCV(2.4.9 core highgui objdetect contrib)
+DETECT_OPENCV(2.4.9 core highgui objdetect contrib legacy imgproc)
 
 INCLUDE_DIRECTORIES(${OpenCV_INCLUDE_DIRS})