#3 Update selinux sub-package to require the correct package with /usr/sbin/semanage
Opened a year ago by plautrba. Modified a year ago
rpms/ plautrba/dokuwiki fix-selinux-requires  into  master

file modified
+8 -3

@@ -3,7 +3,7 @@ 

  

  Name:		dokuwiki

  Version:	0

- Release:	0.32.%{releasetag}%{?dist}

+ Release:	0.33.%{releasetag}%{?dist}

  Summary:	Standards compliant simple to use wiki

  Group:		Applications/Internet

  License:	GPLv2

@@ -30,8 +30,10 @@ 

  Summary:	SElinux support for dokuwiki

  Requires:	%name = %version-%release

  Requires:	policycoreutils

- %if 0%{?rhel} > 5 || 0%{?fedora} 

- Requires:	python2-policycoreutils

+ %if 0%{?rhel} && 0%{?rhel} <= 7

+ Requires: pylicycoreutils-python

+ %else

+ Requires: policycoreutils-python-utils

  %endif

  Group:		Applications/Internet

  BuildArch:	noarch

@@ -201,6 +203,9 @@ 

  %doc DOKUWIKI-SELINUX.README

  

  %changelog

+ * Fri Aug 10 2018 Petr Lautrbach <plautrba@redhat.com> - 0-0.33.20150810a

+ - update selinux sub-package to require the correct package with /usr/sbin/semanage

+ 

  * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0-0.32.20150810a

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

  

semanage lives in policycoreutils-python in Red Hat Enterprise Linux 7 and
lower, but it was moved to policycoreutils-python-utils in Fedora