495d882
%global srcname oauth2
495d882
# Erlang packages do not provide debug subpackages.
495d882
%global debug_package %{nil}
495d882
495d882
495d882
Name:       erlang-%{srcname}
c59c486
Version:    0.6.1
7a9a296
Release:    2%{?dist}
495d882
495d882
License:    MIT
7a9a296
Summary:    An Oauth2 implementation for Erlang
495d882
URL:        https://github.com/kivra/%{srcname}
495d882
Source0:    https://github.com/kivra/%{srcname}/archive/%{version}.tar.gz
495d882
495d882
BuildRequires: erlang-meck
495d882
BuildRequires: erlang-proper
495d882
BuildRequires: erlang-rebar
495d882
495d882
495d882
%description
495d882
This library is designed to simplify the implementation of the server side of
495d882
OAuth2.
495d882
495d882
495d882
%prep
c59c486
%autosetup -n %{srcname}-%{version}
495d882
495d882
495d882
%build
495d882
%rebar_compile
495d882
495d882
495d882
%check
495d882
%__rebar eunit
495d882
495d882
495d882
%install
495d882
install -d $RPM_BUILD_ROOT%{_erllibdir}/%{srcname}-%{version}/ebin
495d882
495d882
install -pm644 ebin/* $RPM_BUILD_ROOT%{_erllibdir}/%{srcname}-%{version}/ebin
495d882
495d882
495d882
%files
495d882
%license LICENSE
495d882
%doc README.md
495d882
%{_erllibdir}/%{srcname}-%{version}
495d882
495d882
495d882
%changelog
7a9a296
* Fri Mar 11 2016 Randy Barlow <rbarlow@redhat.com> - 0.6.1-2
7a9a296
- Rebuild to use the new automatic provides/requires build feature.
7a9a296
c59c486
* Tue Feb 16 2016 Randy Barlow <rbarlow@redhat.com> - 0.6.1-1
c59c486
- Update to 0.6.1.
c59c486
- Re-enable tests on i686.
c59c486
- Remove patch for Erlang 18 since it is fixed in this version.
c59c486
495d882
* Sun Feb 07 2016 Randy Barlow <rbarlow@redhat.com> - 0.6.0-4
495d882
- Added a patch from upstream commit f1e0cb05 to fix support for Erlang 18.
495d882
495d882
* Sat Jan 09 2016 Randy Barlow <rbarlow@redhat.com> - 0.6.0-3
495d882
- Do not run the tests on i686.
495d882
- Use the Erlang macros more effectively.
495d882
495d882
* Tue Jan 05 2016 Randy Barlow <rbarlow@redhat.com> - 0.6.0-2
495d882
- Remove the noarch target, as it causes the package to install outside the erts path.
495d882
- Add a Requires on erlang-erts.
495d882
495d882
* Sun Dec 27 2015 Randy Barlow <rbarlow@redhat.com> - 0.6.0-1
495d882
- Initial release.