be66d2 Apply upstream patch to filter virt-what warnings from virtual fact

Authored and Committed by tmz 6 years ago
    Apply upstream patch to filter virt-what warnings from virtual fact
    
    With the additional requirement of virt-what that was added in
    facter-1.6.18-1, the virtual fact was incorrect when facter was not run
    by root:
    
    $ facter | egrep '^(facterversion|virtual)'
    facterversion => 1.6.18
    virtual => virt-what: this script must be run as root
    
    This is upstream ticket #19989¹.  It was applied to the 1.7.x branch².
    
    ¹ https://projects.puppetlabs.com/issues/19989
    ² https://github.com/puppetlabs/facter/commit/b7784a3
    
        
file modified
+8 -1