Blame fedora-obsolete-packages.spec

f76112a
# Provenpackagers are welcome to modify this package, but please don't obsolete
f76112a
# additional packages without a corresponding bugzilla ticket being filed.
8da748e
8da748e
Name:       fedora-obsolete-packages
f76112a
# Please keep the version equal to the targeted Fedora release
4ff3369
Version:    28
b53866c
Release:    6
8da748e
Summary:    A package to obsolete retired packages
8da748e
8da748e
# This package has no actual content; there is nothing to license.
8da748e
License:    Public Domain
8da748e
URL:        https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages
8da748e
BuildArch:  noarch
8da748e
f76112a
Source0:    README
f76112a
f76112a
# Add Obsoletes: below, along with links to the relevant bugzilla tickets filed
f76112a
# against this package and the version in which the entry can be removed.
f76112a
#
60f7aa4
# All Obsoletes: entries must be versioned, with the version being the same as
60f7aa4
# or just higher than the last version-release of the obsoleted package.  This
60f7aa4
# allows the package to return to the distribution later.
f76112a
f76112a
# https://bugzilla.redhat.com/show_bug.cgi?id=1234567
f76112a
# Remove in f28
60f7aa4
# Obsoletes: foo <= 3.5-7
60f7aa4
60f7aa4
# https://bugzilla.redhat.com/show_bug.cgi?id=1451372
60f7aa4
# Remove in F29 to allow for F25->F26->F28 upgrades.
60f7aa4
Obsoletes: perl-ZeroMQ <= 0.23-13.fc25
60f7aa4
Obsoletes: perl-ZMQ-LibZMQ2 <= 1.09-9.fc25
60f7aa4
Obsoletes: perl-ZMQ-LibZMQ3 <= 1.19-5.fc25
60f7aa4
19dd4ad
# https://bugzilla.redhat.com/show_bug.cgi?id=1463408
19dd4ad
# Remove in F28 to allow for F24->F25->F27 upgrades
19dd4ad
Obsoletes: dap2rpm <= 0.1.11-5.fc25
19dd4ad
Obsoletes: devassistant <= 0.11.2-8.fc25
19dd4ad
Obsoletes: devassistant-cli <= 0.11.2-8.fc25
19dd4ad
Obsoletes: devassistant-core <= 0.11.2-8.fc25
19dd4ad
Obsoletes: devassistant-dap-c <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-common_args <= 0.10.0-10.fc25
19dd4ad
Obsoletes: devassistant-dap-cpp <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-custom <= 0.10.0-10.fc25
19dd4ad
Obsoletes: devassistant-dap-dap <= 1.3-4.fc25
19dd4ad
Obsoletes: devassistant-dap-devassistant <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-docker <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-eclipse <= 0.10.0dev-11.fc25
19dd4ad
Obsoletes: devassistant-dap-git <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-github <= 0.10.1-10.fc25
19dd4ad
Obsoletes: devassistant-dap-java <= 0.11.1-4.fc25
19dd4ad
Obsoletes: devassistant-dap-nodejs <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-openscad <= 0.0.3-4.fc25
19dd4ad
Obsoletes: devassistant-dap-perl <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-php <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-python <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-ruby <= 0.11-4.fc25
19dd4ad
Obsoletes: devassistant-dap-tito <= 0.10.0dev-9.fc25
19dd4ad
Obsoletes: devassistant-dap-vim <= 0.10.0dev-9.fc25
19dd4ad
Obsoletes: devassistant-devel <= 0.11.2-8.fc25
19dd4ad
Obsoletes: devassistant-gui <= 0.11.2-8.fc25
19dd4ad
Obsoletes: python-dap2rpm <= 0.1.11-5.fc25
19dd4ad
Obsoletes: python-dapp <= 0.3.0-6.fc25
19dd4ad
Obsoletes: python3-dapp <= 0.3.0-6.fc25
19dd4ad
Obsoletes: python3-dap2rpm <= 0.1.11-5.fc25
8da748e
b50e22b
# https://bugzilla.redhat.com/show_bug.cgi?id=1498850
b50e22b
# Remove in F28
c0fbfd7
Obsoletes: kdegraphics-strigi-analyzer < 16.04.90
c0fbfd7
Obsoletes: kfilemetadata < 4.14.3-10
c0fbfd7
Obsoletes: libkexiv2 < 15.08.3-10
c0fbfd7
Obsoletes: libkexiv2-devel < 15.08.3-10
b50e22b
Obsoletes: strigi <= 0.7.8-12.fc24
b50e22b
Obsoletes: strigi-libs <= 0.7.8-12.fc24
b50e22b
Obsoletes: strigi-devel <= 0.7.8-12.fc24
b50e22b
8a587f3
# https://bugzilla.redhat.com/show_bug.cgi?id=1443614
8a587f3
# Remove in F30, I guess? Package was current in F26
8a587f3
Obsoletes: webkitgtk < 2.4.12
8a587f3
Obsoletes: webkitgtk-devel < 2.4.12
8a587f3
Obsoletes: webkitgtk3 < 2.4.12
8a587f3
Obsoletes: webkitgtk3-devel < 2.4.12
8a587f3
961cb58
# Remove in F29
961cb58
Obsoletes: hawkey < 0.7
961cb58
Obsoletes: hawkey-devel < 0.7
961cb58
Obsoletes: python2-hawkey < 0.7
961cb58
Obsoletes: python3-hawkey < 0.7
961cb58
961cb58
# Remove in F29
961cb58
Obsoletes: libhif < 0.3
961cb58
Obsoletes: libhif-devel < 0.3
961cb58
ad60d01
# https://bugzilla.redhat.com/show_bug.cgi?id=1423813
bdf1dfc
# Remove in F29
bdf1dfc
Obsoletes: kf5-libkface < 16.08.90
bdf1dfc
Obsoletes: kf5-libkface-devel < 16.08.90
bdf1dfc
464dc5d
# Remove in F30
464dc5d
Obsoletes: seed < 3.9
464dc5d
Obsoletes: seed-devel < 3.9
464dc5d
144fec7
# Remove in F29
144fec7
Obsoletes: compat-gnutls28 < 3.3.21
144fec7
144fec7
# Remove in F29
144fec7
Obsoletes: libsilc < 1.1.10
144fec7
Obsoletes: libsilc-doc < 1.1.10
144fec7
Obsoletes: libsilc-devel < 1.1.10
144fec7
144fec7
# Remove in F29
144fec7
Obsoletes: pam_pkcs11 < 0.6.8
144fec7
144fec7
# Remove in F29
144fec7
Obsoletes: python-dapp < 0.3.0
144fec7
Obsoletes: python3-dapp < 0.3.0
144fec7
4ff3369
# Remove in F30
4ff3369
Obsoletes: compat-ImageMagick693-c++ < 6.9.4
4ff3369
Obsoletes: compat-ImageMagick693-libs < 6.9.4
4ff3369
Obsoletes: compat-libvpx1 < 1.4.0
4ff3369
ac71a72
# Remove in F30
ac71a72
Obsoletes: xulrunner < 46
ac71a72
Obsoletes: xulrunner-devel < 46
ac71a72
444bc6d
# Remove in F31
444bc6d
Obsoletes: python2-zeroconf < 0.20.0
444bc6d
Obsoletes: python2-chromecast < 2.0.0
b1c8c36
Obsoletes: bind99-license < 9.9.11-5
b1c8c36
Obsoletes: bind99-libs < 9.9.11-5
b1c8c36
Obsoletes: bind99-devel < 9.9.11-5
444bc6d
Obsoletes: mozjs17 < 18
b1c8c36
Obsoletes: mozjs17-devel < 18
444bc6d
1309464
# Remove in F31
b53866c
# https://bugzilla.redhat.com/show_bug.cgi?id=1568670
b53866c
Obsoletes: caribou < 0.4.21-10
b53866c
Obsoletes: caribou-antler < 0.4.21-10
b53866c
Obsoletes: caribou-devel < 0.4.21-10
b53866c
Obsoletes: caribou-gtk2-module < 0.4.21-10
b53866c
Obsoletes: caribou-gtk3-module < 0.4.21-10
b53866c
Obsoletes: python2-caribou < 0.4.21-10
b53866c
Obsoletes: python3-caribou < 0.4.21-10
1309464
8da748e
%description
8da748e
This package exists only to obsolete other packages which need to be removed
8da748e
from the distribution for some reason.
8da748e
60f7aa4
Current obsoleted packages:
60f7aa4
  perl-ZeroMQ <= 0.23-13.fc25
60f7aa4
  perl-ZMQ-LibZMQ2 <= 1.09-9.fc25
60f7aa4
  perl-ZMQ-LibZMQ3 <= 1.19-5.fc25
19dd4ad
  (See https://bugzilla.redhat.com/show_bug.cgi?id=1451372)
19dd4ad
19dd4ad
  dap2rpm <= 0.1.11-5.fc25
19dd4ad
  devassistant-cli <= 0.11.2-8.fc25
19dd4ad
  devassistant-core <= 0.11.2-8.fc25
19dd4ad
  devassistant-dap-common_args <= 0.10.0-10.fc25
19dd4ad
  devassistant-dap-cpp <= 0.11-4.fc25
19dd4ad
  devassistant-dap-custom <= 0.10.0-10.fc25
19dd4ad
  devassistant-dap-c <= 0.11-4.fc25
19dd4ad
  devassistant-dap-dap-1.3-4.fc25
19dd4ad
  devassistant-dap-devassistant <= 0.11-4.fc25
19dd4ad
  devassistant-dap-docker <= 0.11-4.fc25
19dd4ad
  devassistant-dap-eclipse <= 0.10.0dev-11.fc25
19dd4ad
  devassistant-dap-github <= 0.10.1-10.fc25
19dd4ad
  devassistant-dap-git <= 0.11-4.fc25
19dd4ad
  devassistant-dap-java <= 0.11.1-4.fc25
19dd4ad
  devassistant-dap-nodejs <= 0.11-4.fc25
19dd4ad
  devassistant-dap-openscad <= 0.0.3-4.fc25
19dd4ad
  devassistant-dap-perl <= 0.11-4.fc25
19dd4ad
  devassistant-dap-php <= 0.11-4.fc25
19dd4ad
  devassistant-dap-python <= 0.11-4.fc25
19dd4ad
  devassistant-dap-ruby <= 0.11-4.fc25
19dd4ad
  devassistant-dap-tito <= 0.10.0dev-9.fc25
19dd4ad
  devassistant-dap-vim <= 0.10.0dev-9.fc25
19dd4ad
  devassistant-devel <= 0.11.2-8.fc25
19dd4ad
  devassistant-gui <= 0.11.2-8.fc25
19dd4ad
  devassistant <= 0.11.2-8.fc25
19dd4ad
  python-dapp <= 0.3.0-6.fc25
19dd4ad
  python-dap2rpm <= 0.1.11-5.fc25
19dd4ad
  python3-dapp <= 0.3.0-6.fc25
19dd4ad
  python3-dap2rpm <= 0.1.11-5.fc25
19dd4ad
  (See https://bugzilla.redhat.com/show_bug.cgi?id=1463408)
60f7aa4
8a587f3
  webkitgtk < 2.4.12
8a587f3
  webkitgtk-devel < 2.4.12
8a587f3
  webkitgtk3 < 2.4.12
8a587f3
  webkitgtk3-devel < 2.4.12
8a587f3
  (See https://bugzilla.redhat.com/show_bug.cgi?id=1443614)
8a587f3
c0fbfd7
  kdegraphics-strigi-analyzer < 16.04.90
c0fbfd7
  kfilemetadata < 4.14.3-10
b50e22b
  libkexiv2 <= 15.08.3-2.fc24
c0fbfd7
  strigi <= 0.7.8-12.fc24
b50e22b
  (See https://bugzilla.redhat.com/show_bug.cgi?id=1498850)
b50e22b
bdf1dfc
  kf5-libkface < 16.08.90
bdf1dfc
  (See https://bugzilla.redhat.com/show_bug.cgi?id=1423813)
bdf1dfc
60f7aa4
f76112a
%prep
f76112a
%autosetup -c -T
f76112a
cp %SOURCE0 .
f76112a
19dd4ad
8da748e
%files
f76112a
%doc README
8da748e
19dd4ad
8da748e
%changelog
b53866c
* Mon May 07 2018 Pete Walter <pwalter@fedoraproject.org> - 28-6
b53866c
- Obsolete python2-caribou and python3-caribou as well (#1568670)
b53866c
1309464
* Fri May 04 2018 Pete Walter <pwalter@fedoraproject.org> - 28-5
1309464
- Obsolete old caribou versions (#1568670)
1309464
b1c8c36
* Thu Apr 12 2018 Kalev Lember <klember@redhat.com> - 28-4
b1c8c36
- Fix bind99 obsoletes versions, obsolete mozjs17-devel
b1c8c36
444bc6d
* Thu Apr 12 2018 Peter Robinson <pbrobinson@fedoraproject.org> 28-3
444bc6d
- bind99, mozjs17, python2-zeroconf, python2-chromecast
444bc6d
ac71a72
* Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 28-2
ac71a72
- Add xulrunner obsoletes
ac71a72
4ff3369
* Mon Nov 13 2017 Pete Walter <pwalter@fedoraproject.org> - 28-1
4ff3369
- Obsolete compat-ImageMagick693, compat-libvpx1
4ff3369
144fec7
* Wed Nov  8 2017 Peter Robinson <pbrobinson@fedoraproject.org> 27-10
144fec7
- Obsolete  compat-gnutls28, libsilc, pam_pkcs11, python-dapp
144fec7
c0fbfd7
* Fri Oct 13 2017 Rex Dieter <rdieter@fedoraproject.org> - 27-9
c0fbfd7
- Obsoletes: kdegraphics-strigi-analyzer kfilemetadata
c0fbfd7
- bump libkexiv2 version
c0fbfd7
bdf1dfc
* Sat Oct 07 2017 Rex Dieter <rdieter@fedoraproject.org> - 27-8
bdf1dfc
- Obsolets: kf5-libkface (#1423813)
bdf1dfc
b50e22b
* Sat Oct 07 2017 Rex Dieter <rdieter@fedoraproject.org> - 27-7
b50e22b
- Obsoletes: strigi, libkexiv2 (#1498850)
b50e22b
464dc5d
* Tue Aug 29 2017 Kalev Lember <klember@redhat.com> - 27-6
464dc5d
- Add seed obsoletes
464dc5d
961cb58
* Tue Aug 29 2017 Kalev Lember <klember@redhat.com> - 27-5
961cb58
- Add hawkey and libhif obsoletes
961cb58
8c1cc51
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 27-4
8c1cc51
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
8c1cc51
8a587f3
* Tue Jul 11 2017 Adam Williamson <awilliam@redhat.com> - 27-3
8a587f3
- Add webkitgtk and webkitgtk3 (and -devel) - RHBZ #1443614
8a587f3
19dd4ad
* Wed Jun 21 2017 Jason L Tibbitts III <tibbs@math.uh.edu> - 27-2
19dd4ad
- Add various devassistant-related packages from https://bugzilla.redhat.com/show_bug.cgi?id=1463408
19dd4ad
60f7aa4
* Tue May 16 2017 Jason L Tibbitts III <tibbs@math.uh.edu> - 27-1
60f7aa4
- Add perl ZMQ packages from https://bugzilla.redhat.com/show_bug.cgi?id=1451372
60f7aa4
3d2879a
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 26-2
3d2879a
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
3d2879a
8da748e
* Wed Sep 14 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 26-1
8da748e
- Initial release; nothing to obsolete yet.