Blame fedora-obsolete-packages.spec

f76112
# Provenpackagers are welcome to modify this package, but please don't obsolete
f76112
# additional packages without a corresponding bugzilla ticket being filed.
8da748
8da748
Name:       fedora-obsolete-packages
f76112
# Please keep the version equal to the targeted Fedora release
8da748
Version:    26
633aef
Release:    4
8da748
Summary:    A package to obsolete retired packages
8da748
8da748
# This package has no actual content; there is nothing to license.
8da748
License:    Public Domain
8da748
URL:        https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages
8da748
BuildArch:  noarch
8da748
f76112
Source0:    README
f76112
f76112
# Add Obsoletes: below, along with links to the relevant bugzilla tickets filed
f76112
# against this package and the version in which the entry can be removed.
f76112
#
f76112
# All Obsoletes: entries must be versioned, with the version being just higher
f76112
# than the last version-release of the obsoleted package.  This allows the
f76112
# package to return to the distribution later.
f76112
f76112
# https://bugzilla.redhat.com/show_bug.cgi?id=1234567
f76112
# Remove in f28
384e9d
# Obsoletes: foo <= 3.5-7
384e9d
384e9d
# https://bugzilla.redhat.com/show_bug.cgi?id=1463408
384e9d
# Remove in F28 to allow for F24->F25->F27 upgrades
384e9d
Obsoletes: dap2rpm <= 0.1.11-5.fc25
384e9d
Obsoletes: devassistant <= 0.11.2-8.fc25
384e9d
Obsoletes: devassistant-cli <= 0.11.2-8.fc25
384e9d
Obsoletes: devassistant-core <= 0.11.2-8.fc25
384e9d
Obsoletes: devassistant-dap-c <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-common_args <= 0.10.0-10.fc25
384e9d
Obsoletes: devassistant-dap-cpp <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-custom <= 0.10.0-10.fc25
384e9d
Obsoletes: devassistant-dap-dap <= 1.3-4.fc25
384e9d
Obsoletes: devassistant-dap-devassistant <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-docker <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-eclipse <= 0.10.0dev-11.fc25
384e9d
Obsoletes: devassistant-dap-git <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-github <= 0.10.1-10.fc25
384e9d
Obsoletes: devassistant-dap-java <= 0.11.1-4.fc25
384e9d
Obsoletes: devassistant-dap-nodejs <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-openscad <= 0.0.3-4.fc25
384e9d
Obsoletes: devassistant-dap-perl <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-php <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-python <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-ruby <= 0.11-4.fc25
384e9d
Obsoletes: devassistant-dap-tito <= 0.10.0dev-9.fc25
384e9d
Obsoletes: devassistant-dap-vim <= 0.10.0dev-9.fc25
384e9d
Obsoletes: devassistant-devel <= 0.11.2-8.fc25
384e9d
Obsoletes: devassistant-gui <= 0.11.2-8.fc25
384e9d
Obsoletes: python-dap2rpm <= 0.1.11-5.fc25
384e9d
Obsoletes: python-dapp <= 0.3.0-6.fc25
384e9d
Obsoletes: python3-dapp <= 0.3.0-6.fc25
384e9d
Obsoletes: python3-dap2rpm <= 0.1.11-5.fc25
384e9d
633aef
# Remove in F29
633aef
Obsoletes: kf5-libkface < 16.08.90
633aef
Obsoletes: kf5-libkface-devel < 16.08.90
633aef
8da748
8da748
%description
8da748
This package exists only to obsolete other packages which need to be removed
8da748
from the distribution for some reason.
8da748
384e9d
Current obsoleted packages:
384e9d
  dap2rpm <= 0.1.11-5.fc25
384e9d
  devassistant-cli <= 0.11.2-8.fc25
384e9d
  devassistant-core <= 0.11.2-8.fc25
384e9d
  devassistant-dap-common_args <= 0.10.0-10.fc25
384e9d
  devassistant-dap-cpp <= 0.11-4.fc25
384e9d
  devassistant-dap-custom <= 0.10.0-10.fc25
384e9d
  devassistant-dap-c <= 0.11-4.fc25
384e9d
  devassistant-dap-dap-1.3-4.fc25
384e9d
  devassistant-dap-devassistant <= 0.11-4.fc25
384e9d
  devassistant-dap-docker <= 0.11-4.fc25
384e9d
  devassistant-dap-eclipse <= 0.10.0dev-11.fc25
384e9d
  devassistant-dap-github <= 0.10.1-10.fc25
384e9d
  devassistant-dap-git <= 0.11-4.fc25
384e9d
  devassistant-dap-java <= 0.11.1-4.fc25
384e9d
  devassistant-dap-nodejs <= 0.11-4.fc25
384e9d
  devassistant-dap-openscad <= 0.0.3-4.fc25
384e9d
  devassistant-dap-perl <= 0.11-4.fc25
384e9d
  devassistant-dap-php <= 0.11-4.fc25
384e9d
  devassistant-dap-python <= 0.11-4.fc25
384e9d
  devassistant-dap-ruby <= 0.11-4.fc25
384e9d
  devassistant-dap-tito <= 0.10.0dev-9.fc25
384e9d
  devassistant-dap-vim <= 0.10.0dev-9.fc25
384e9d
  devassistant-devel <= 0.11.2-8.fc25
384e9d
  devassistant-gui <= 0.11.2-8.fc25
384e9d
  devassistant <= 0.11.2-8.fc25
384e9d
  python-dapp <= 0.3.0-6.fc25
384e9d
  python-dap2rpm <= 0.1.11-5.fc25
384e9d
  python3-dapp <= 0.3.0-6.fc25
384e9d
  python3-dap2rpm <= 0.1.11-5.fc25
384e9d
  (See https://bugzilla.redhat.com/show_bug.cgi?id=1463408)
384e9d
633aef
  kf5-libkface < 16.08.90
633aef
  (See https://bugzilla.redhat.com/show_bug.cgi?id=1423813)
633aef
384e9d
f76112
%prep
f76112
%autosetup -c -T
f76112
cp %SOURCE0 .
f76112
8da748
%files
f76112
%doc README
8da748
8da748
%changelog
633aef
* Sat Oct 07 2017 Rex Dieter <rdieter@fedoraproject.org> - 26-4
633aef
- Obsoletes: kf5-libkface (#1423813)
633aef
384e9d
* Wed Jun 21 2017 Jason L Tibbitts III <tibbs@math.uh.edu> - 26-3
384e9d
- Add various devassistant-related packages from
384e9d
  https://bugzilla.redhat.com/show_bug.cgi?id=1463408
384e9d
3d2879
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 26-2
3d2879
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
3d2879
8da748
* Wed Sep 14 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 26-1
8da748
- Initial release; nothing to obsolete yet.