Blob Blame History Raw
# Provenpackagers are welcome to modify this package, but please don't obsolete
# additional packages without a corresponding bugzilla ticket being filed.

# Please remember to add all of the necessary information.  See below the
# Source0: line for a description of the format.  It is important that
# everything be included; yanking packages from an end-user system is "serious
# business" and should not be done lightly or without making everything as
# clear as possible.

# Finally, please keep python2 obsoletes together, since there is bound to be a
# significant number of them.

Name:       fedora-obsolete-packages
# Please keep the version equal to the targeted Fedora release
Version:    32
Release:    12
Summary:    A package to obsolete retired packages

# This package has no actual content; there is nothing to license.
License:    Public Domain
URL:        https://docs.fedoraproject.org/en-US/packaging-guidelines/#renaming-or-replacing-existing-packages
BuildArch:  noarch

Source0:    README

# ===============================================================================
# Skip down below these convenience macros
%define obsolete_ticket() %{lua:
    local ticket = rpm.expand('%1')

    -- May need to declare the master structure
    if type(obs) == 'nil' then
        obs = {}
    end

    if ticket == '%1' then
        rpm.expand('%{error:No ticket provided to obsolete_ticket}')
    end

    if ticket == 'Ishouldfileaticket' then
        ticket = nil
    end

    -- Declare a new set of obsoletes
    local index = #obs+1
    obs[index] = {}
    obs[index].ticket = ticket
    obs[index].list = {}
}

%define obsolete() %{lua:
    local pkg = rpm.expand('%1')
    local ver = rpm.expand('%2')

    if pkg == '%1' then
        rpm.expand('%{error:No package name provided to obsolete}')
    end
    if ver == '%2' then
        rpm.expand('%{error:No version provided to obsolete}')
    end

    if not string.find(ver, '-') then
        rpm.expand('%{error:You must provide a version-release, not just a version.}')
    end

    local o = pkg .. ' < ' .. ver
    print('Obsoletes: ' .. o)

    -- Append this obsolete to the last set of obsoletes in the list
    local list = obs[#obs].list
    list[#list+1] = o
}

# Don't use this macro!  Only here because people keep doing this wrong.
%define obsolete_wrong() %{lua:
    local pkg = rpm.expand('%1')
    local ver = rpm.expand('%2')

    if pkg == '%1' then
        rpm.expand('%{error:No package name provided to obsolete}')
    end
    if ver == '%2' then
        rpm.expand('%{error:No version provided to obsolete}')
    end

    local o = pkg .. ' < ' .. ver
    print('Obsoletes: ' .. o)

    -- Append this obsolete to the last set of obsoletes in the list
    local list = obs[#obs].list
    list[#list+1] = o
}


%define list_obsoletes %{lua:
    local i
    local j
    for i = 1,#obs do
        if obs[i].ticket ~= nil and string.find(obs[i].ticket, '1578359') then
            print('Plus the following python2 packages, in accordance with the general switch away\\n')
            print('from Python2 ahead of its retirement in 2020.  See\\n')
            print('https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3 for more\\n')
            print('information.\\n\\n')
        end

        for j = 1,#obs[i].list do
            print('  ' .. obs[i].list[j] .. '\\n')
        end
        if obs[i].ticket == nil then
            print('  (No ticket was provided!)\\n\\n')
        else
            print('  (See ' .. obs[i].ticket .. ')\\n\\n')
        end
    end
}

# ===============================================================================
# Add calls to the obsolete_ticket and obsolete macros below, along with a note
# indicating the Fedora version in which the entries can be removed.  This is
# generally three releases beyond whatever release Rawhide is currently.  The
# macros make this easy, and will automatically update the package description.

# The ticket information is important.  Please don't add things here without
# having a filed ticket, preferrably in bugzilla.

# All Obsoletes: entries MUST be versioned (including the release), with the
# version being the same as or just higher than the last version-release of the
# obsoleted package.  This allows the package to return to the distribution
# later.  The best possible thing to do is to find the last version-release
# which was in the distribution, add one to the release, and add that version
# without using a dist tag.  This allows a rebuild with a bumped Release: to be
# installed.

# And don't forget to update the package description!


# Template:
# Remove in F33
# %%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1234567
# %%obsolete foo 3.5-7

# ========================================
# Please place non-python2 Obsoletes: here
# ========================================

# Remove in F33: retired in F30
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1747428
%obsolete gegl 0.2.0-41

# Remove in F33: retired in F31
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1702954
%obsolete california 0.4.0-19

# Remove in F33: retired in F30+
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1700073
%obsolete mongodb 4.0.3-4
%obsolete mongodb-server 4.0.3-4
%obsolete mongodb-test 4.0.3-4

# Remove in F33; retired in F30+
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1696965
%obsolete appcenter 3.1.1-2
%obsolete appcenter-gnome-shell-search-provider 3.1.1-2

# Remove in F33
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1680068
%obsolete empathy 3.12.14-9

# Remove in F33
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1707567
%obsolete yumex 3.0.17-3

# Remove in F33
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1707570
%obsolete pix 1.8.2-2

# Remove in F33
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1707577
%obsolete system-config-services 0.111.4-4

# Remove in F33
%obsolete_ticket https://src.fedoraproject.org/rpms/gedit-plugins/pull-request/1
%obsolete gedit-plugin-synctex 3.33.90-1

# Remove in F33: retired in F30
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1644813
%obsolete fedmsg-notify 0.5.9-10

# Remove in F33: retired in F31
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1747430
%obsolete gcompris 15.11-1
%obsolete gcompris-administration 15.11-1
%obsolete gcompris-sound-af 15.11-1
%obsolete gcompris-sound-ar 15.11-1
%obsolete gcompris-sound-ast 15.11-1
%obsolete gcompris-sound-bg 15.11-1
%obsolete gcompris-sound-br 15.11-1
%obsolete gcompris-sound-ca 15.11-1
%obsolete gcompris-sound-cs 15.11-1
%obsolete gcompris-sound-da 15.11-1
%obsolete gcompris-sound-de 15.11-1
%obsolete gcompris-sound-el 15.11-1
%obsolete gcompris-sound-en 15.11-1
%obsolete gcompris-sound-eo 15.11-1
%obsolete gcompris-sound-es 15.11-1
%obsolete gcompris-sound-eu 15.11-1
%obsolete gcompris-sound-fi 15.11-1
%obsolete gcompris-sound-fr 15.11-1
%obsolete gcompris-sound-gd 15.11-1
%obsolete gcompris-sound-he 15.11-1
%obsolete gcompris-sound-hi 15.11-1
%obsolete gcompris-sound-hu 15.11-1
%obsolete gcompris-sound-id 15.11-1
%obsolete gcompris-sound-it 15.11-1
%obsolete gcompris-sound-kn 15.11-1
%obsolete gcompris-sound-lt 15.11-1
%obsolete gcompris-sound-mr 15.11-1
%obsolete gcompris-sound-nb 15.11-1
%obsolete gcompris-sound-nl 15.11-1
%obsolete gcompris-sound-nn 15.11-1
%obsolete gcompris-sound-pa 15.11-1
%obsolete gcompris-sound-pt 15.11-1
%obsolete gcompris-sound-ru 15.11-1
%obsolete gcompris-sound-sk 15.11-1
%obsolete gcompris-sound-sl 15.11-1
%obsolete gcompris-sound-so 15.11-1
%obsolete gcompris-sound-sr 15.11-1
%obsolete gcompris-sound-sv 15.11-1
%obsolete gcompris-sound-th 15.11-1
%obsolete gcompris-sound-tr 15.11-1
%obsolete gcompris-sound-ur 15.11-1
%obsolete gcompris-sound-zh_CN 15.11-1

# Remove in F34
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1725789
%obsolete python3-importlib-metadata 0.18-4

# ==========================================
# Please collect the python2 Obsoletes: here
# ==========================================

# Remove in F33; retired in F31+
%obsolete_ticket https://bugzilla.redhat.com/show_bug.cgi?id=1578359
%obsolete autocloud-backend 0.8.0-6
%obsolete autocloud-common 0.8.0-6
%obsolete autocloud-web 0.8.0-6
%obsolete bkchem 0.14.0-21
%obsolete bmpanel2-cfg 2.1-0.24
%obsolete bpython 0.17.1-6
%obsolete broctl 2.5.4-5
%obsolete bugyou_plugins 0.1.6-6
%obsolete cas 1.0-15
%obsolete catkin 0.4.5-20
%obsolete childsplay 1.6-30
%obsolete cwiid-python2 0.6.00-30
%obsolete darkserver 2.0-6
%obsolete darkserver-importer 2.0-6
%obsolete dreampie 1.1.1-18
%obsolete driconf 0.9.1-31
%obsolete emacs-pymacs 0.25-9
%obsolete fedocal 0.16-3
%obsolete fedora-motd 0.1.2-7
%obsolete firmware-tools 2.1.15-6
%obsolete flr 0.0.4-8
%obsolete fwbackups 1.43.7-7
%obsolete fwfstab 0.04-0.17
%obsolete galternatives 0.13.4-27
%obsolete genbackupdata 1.9-10
%obsolete github2fedmsg 0.3.6-10
%obsolete gitifyhg 0.8.4-13
%obsolete gnome-activity-journal 0.8.0-15
%obsolete gnue-common 0.6.9-17
%obsolete gofed-gofedlib 1.0.0-0.23
%obsolete gofed-infra 1.0.0-0.23
%obsolete gofed-resources  1.0.0-0.23
%obsolete googsystray 1.3.1-14
%obsolete gscribble 0.1.2-17
%obsolete gwsmhg 0.13.2-16
%obsolete hamster-time-tracker 2.0-0.17
%obsolete igor 0.4.1-12
%obsolete igor-client 0.4.1-12
%obsolete igor-common 0.4.1-12
%obsolete kimchi 1.5.1-12
%obsolete labyrinth 0.6-17
%obsolete loggerhead 1.18.2-10
%obsolete londonlaw 0.3.0-0.13
%obsolete loopabull 0.0.6-7
%obsolete mash 0.6.19-9
%obsolete memaker 20100110-20
%obsolete meta-test-family 0.8.0-5
%obsolete modularity-testing-framework 0.5.1-6
%obsolete mysql-utilities 1.5.6-8
%obsolete nagios-plugins-lfc 0.9.6-10
%obsolete nagstamon 1.0.1-8
%obsolete nautilus-pastebin 0.7.2-10
%obsolete nested 1.2.2-23
%obsolete ninja-ide 2.3-10
%obsolete nordugrid-arc-acix-cache 5.4.4-2
%obsolete nordugrid-arc-gangliarc 1.0.2-8
%obsolete nxt_python 2.2.2-7
%obsolete obmenu 1.0-29
%obsolete ocfs2console 1.8.5-11
%obsolete oggconvert 0.3.3-22
%obsolete openteacher 3.2-13
%obsolete pdc-updater 0.9.3-3
%obsolete pkpgcounter 3.50-18
%obsolete pmpu 0.2-20
%obsolete pondus 0.8.0-15
%obsolete pycam 0.5.1-12
%obsolete pyfribidi 0.11.0-19
%obsolete pygtkglext 1.1.0-31
%obsolete pygtksourceview 2.10.1-19
%obsolete pykde4 4.14.3-31
%obsolete pyliblzma 0.5.3-26
%obsolete PyPE 2.9.4-12
%obsolete PyQwt 5.2.0-43
%obsolete pyroom 0.4.1-20
%obsolete python2-ahkab 0.18-15
%obsolete python2-amara 1.2.0.2-25
%obsolete python2-amqp 2.4.1-2
%obsolete python2-anymarkup 0.5.0-13
%obsolete python2-anymarkup-core 0.5.0-14
%obsolete python2-anyvc 0.3.7.1-16
%obsolete python2-apsw 3.24.0.r1-3
%obsolete python2-ase 3.16.2-6
%obsolete python2-autobahn 19.3.2-2
%obsolete python2-backports-unittest_mock 1.2.1-8
%obsolete python2-betamax 0.8.1-5
%obsolete python2-Bottleneck 1.2.1-9
%obsolete python2-breathe 4.7.3-7
%obsolete python2-broccoli 2.5.4-5
%obsolete python2-cairosvg 1.0.20-1
%obsolete python2-carddav 0.7.0-13
%obsolete python2-case 1.5.2-10
%obsolete python2-catkin-sphinx 0.2.2-13
%obsolete python2-celery 4.2.1-5
%obsolete python2-cliapp 1.20180121-2
%obsolete python2-cliff 2.13.0-3
%obsolete python2-cmdsignature 1.0.0-0.23
%obsolete python2-cmusphinx3 0.8-33
%obsolete python2-copr 1.90-2
%obsolete python2-coveralls 1.2.0-7
%obsolete python2-cracklib 2.9.6-20
%obsolete python2-curtsies 0.3.0-5
%obsolete python2-datanommer-models 0.9.1-7
%obsolete python2-dbusmock 0.17-8
%obsolete python2-deltarpm 3.6-30
%obsolete python2-deprecation 2.0.6-2
%obsolete python2-docker 3.5.0-2
%obsolete python2-dropbox 9.4.0-2
%obsolete python2-egenix-mx-base 3.2.9-9
%obsolete python2-elfdata 0.6-11
%obsolete python2-fabric3 1.13.1-9
%obsolete python2-factory-boy 2.11.1-5
%obsolete python2-falcon 1.4.1-7
%obsolete python2-fedmsg 1.1.1-5
%obsolete python2-flask-openid 1.2.5-14
%obsolete python2-flickrapi 2.2.1-6
%obsolete python2-fmn 2.1.1-4
%obsolete python2-fmn-lib 0.8.2-9
%obsolete python2-future 0.17.0-3
%obsolete python2-gamin 0.1.10-34
%obsolete python2-gencpp 0.3.4-15
%obsolete python2-genlisp 0.3.3-15
%obsolete python2-genpy 0.3.7-17
%obsolete python2-gerritlib 0.6.0-9
%obsolete python2-gerrit-view 0.3.2-12
%obsolete python2-gertty 1.5.0-6
%obsolete python2-gitdb 2.0.3-6
%obsolete python2-GitPython 2.1.11-3
%obsolete python2-google-api-client 1:1.6.7-7
%obsolete python2-gpaw 1.4.0-11
%obsolete python2-gpg 1.12.0-2
%obsolete python2-grokmirror 1.1.1-2
%obsolete python2-hacking 1.1.0-6
%obsolete python2-hardware 0.18-13
%obsolete python2-hardware-detect 0.18-13
%obsolete python2-intervaltree 2.1.0-5
%obsolete python2-jedi 0.12.1-4
%obsolete python2-jenkins 0.4.15-7
%obsolete python2-jenkins-job-builder 1:2.1.0-3
%obsolete python2-jsonpath-rw 1.2.3-19
%obsolete python2-jsonpath-rw-ext 1.2.0-2
%obsolete python2-jsonschema 2.6.0-10
%obsolete python2-keystoneauth1 3.4.0-4
%obsolete python2-kickstart 3.20-3
%obsolete python2-koji 1.17.0-6
%obsolete python2-koji-cli-plugins 1.17.0-6
%obsolete python2-koji-containerbuild-cli 0.7.13.1-2
%obsolete python2-kombu 1:4.2.2-3
%obsolete python2-langtable 0.0.43-4
%obsolete python2-larch 1.20151025-10
%obsolete python2-lazr-smtptest 2.0.3-10
%obsolete python2-libemu 0.2.0-11
%obsolete python2-libguestfs 1:1.40.2-5
%obsolete python2-libiptcdata 1.0.4-21
%obsolete python2-libmodulemd 2.6.0-2
%obsolete python2-librtfcomp 1.1-27
%obsolete python2-libselinux 2.9-5
%obsolete python2-libsemanage 2.9-3
%obsolete python2-libturpial 1.7.0-12
%obsolete python2-libvirt 5.1.0-3
%obsolete python2-lldb 8.0.0-2
%obsolete python2-lunatic 1.0.1-0.26
%obsolete python2-lz4 2.1.2-3
%obsolete python2-mandrill 1.0.51-14
%obsolete python2-markdown 2.6.11-6
%obsolete python2-matplotlib-gtk 2.2.4-3
%obsolete python2-matplotlib-gtk3 2.2.4-3
%obsolete python2-matplotlib-qt4 2.2.4-3
%obsolete python2-matplotlib-qt5 2.2.4-3
%obsolete python2-moksha-hub 1.5.17-2
%obsolete python2-mox3 0.17.0-9
%obsolete python2-mpi4py-mpich 3.0.1-2
%obsolete python2-mpi4py-openmpi 3.0.1-2
%obsolete python2-multilib 1.2-8
%obsolete python2-ndg_httpsclient 0.4.0-14
%obsolete python2-neo4j-driver 1.6.2-3
%obsolete python2-neomodel 3.3.1-2
%obsolete python2-nose-cover3 0.1.0-24
%obsolete python2-nose-progressive 1.5.1-16
%obsolete python2-nose-xcover 1.0.11-3
%obsolete python2-nototools 0-0.20190710
%obsolete python2-nss 1.0.1-15
%obsolete python2-numexpr 2.6.6-3
%obsolete python2-numpydoc 0.8.0-6
%obsolete python2-openstacksdk 0.12.0-4
%obsolete python2-pandas 0.23.4-3
%obsolete python2-pandas-datareader 0.6.0-7
%obsolete python2-policycoreutils 2.9-2
%obsolete python2-postman 0.6.0-17
%obsolete python2-praw 3.6.2-3
%obsolete python2-psphere 0.5.2-16
%obsolete python2-pudb 2017.1.4-5
%obsolete python2-pungi 4.1.38-2
%obsolete python2-pwquality 1.4.0-13
%obsolete python2-pyaff 3.7.18-3
%obsolete python2-pyaudio 0.2.11-3
%obsolete python2-PyDrive 1.3.1-8
%obsolete python2-pyfakefs 3.1-7
%obsolete python2-pykafka 2.6.0-0.6
%obsolete python2-pylibravatar 1.6-20
%obsolete python2-pypam 0.5.0-41
%obsolete python2-pypump 0.6-14
%obsolete python2-pytest-cache 1.0-17
%obsolete python2-pytest-catchlog 1.2.2-12
%obsolete python2-pytest-forked 1.0.2-3
%obsolete python2-pytest-pep8 1.0.6-18
%obsolete python2-pytest-shutil 1.2.6-7
%obsolete python2-pytest-timeout 1.3.3-5
%obsolete python2-pytest-tornado 0.8.0-2
%obsolete python2-pytest-vcr 1.0.1-2
%obsolete python2-pytest-virtualenv 1.2.11-11
%obsolete python2-pytest-watch 4.1.0-12
%obsolete python2-pytest-xdist 1.29.0-3
%obsolete python2-qt5-webengine 5.12.1-6
%obsolete python2-rapi 0.15.2-17
%obsolete python2-raven 6.9.0-5
%obsolete python2-requests_ntlm 1.1.0-5
%obsolete python2-requests-toolbelt 0.9.1-2
%obsolete python2-rhev 1.0-16
%obsolete python2-root 6.18.00-4
%obsolete python2-rosinstall 0.7.8-5
%obsolete python2-routes 2.4.1-9
%obsolete python2-rpyc 4.0.1-4
%obsolete python2-rra 0.14-20
%obsolete python2-sanlock 3.6.0-9
%obsolete python2-setools 4.1.1-15
%obsolete python2-snappy 0.5.3-3
%obsolete python2-snowballstemmer 1.2.1-11
%obsolete python2-sphinx 1:2.0.0~b1-2
%obsolete python2-sphinxcontrib-httpdomain 1.7.0-5
%obsolete python2-sphinxcontrib-websupport 1.1.0-2
%obsolete python2-sphinx-intl 0.9.11-7
%obsolete python2-sphinx_rtd_theme 0.4.3-3
%obsolete python2-sphinx-theme-alabaster 0.7.12-5
%obsolete python2-sphinxtrain 1.0.8-47
%obsolete python2-sqlalchemy-utils 0.32.12-10
%obsolete python2-squaremap 1.0.3-12
%obsolete python2-stevedore 1.28.0-3
%obsolete python2-stomper 0.4.1-11
%obsolete python2-stomppy 4.1.21-3
%obsolete python2-subvertpy 0.10.1-6
%obsolete python2-tables 3.4.4-5
%obsolete python2-tahrir 0.9.2-7
%obsolete python2-tahrir-api 0.8.1-10
%obsolete python2-tornado 5.0.2-6
%obsolete python2-totpcgi 0.5.5-19
%obsolete python2-trollius 2.1-11
%obsolete python2-tw2-core 2.2.3-14
%obsolete python2-tw2-dynforms 2.0.1-18
%obsolete python2-tw2-excanvas 2.0.2-16
%obsolete python2-tw2-jit 2.0.3-19
%obsolete python2-tw2-jqplugins-flot 2.0.1-17
%obsolete python2-tw2-jqplugins-gritter 2.0.1-16
%obsolete python2-tw2-sqla 2.0.6-15
%obsolete python2-txaio 18.8.1-2
%obsolete python2-txsocksx 1.15.0.2-11
%obsolete python2-unbound 1.8.3-8
%obsolete python2-urwidtrees 1.0-11
%obsolete python2-vatnumber 1.2-12
%obsolete python2-vdsm 4.18.999-448
%obsolete python2-virtualenv 16.0.0-8
%obsolete python2-virtualenv-api 2.1.16-7
%obsolete python2-virtualenv-python26 16.0.0-8
%obsolete python2-warlock 1.3.0-9
%obsolete python2-watchdog 0.8.3-12
%obsolete python2-webhelpers 1.3-21
%obsolete python2-websocket-client 0.54.0-2
%obsolete python2-winrm 0.3.0-5
%obsolete python2-xmms2 0.8-59
%obsolete python2-yaql 1.1.3-7
%obsolete python-jabberbot 0.15-5
%obsolete pyvnc2swf 0.9.5-26
%obsolete pywebkitgtk 1.1.8-14
%obsolete qct 1.7-21
%obsolete qct-mercurial 1.7-21
%obsolete rb_libtorrent-python2 1.1.13-3
%obsolete repo_manager 0.1.0-15
%obsolete revelation 0.4.14-21
%obsolete rssdler 0.4.2-18
%obsolete scout 0.4-24
%obsolete shinken 2.4.3-16
%obsolete sK1 0.9.1-0.20
%obsolete snake 0.11.1-13
%obsolete snap 0.6-14
%obsolete Spawning 0.9.7-8
%obsolete specto 0.4.1-16
%obsolete sphinx-webtools 0.2.1-20120541
%obsolete stonevpn 0.4.17-4
%obsolete stylus-toolbox 0.2.7-17
%obsolete supybot-fedmsg 0.2.0-9
%obsolete supybot-fedora 0.4.2-3
%obsolete supybot-koji 0.2-18
%obsolete supybot-meetbot 0.1.4-27
%obsolete synce-kpm 0.15.1-14
%obsolete synce-sync-engine 0.15.1-18
%obsolete syncthing-gtk 0.9.4.3-3
%obsolete system-config-users 1.3.8-7
%obsolete testoob 1.13-23
%obsolete the-new-hotness 0.10.0-6
%obsolete trac-sphinx-plugin 0.2.1-20120528
%obsolete translation-filter 1.0-16
%obsolete translation-filter-kde 1.0-16
%obsolete tunir 0.17.3-7
%obsolete turpial 3.0-13
%obsolete vdsm 4.18.999-448
%obsolete vdsm-api 4.18.999-448
%obsolete vdsm-jsonrpc 4.18.999-448
%obsolete vdsm-xmlrpc 4.18.999-448
%obsolete vdsm-yajsonrpc 4.18.999-448
%obsolete viewvc 1.1.26-10
%obsolete virtaal 0.7.1-15
%obsolete wicd-common 1.7.4-10
%obsolete wordgroupz 0.3.1-18
%obsolete writetype 1.2.130-19
%obsolete wuja 0.0.8-22
%obsolete yum-axelget 1.0.5.1-11
%obsolete yum-langpacks 0.4.5-11
%obsolete yum-metadata-parser 1.1.4-23
%obsolete yum-utils 1.1.31-520

# Remove in F34; retired in F32+
%obsolete python2-rabbitvcs 0.17.1-13

%description
This package exists only to obsolete other packages which need to be removed
from the distribution for some reason.

Currently obsoleted packages:

%list_obsoletes


%prep
%autosetup -c -T
cp %SOURCE0 .


%files
%doc README


%changelog
* Wed Sep 11 2019 Miro Hrončok <mhroncok@redhat.com> - 32-12
- Fix a typo in gcompris (#1747430)

* Tue Sep  3 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 32-11
- Obsolete fedmsg-notify (#1644813), gcompris (#1747430)

* Tue Sep  3 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 32-10
- Obsolete python2-pandas-datareader

* Tue Sep  3 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 32-9
- Obsolete gegl (#1747428)

* Fri Aug 30 2019 Miro Hrončok <mhroncok@redhat.com> - 32-8
- Obsolete python2-cliff, python2-copr, python2-docker, python2-fedmsg,
  python2-future, python2-grokmirror, python2-keystoneauth1, python2-markdown,
  python2-openstacksdk, python2-pwquality, python2-warlock, system-config-users
  (#1747436)

* Fri Aug 30 2019 Pete Walter <pwalter@fedoraproject.org> - 32-7
- Obsolete python2-rabbitvcs (#1738183)

* Mon Aug 26 2019 Neal Gompa <ngompa13@gmail.com> - 32-6
- Obsolete oggconvert

* Sun Aug 25 2019 Kalev Lember <klember@redhat.com> - 32-5
- Obsolete gedit-plugin-synctex

* Sun Aug 25 2019 Kalev Lember <klember@redhat.com> - 32-4
- Obsolete python2-unbound

* Thu Aug 22 2019 Miro Hrončok <mhroncok@redhat.com> - 32-3
- Obsolete python3-importlib-metadata (#1725789)

* Mon Aug 19 2019 Kalev Lember <klember@redhat.com> - 32-2
- Obsolete python2-libselinux and python2-libsemanage

* Tue Aug 13 2019 Miro Hrončok <mhroncok@redhat.com> - 32-1
- Cleaned up for Fedora 32

* Tue Aug 13 2019 Miro Hrončok <mhroncok@redhat.com> - 31-20
- Obsolete a batch of problematic python2 packages removed in Fedora 31

* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 31-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Mon Jun 24 2019 Miro Hrončok <mhroncok@redhat.com> - 31-18
- Obsolete python2-langtable (#1706075)

* Tue May 21 2019 Miro Hrončok <mhroncok@redhat.com> -31-17
- Obsolete yumex (#1707567)
- Obsolete pix (#1707570)
- Obsolete system-config-services (#1707577)

* Thu May 09 2019 Miro Hrončok <mhroncok@redhat.com> - 31-16
- Bump python2-hawkey, python2-libdnf and python2-solv versions (#1632564)

* Thu Apr 25 2019 Kalev Lember <klember@redhat.com> - 31-15
- Obsolete california (#1702954)

* Mon Apr 22 2019 Miro Hrončok <mhroncok@redhat.com> - 31-14
- No longer obsolete python2-blockdiag (#1699834)

* Tue Apr 16 2019 Orion Poplawski <orion@nwra.com> - 31-13
- Obsolete python2-envisage (#1700310)

* Tue Apr 16 2019 Miro Hrončok <mhroncok@redhat.com> - 31-12
- Obsolete mongodb, mongodb-server, mongodb-test < 4.0.3-4 (#1700073)
- Obsolete python2-certbot < 0.31.0-3 and python2-josepy < 1.1.0-7 (#1700045)

* Mon Apr 15 2019 Kevin Fenzi <kevin@scrye.com> - 31-11
- Obsolete mongodb < 4.0.3-3 (#1700073)

* Mon Apr 15 2019 Miro Hrončok <mhroncok@redhat.com> - 31-10
- Obsolete python2-cinderclient < 3.5.0-2

* Sun Apr 14 2019 Miro Hrončok <mhroncok@redhat.com> - 31-9
- Obsolete python2-testify < 0.11.0-13

* Thu Apr 11 2019 Fabio Valentini <decathorpe@gmail.com> - 31-8
- Add obsoletes for appcenter* packages.

* Wed Apr 10 2019 Kalev Lember <klember@redhat.com> - 31-7
- Remove gnome-books obsoletes now that the package is back in Fedora (#1698489)

* Mon Apr 08 2019 Miro Hrončok <mhroncok@redhat.com> - 31-6
- Obsolete another batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Thu Apr 04 2019 Miro Hrončok <mhroncok@redhat.com> - 31-5
- Obsolete another batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
- Obsolete python2-pylint (#1686848)
- Obsolete python2 subpackages of ceph (#1687998)

* Thu Apr 04 2019 Kalev Lember <klember@redhat.com> - 31-4
- Obsolete PyXB (#1696209)

* Fri Mar 08 2019 Miro Hrončok <mhroncok@redhat.com> - 31-3
- Obsolete Python 2 Sphinx packages
  https://fedoraproject.org/wiki/Changes/Sphinx2

* Mon Mar 04 2019 Miro Hrončok <mhroncok@redhat.com> - 31-2
- Obsolete another batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Fri Feb 22 2019 Jason L Tibbitts III <tibbs@math.uh.edu> - 31-1
- Cleaned up for F31.
- Obsolete empathy (bz 1680068).

* Tue Feb 19 2019 Pete Walter <pwalter@fedoraproject.org> - 30-28
- Bump librepo and libcomps python2 subpackage obsoletes versions

* Tue Feb 19 2019 Pete Walter <pwalter@fedoraproject.org> - 30-27
- Bump dnf python2 subpackage obsoletes versions

* Tue Feb 19 2019 Bastien Nocera <bnocera@redhat.com> - 30-26
- Obsolete gnome-books after split off from gnome-documents

* Wed Feb 13 2019 Björn Esser <besser82@fedoraproject.org> - 30-25
- Obsolete trafficserver < 5.3.0-14 and its sub-packages

* Tue Feb 12 2019 Kalev Lember <klember@redhat.com> - 30-24
- Obsolete python-xpyb-devel as well, in addition to python2-xpyb

* Tue Feb 12 2019 Kalev Lember <klember@redhat.com> - 30-23
- Obsolete vala-compat

* Mon Feb 11 2019 Kalev Lember <klember@redhat.com> - 30-22
- Obsolete python2-isort

* Fri Feb 08 2019 Kalev Lember <klember@redhat.com> - 30-21
- Obsolete wxGTK and its subpackages

* Thu Feb 07 2019 Miro Hrončok <mhroncok@redhat.com> - 30-20
- Obsolete another batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Thu Jan 31 2019 Pete Walter <pwalter@fedoraproject.org> - 30-19
- Obsolete python2-samba

* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 30-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Tue Jan 29 2019 Pete Walter <pwalter@fedoraproject.org> - 30-17
- Obsolete python2-librepo

* Tue Jan 29 2019 Pete Walter <pwalter@fedoraproject.org> - 30-16
- Obsolete python2-bodhi and python2-bodhi-client
- Bump dnf-plugins-core python2 package obsoletes versions

* Thu Jan 10 2019 Kalev Lember <klember@redhat.com> - 30-15
- Obsolete gedit-plugin-dashboard

* Sat Jan 05 2019 Pete Walter <pwalter@fedoraproject.org> - 30-14
- Fix python2-blockdev and python2-dnf-plugins obsolete versions

* Thu Dec 13 2018 Miro Hrončok <mhroncok@redhat.com> - 30-13
- Obsolete sixth batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Fri Nov 23 2018 Miro Hrončok <mhroncok@redhat.com> - 30-12
- Obsolete fifth batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Thu Nov 01 2018 Miro Hrončok <mhroncok@redhat.com> - 30-11
- Obsolete fourth batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Fri Oct 05 2018 Miro Hrončok <mhroncok@redhat.com> - 30-10
- Obsolete fourth batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Sun Sep 30 2018 Miro Hrončok <mhroncok@redhat.com> - 30-9
- Obsolete third batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Tue Sep 18 2018 Miro Hrončok <mhroncok@redhat.com> - 30-8
- Obsolete second batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Tue Sep 18 2018 Miro Hrončok <mhroncok@redhat.com> - 30-7
- Obsolete python2-mapnik (#1630222)
- Obsolete first batch of problematic mass retired python2 packages
  https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

* Tue Sep 11 2018 Scott Talbert <swt@techie.net> - 30-6
- Obsolete python2-libconcord, python2-pyqtgraph, python2-pyopengl-tk

* Mon Sep 03 2018 Miro Hrončok <mhroncok@redhat.com> - 30-5
- Obsolete python2-behave (#1624838)

* Wed Aug 22 2018 Miro Hrončok <mhroncok@redhat.com>
- Obsolete more python3 packages (#1610422)

* Mon Aug 20 2018 Miro Hrončok <mhroncok@redhat.com> - 30-3
- Bump up version of abrt packages

* Fri Aug 17 2018 Miro Hrončok <mhroncok@redhat.com> - 30-2
- Obsolete python3-svgwrite (#1610422) (#1605936)

* Thu Aug 16 2018 Miro Hrončok <mhroncok@redhat.com> - 30-1
- Fedora 30 bump (removed all no longer needed obsoletes)

* Thu Aug 16 2018 Miro Hrončok <mhroncok@redhat.com> - 29-17
- Obsolete python3-trollius-redis (#1610422) (#1606877)

* Mon Aug 13 2018 Kalev Lember <klember@redhat.com> - 29-16
- Obsolete vte3 (#1315425)

* Wed Aug 08 2018 Miro Hrončok <mhroncok@redhat.com> - 29-15
- Obsolete python3-ovirt-register (#1610422) (#1605819)

* Wed Aug 01 2018 Miro Hrončok <mhroncok@redhat.com> - 29-14
- Obsolete removed python3 packages (#1610422)

* Tue Jul 31 2018 Stephen Gallagher <sgallagh@redhat.com> - 29-13
- Obsolete rolekit

* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 29-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Mon Jul 02 2018 Pete Walter <pwalter@fedoraproject.org> - 29-11
- Obsolete fedora-productimg-workstation
- Bump NetworkManager-glib and libnm-gtk obsoletes versions

* Wed Jun 06 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 29-10
- Add ppc64-utils (https://bugzilla.redhat.com/show_bug.cgi?id=1588130).

* Fri May 18 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 29-9
- Add abrt-related python2 packages.
- Clean up and add more documentation, since many provenpackagers are modifying
  this package without including the needed information.
- Remove the last F29 entries.
- Fix bogus date in %%changelog.

* Thu May 17 2018 Lubomir Rintel <lkundrak@v3.sk> - 29-8
- Bump version of libnm-glib packages to f28 updates

* Mon May 07 2018 Pete Walter <pwalter@fedoraproject.org> - 29-7
- Obsolete python2-caribou and python3-caribou as well (#1568670)

* Fri May  4 2018 Peter Robinson <pbrobinson@fedoraproject.org> 29-6
- Obsolete libmx and presence
- Obsolete clucene09-core xorg-x11-drv-freedreno

* Fri May 04 2018 Pete Walter <pwalter@fedoraproject.org> - 29-5
- Obsolete old caribou versions (#1568670)

* Tue Apr 24 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 29-4
- Remove a number of "Remove in F28" and "Remove in F29" entries.

* Mon Apr 23 2018 Lubomir Rintel <lkundrak@v3.sk> - 29-3
- Obsolete libnm-glib based packages

* Thu Apr 12 2018 Kalev Lember <klember@redhat.com> - 29-2
- Fix bind99 obsoletes versions, obsolete mozjs17-devel

* Thu Apr 12 2018 Peter Robinson <pbrobinson@fedoraproject.org> 29-1
- bind99, mozjs17, python2-zeroconf, python2-chromecast

* Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 28-2
- Add xulrunner obsoletes

* Mon Nov 13 2017 Pete Walter <pwalter@fedoraproject.org> - 28-1
- Obsolete compat-ImageMagick693, compat-libvpx1

* Wed Nov  8 2017 Peter Robinson <pbrobinson@fedoraproject.org> 27-10
- Obsolete  compat-gnutls28, libsilc, pam_pkcs11, python-dapp

* Fri Oct 13 2017 Rex Dieter <rdieter@fedoraproject.org> - 27-9
- Obsoletes: kdegraphics-strigi-analyzer kfilemetadata
- bump libkexiv2 version

* Sat Oct 07 2017 Rex Dieter <rdieter@fedoraproject.org> - 27-8
- Obsolets: kf5-libkface (#1423813)

* Sat Oct 07 2017 Rex Dieter <rdieter@fedoraproject.org> - 27-7
- Obsoletes: strigi, libkexiv2 (#1498850)

* Tue Aug 29 2017 Kalev Lember <klember@redhat.com> - 27-6
- Add seed obsoletes

* Tue Aug 29 2017 Kalev Lember <klember@redhat.com> - 27-5
- Add hawkey and libhif obsoletes

* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 27-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

* Tue Jul 11 2017 Adam Williamson <awilliam@redhat.com> - 27-3
- Add webkitgtk and webkitgtk3 (and -devel) - RHBZ #1443614

* Wed Jun 21 2017 Jason L Tibbitts III <tibbs@math.uh.edu> - 27-2
- Add various devassistant-related packages from https://bugzilla.redhat.com/show_bug.cgi?id=1463408

* Tue May 16 2017 Jason L Tibbitts III <tibbs@math.uh.edu> - 27-1
- Add perl ZMQ packages from https://bugzilla.redhat.com/show_bug.cgi?id=1451372

* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 26-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

* Wed Sep 14 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 26-1
- Initial release; nothing to obsolete yet.