#10 Obsolete more python3 packages (#1610422)
Merged 2 years ago by churchyard. Opened 2 years ago by churchyard.
rpms/ churchyard/fedora-obsolete-packages py3_next  into  master

file modified
+38 -1

@@ -13,7 +13,7 @@ 

  Name:       fedora-obsolete-packages

  # Please keep the version equal to the targeted Fedora release

  Version:    30

- Release:    3

+ Release:    4

  Summary:    A package to obsolete retired packages

  

  # This package has no actual content; there is nothing to license.

@@ -103,19 +103,36 @@ 

  Obsoletes: fedrepo-req < 1.12.0-2

  Obsoletes: fedrepo-req-admin < 1.12.0-2

  Obsoletes: python3-amqplib < 1.0.2-22

+ Obsoletes: python3-compyte < 0.0.1-0.13

  Obsoletes: python3-django-discover-runner < 1.0-14

  Obsoletes: python3-django-keyedcache3 < 1.5.3-10

  Obsoletes: python3-django-notification < 1.2.0-10

  Obsoletes: python3-django-openstack-auth < 2.4.2-4

+ Obsoletes: python3-djvulibre < 0.8-6

  Obsoletes: python3-fedrepo-req < 1.12.0-2

+ Obsoletes: python3-flask-restless < 0.17.0-14

  Obsoletes: python3-iptools < 0.6.1-17

+ Obsoletes: python3-liblarch_gtk < 3.0-5

+ Obsoletes: python3-liblarch < 3.0-5

+ Obsoletes: python3-lmiwbem < 0.7.2-22

+ Obsoletes: python3-ludolph-zabbix < 1.7-5

+ Obsoletes: python3-ludolph < 1.0.1-6

  Obsoletes: python3-mlpy < 3.5.0-9

+ Obsoletes: python3-openstack-nose-plugin < 0.11-17

  Obsoletes: python3-ovirt-register < 1.0.0-20

  Obsoletes: python3-pygpgme < 0.3-29

+ Obsoletes: python3-sleekxmpp < 1.3.2-7

  Obsoletes: python3-svgwrite < 1.1.12-6

  Obsoletes: python3-taskw < 1.2.0-10

+ Obsoletes: python3-testfixtures-tests < 4.14.3-7

+ Obsoletes: python3-testfixtures < 4.14.3-7

+ Obsoletes: python3-tlslite < 0.4.9-10

  Obsoletes: python3-toro < 1.0.1-9

  Obsoletes: python3-trollius-redis < 0.1.4-16

+ Obsoletes: python3-tweepy < 3.5.0-10

+ Obsoletes: python3-ufo2ft < 1.1.0-6

+ Obsoletes: python3-wordpress-xmlrpc < 2.3-14

+ Obsoletes: rtv < 1.22.1-4

  Obsoletes: targetd < 0.8.6-6

  

  # Remove in F31

@@ -167,19 +184,36 @@ 

    fedrepo-req < 1.12.0-2

    fedrepo-req-admin < 1.12.0-2

    python3-amqplib < 1.0.2-22

+   python3-compyte < 0.0.1-0.13

    python3-django-discover-runner < 1.0-14

    python3-django-keyedcache3 < 1.5.3-10

    python3-django-notification < 1.2.0-10

    python3-django-openstack-auth < 2.4.2-4

+   python3-djvulibre < 0.8-6

    python3-fedrepo-req < 1.12.0-2

+   python3-flask-restless < 0.17.0-14

    python3-iptools < 0.6.1-17

+   python3-liblarch_gtk < 3.0-5

+   python3-liblarch < 3.0-5

+   python3-lmiwbem < 0.7.2-22

+   python3-ludolph-zabbix < 1.7-5

+   python3-ludolph < 1.0.1-6

    python3-mlpy < 3.5.0-9

+   python3-openstack-nose-plugin < 0.11-17

    python3-ovirt-register < 1.0.0-20

    python3-pygpgme < 0.3-29

+   python3-sleekxmpp < 1.3.2-7

    python3-svgwrite < 1.1.12-6

    python3-taskw < 1.2.0-10

+   python3-testfixtures-tests < 4.14.3-7

+   python3-testfixtures < 4.14.3-7

+   python3-tlslite < 0.4.9-10

    python3-toro < 1.0.1-9

    python3-trollius-redis < 0.1.4-16

+   python3-tweepy < 3.5.0-10

+   python3-ufo2ft < 1.1.0-6

+   python3-wordpress-xmlrpc < 2.3-14

+   rtv < 1.22.1-4

    targetd < 0.8.6-6

    (see https://bugzilla.redhat.com/show_bug.cgi?id=1610422)

  

@@ -209,6 +243,9 @@ 

  

  

  %changelog

+ * Wed Aug 22 2018 Miro Hrončok <mhroncok@redhat.com>

+ - Obsolete more python3 packages (#1610422)

+ 

  * Mon Aug 20 2018 Miro Hrončok <mhroncok@redhat.com> - 30-3

  - Bump up version of abrt packages

  

  • python3-compyte < 0.0.1-0.13
  • python3-djvulibre < 0.8-6
  • python3-flask-restless < 0.17.0-14
  • python3-liblarch_gtk < 3.0-5
  • python3-liblarch < 3.0-5
  • python3-lmiwbem < 0.7.2-22
  • python3-ludolph-zabbix < 1.7-5
  • python3-ludolph < 1.0.1-6
  • python3-openstack-nose-plugin < 0.11-17
  • python3-sleekxmpp < 1.3.2-7
  • python3-testfixtures-tests < 4.14.3-7
  • python3-testfixtures < 4.14.3-7
  • python3-tlslite < 0.4.9-10
  • python3-tweepy < 3.5.0-10
  • python3-ufo2ft < 1.1.0-6
  • python3-wordpress-xmlrpc < 2.3-14
  • rtv < 1.22.1-4

@tibbs are the debuginfos OK here?

I wouldn't think it would be necessary to add debuginfo packages here since they don't have dependencies and thus can't shouldn't the kind of dependency issues this package is designed to prevent. I don't think there's any real benefit to adding them here, but also there isn't any particular downside besides not keeping the list down to the absolute minimum required to prevent dependency issues.

Debuginfo packages are all parallel-installable and don't get updated like everything else does (because generally the repository isn't kept enabled) so people who install them have to clean them up manually anyway. I just noticed I have 141 outdated debuginfo packages installed currently.

rebased onto 2489aaf

2 years ago

Pull-Request has been merged by churchyard

2 years ago