a84eae6 Update cmake build to use C++20 standard.

Authored and Committed by filbranden 3 months ago
1 file changed. 7 lines added. 1 lines removed.
    Update cmake build to use C++20 standard.
    
    GCC 11 includes support for C++ coroutines, but it needs to use C++20
    standard for that to be enabled.
    
    https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=29f0e90d9904d8e0965443d4da4c95ddde5edb1e
    
    Tested that Folly coroutines get properly enabled when the appropriate
    C++ standard flags are provided.
    
    Signed-off-by: Filipe Brandenburger <filbranden@gmail.com>
    
        
file modified
+7 -1