Blob Blame Raw
%global upstreamver 4r7p8
%global pkgdate 2015_06_09-20_27
%global gapdirname gap%(cut -dp -f1 <<< %upstreamver)
%global gapdir %{_prefix}/lib/gap
%global icondir %{_datadir}/icons/hicolor

Name:           gap
Version:        %(sed -r "s/r|p/./g" <<< %upstreamver)
Release:        1%{?dist}
Summary:        Computational discrete algebra

License:        GPLv2+
URL:            http://www.gap-system.org/
Source0:        ftp://ftp.gap-system.org/pub/gap/gap47/tar.bz2/%{name}%{upstreamver}_%{pkgdate}.tar.bz2
Source1:        gap-README.fedora
Source2:        update-gap-workspace
Source3:        gap.xml
Source4:        gap.desktop
Source5:        gap.el
Source6:        gap.1.in
Source7:        gac.1.in
Source8:        update-gap-workspace.1
Source9:        gap.vim
Source10:       gap.appdata.xml
# This patch from Debian rearranges some paths to match Linux conventions.
Patch0:         %{name}-paths.patch
# This patch applies a change from Debian to allow help files to be in gzip
# compressed DVI files, and also adds support for viewing with xdg-open.
Patch1:         %{name}-help.patch
# This patch will not be sent upstream.  It makes the main binary read the
# environment variables now read by gap.sh, so we can dispose of the shell
# script and run the actual binary directly.
Patch2:         %{name}-env.patch
# Filed as an upstream git pull request.  Force use of the 64-bit stat()
# routines to avoid overflow of the inode and size fields.
Patch3:         %{name}-stat.patch
# Filed as an upstream git pull request.  In mock --shell environments,
# isatty(0) == true, but ttyname(0) == NULL, leading to a crash.  This breaks
# debugging GAP package test suites.
Patch4:         %{name}-ttyname.patch

BuildRequires:  desktop-file-utils
BuildRequires:  gmp-devel
BuildRequires:  m4
BuildRequires:  netpbm-progs
BuildRequires:  readline-devel

Requires:       %{name}-libs = %{version}-%{release}
Requires:       %{name}-core%{?_isa} = %{version}-%{release}
Requires:       %{name}-online-help = %{version}-%{release}

%description
GAP is a system for computational discrete algebra, with particular
emphasis on Computational Group Theory.  GAP provides a programming
language, a library of thousands of functions implementing algebraic
algorithms written in the GAP language as well as large data libraries
of algebraic objects.  GAP is used in research and teaching for studying
groups and their representations, rings, vector spaces, algebras,
combinatorial structures, and more.

This is a metapackage that requires the standard GAP components.

%package libs
Summary:        Essential GAP libraries
BuildArch:      noarch

# These obsoletes and provides can be removed once Fedora 20 is EOL, or if
# somebody packages one of the GAP emacs interfaces.
Obsoletes:      %{name}-emacs < 4.7.2-1
Provides:       %{name}-emacs = %{version}-%{release}
Obsoletes:      %{name}-emacs-el < 4.7.2-1
Provides:       %{name}-emacs-el = %{version}-%{release}
Obsoletes:      %{name}-xemacs < 4.7.2-1
Provides:       %{name}-xemacs = %{version}-%{release}
Obsoletes:      %{name}-xemacs-el < 4.7.2-1
Provides:       %{name}-xemacs-el = %{version}-%{release}

%description libs
This package contains the essential GAP libraries: lib and grp, as well as
the primitive, small, and transitive group databases.

%package core
Summary:        GAP core components
Requires:       %{name}-libs = %{version}-%{release}
Requires:       GAPDoc
# The gap binary executes gunzip
Requires:       gzip
Requires:       hicolor-icon-theme

%description core
This package contains the core GAP system.

%package online-help
Summary:        Online help for GAP
Requires:       %{name}-core = %{version}-%{release}
BuildArch:      noarch

%description online-help
This package contains the documentation in TeX format needed for GAP's
online help system.

%package devel
Summary:        GAP compiler and development files
Requires:       %{name}-core%{?isa} = %{version}-%{release}
Requires:       gcc
Requires:       gmp-devel%{?_isa}

%description devel
This package contains the GAP compiler (gac) and the header files necessary
for developing GAP programs.

%package vim
Summary:        Edit GAP files with VIM
Requires:       %{name}-core = %{version}-%{release}, vim-filesystem
BuildArch:      noarch

%description vim
This package provides VIM add-on files to support editing GAP sources.
Both syntax highlighting and indentation are supported.

%prep
%setup -q -n %{gapdirname}
%patch0
%patch1
%patch2
%patch3
%patch4

# Replace the CFLAGS and find the math functions
sed -re "s|(gp_cv_prog_cc_cdynoptions=)\"-fPIC -Wall -O2|\1\"\$RPM_OPT_FLAGS -fPIC|" \
    -e "s|(gp_cv_prog_cc_cdynlinking=)\"-shared -g[[:digit:]]*|\1\"\$RPM_LD_FLAGS -shared|" \
    -e '/log2 log10/iLIBS="-lm $LIBS"' \
    -i cnf/configure.out

# Get the README
cp -p %{SOURCE1} README.fedora

# Fix a missing executable bit
chmod a+x makepkgs

# The makepkgs script is unable to find 2 packages due to version numbers
ln -s io-4.4.4 pkg/io
ln -s orb-4.7.3 pkg/orb

%build
%configure --with-gmp=system \
  CPPFLAGS='-D_FILE_OFFSET_BITS=64 -DSYS_DEFAULT_PATHS=\"%{gapdir}\"'
# FIXME: GAP 4.5 broke %%{?_smp_mflags}
make

# Get the value of the GAParch variable
source ./sysinfo.gap

# The packages must be built for the check script to succeed
sed -e "s|@gaparch@|$GAParch|" \
    -e "s| -DSYS_DEFAULT_PATHS=\\\"/usr/share/gap\\\"||" \
    -i bin/$GAParch/gac
mkdir -p bin/$GAParch/extern/gmp/include
ln -s %{_includedir}/gmp.h bin/$GAParch/extern/gmp/include
sed -i "s|-D_GNU_SOURCE|-I$PWD|" Makefile-default*
sed -i "s|-o|-p -I -p $PWD -p -I -p $PWD/bin/$GAParch &|" \
    pkg/edim/Makefile.in pkg/Browse/Makefile.in
make packages

# Compress help files
find doc -name \*.dvi -o -name \*.toc | xargs gzip --best

# Compress large group files
find -O3 small -mindepth 2 -type f | xargs gzip --best -f
gzip --best prim/grps/*.g trans/*.grp

# Create an RPM macro file for GAP packages
cat > macros.%{name} << EOF
%%_gap_version %{version}
%%_gap_upstream_version %{upstreamver}
%%_gap_dir %{gapdir}
EOF

%install
# Get the value of the GAParch variable
source ./sysinfo.gap

# Install the binaries
mkdir -p %{buildroot}%{_bindir}
cp -p bin/$GAParch/{gac,gap} %{buildroot}%{_bindir}
cp -p %{SOURCE2} %{buildroot}%{_bindir}

# Install the data
mkdir -p %{buildroot}%{gapdir}/etc
cp -a grp lib prim small trans tst %{buildroot}%{gapdir}
cp -p etc/debug* %{buildroot}%{gapdir}/etc

# Install the arch-specific files
cp -a sysinfo.gap* %{buildroot}%{gapdir}

# Create the system workspace, initially empty
mkdir -p %{buildroot}%{_localstatedir}/lib/%{name}
touch %{buildroot}%{_localstatedir}/lib/%{name}/workspace.gz

# Install the header and object files where the GAP compiler can find them
mkdir -p %{buildroot}%{gapdir}/src
cp -p src/*.h %{buildroot}%{gapdir}/src
mkdir -p %{buildroot}%{gapdir}/bin/$GAParch
cp -p bin/$GAParch/config.h %{buildroot}%{gapdir}/bin/$GAParch
cp -p bin/$GAParch/*.o %{buildroot}%{gapdir}/bin/$GAParch
rm -f bin/$GAParch/extern/Makefile
cp -a bin/$GAParch/extern %{buildroot}%{gapdir}/bin/$GAParch
ln -s %{_bindir}/gac %{buildroot}%{gapdir}/bin/$GAParch/gac
ln -s %{_bindir}/gap %{buildroot}%{gapdir}/bin/$GAParch/gap

# Make an empty directory to hold the GAP packages
mkdir -p %{buildroot}%{gapdir}/pkg

# Intall the documentation
cp -a doc %{buildroot}%{gapdir}
rm -f %{buildroot}%{gapdir}/doc/manualindex
rm -fr %{buildroot}%{gapdir}/doc/test

# Install the icon; the original is 1024x1024
bmptopnm bin/gapicon.bmp > gapicon.pnm
for size in 32 48 64 96 128 192 256 512; do
  mkdir -p %{buildroot}%{icondir}/${size}x${size}
  pamscale -xsize=$size -ysize=$size gapicon.pnm | pnmtopng -compression=9 \
    > %{buildroot}%{icondir}/${size}x${size}/%{name}.png
done

# Install the MIME type
mkdir -p %{buildroot}%{_datadir}/mime/packages
cp -p %{SOURCE3} %{buildroot}%{_datadir}/mime/packages

# Install the desktop file
mkdir -p %{buildroot}%{_datadir}/applications
desktop-file-install --mode=644 --dir=%{buildroot}%{_datadir}/applications \
  %{SOURCE4}

# Install the AppData file
mkdir -p %{buildroot}%{_datadir}/appdata
install -pm 644 %{SOURCE10} %{buildroot}%{_datadir}/appdata

# Install the RPM macro file
mkdir -p %{buildroot}%{_rpmconfigdir}/macros.d
cp -p macros.%{name} %{buildroot}%{_rpmconfigdir}/macros.d

# Install the VIM support
mkdir -p %{buildroot}%{_datadir}/vim/vimfiles/indent
cp -p etc/gap_indent.vim %{buildroot}%{_datadir}/vim/vimfiles/indent
mkdir -p %{buildroot}%{_datadir}/vim/vimfiles/syntax
cp -p etc/gap.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax
mkdir -p %{buildroot}%{_datadir}/vim/vimfiles/ftdetect
cp -p %{SOURCE9} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect

# Install the man pages
mkdir -p %{buildroot}%{_mandir}/man1
sed "s|@VERSION@|%{version}|" %{SOURCE6} > %{buildroot}%{_mandir}/man1/gap.1
sed "s|@VERSION@|%{version}|" %{SOURCE7} > %{buildroot}%{_mandir}/man1/gac.1
cp -p %{SOURCE8} %{buildroot}%{_mandir}/man1

%post core
/usr/bin/update-desktop-database %{_datadir}/applications &>/dev/null ||:
/bin/touch --no-create %{icondir} >&/dev/null ||:
/bin/touch --no-create %{_datadir}/mime/packages &> /dev/null || :

%posttrans
/usr/bin/gtk-update-icon-cache %{icondir} >&/dev/null ||:
/usr/bin/update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%{_bindir}/update-gap-workspace &> /dev/null || :

%preun
if [ $1 -eq 0 ]; then
  {_bindir}/update-gap-workspace delete &> /dev/null || :
fi

%postun core
/usr/bin/update-desktop-database %{_datadir}/applications &>/dev/null ||:
if [ $1 -eq 0 ] ; then
  /bin/touch --no-create %{icondir} >&/dev/null ||:
  /usr/bin//gtk-update-icon-cache %{icondir} >&/dev/null ||:
  /bin/touch --no-create %{_datadir}/mime/packages &> /dev/null || :
  /usr/bin/update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
fi

%check
sed -e "s|^GAP_DIR=.*|GAP_DIR=$PWD|" \
    -e "s|\$GAP_DIR/bin/\$GAP_PRG|$PWD/bin/\$GAP_PRG|" \
    -i bin/gap.sh bin/gap-default*.sh
sed -i "s|80 -r|& -l $PWD|" Makefile-default*
make testinstall

%files
# No files in the metapackage

%files libs
%doc small/README
%license etc/GPL
%dir %{gapdir}
%{gapdir}/grp/
%{gapdir}/lib/
%{gapdir}/prim/
%{gapdir}/small/
%{gapdir}/trans/

%files core
%doc README.fedora
%{_bindir}/gap
%{_bindir}/update-gap-workspace
%{gapdir}/sysinfo.gap*
%{gapdir}/pkg/
%{_mandir}/man1/gap.1*
%{_mandir}/man1/update-gap-workspace.1*
%{_datadir}/appdata/gap.appdata.xml
%{_datadir}/applications/gap.desktop
%{_datadir}/mime/packages/gap.xml
%{icondir}/32x32/gap.png
%{icondir}/48x48/gap.png
%{icondir}/64x64/gap.png
%{icondir}/96x96/gap.png
%{icondir}/128x128/gap.png
%{icondir}/192x192/gap.png
%{icondir}/256x256/gap.png
%{icondir}/512x512/gap.png
%dir %{_localstatedir}/lib/%{name}/
%verify(user group mode) %{_localstatedir}/lib/%{name}/workspace.gz

%files online-help
%{gapdir}/doc/

%files devel
%{_bindir}/gac
%{gapdir}/bin/
%{gapdir}/src/
%{gapdir}/tst/
%{_mandir}/man1/gac.1*
%{_rpmconfigdir}/macros.d/macros.%{name}

%files vim
%{gapdir}/etc/
%{_datadir}/vim/vimfiles/ftdetect/gap.vim
%{_datadir}/vim/vimfiles/indent/gap_indent.vim
%{_datadir}/vim/vimfiles/syntax/gap.vim

%changelog
* Fri Jun 12 2015 Jerry James <loganjerry@gmail.com> - 4.7.8-1
- New upstream release

* Wed May 20 2015 Jerry James <loganjerry@gmail.com> - 4.7.7-2
- Fix gac compiler flags for dynamic objects
- Update appdata

* Mon Feb 16 2015 Jerry James <loganjerry@gmail.com> - 4.7.7-1
- New upstream release

* Fri Jan 23 2015 Jerry James <loganjerry@gmail.com> - 4.7.6-3
- Fix scriptlets so they don't complain when uninstalling
- Drop obsolete Group tags

* Thu Jan 15 2015 Jerry James <loganjerry@gmail.com> - 4.7.6-2
- Fix crash with nameless TTYs, such as in mock shell environments

* Wed Dec 10 2014 Jerry James <loganjerry@gmail.com> - 4.7.6-1
- New upstream release
- Fix license handling
- Install more icon sizes

* Sat Aug 16 2014 Rex Dieter <rdieter@fedoraproject.org> 4.7.5-3
- update scriplets

* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

* Thu Jun 19 2014 Jerry James <loganjerry@gmail.com> - 4.7.5-1
- New upstream release
- Fix ownership of workspace.gz

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.7.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Wed Mar 19 2014 Jerry James <loganjerry@gmail.com> - 4.7.4-1
- New upstream release

* Wed Feb  5 2014 Jerry James <loganjerry@gmail.com> - 4.7.2-2
- Update location of rpm macro file for rpm >= 4.11
- Add an AppData file

* Tue Jan 14 2014 Jerry James <loganjerry@gmail.com> - 4.7.2-1
- New upstream release
- Upstream no longer distributes an (X)Emacs interface

* Mon Jul 29 2013 Jerry James <loganjerry@gmail.com> - 4.6.5-1
- New upstream release

* Wed May 22 2013 Jerry James <loganjerry@gmail.com> - 4.6.4-2
- Update -stat patch to provide large integer conversion (for, e.g., loff_t)
- Drop meataxe Requirement as it has been replaced with internal routines

* Thu May 16 2013 Jerry James <loganjerry@gmail.com> - 4.6.4-1
- New upstream release

* Thu Mar 28 2013 Jerry James <loganjerry@gmail.com> - 4.6.3-1
- New upstream release

* Sat Mar 09 2013 Ralf Cors├ępius <corsepiu@fedoraproject.org> - 4.6.2-2
- Remove %%config from %%{_sysconfdir}/rpm/macros.*
  (https://fedorahosted.org/fpc/ticket/259).

* Wed Feb 20 2013 Jerry James <loganjerry@gmail.com> - 4.6.2-1
- New upstream release
- Move update-gap-workspace call to posttrans (bz 912067)
- Add -stat patch and -D_FILE_OFFSET_BITS=64 to CPPFLAGS to use 64-bit
  stat interface on 32-bit systems

* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.7-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

* Fri Dec 21 2012 Rex Dieter <rdieter@fedoraproject.org> 4.5.7-2
- optimize/update icon scriptlets

* Mon Dec 17 2012 Jerry James <loganjerry@gmail.com> - 4.5.7-1
- New upstream release

* Mon Oct 22 2012 Jerry James <loganjerry@gmail.com> - 4.5.6-3
- Further fixes for the -m32/-m64 issue
- Many packages need the primitive, small, or transitive groups; collapse them
  all into the -libs subpackage so they are always available
- Provide sysinfo-default[32|64], as required by some packages
- Provide symbolic links to gac and gap from the bin directory, as required by
  some packages

* Sat Oct 20 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 4.5.6-2
- -m32/-m64 should come from RPM_OPT_FLAGS. Fix build issues on non x86 arches

* Mon Sep 24 2012 Jerry James <loganjerry@gmail.com> - 4.5.6-1
- New upstream release
- Remove unused patches from git

* Thu Sep 13 2012 Jerry James <loganjerry@gmail.com> - 4.5.5-1
- New upstream release
- Drop upstreamed patches
- Sources are now UTF-8; no conversion necessary

* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.12-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

* Tue Jan 31 2012 Jerry James <loganjerry@gmail.com> - 4.4.12-4
- Add an RPM macro file for GAP packages
- Fix the location of config.h

* Wed Jan 11 2012 Jerry James <loganjerry@gmail.com> - 4.4.12-3
- Fix problems found on review

* Tue Jan  3 2012 Jerry James <loganjerry@gmail.com> - 4.4.12-2
- Mimic Debian's subpackage structure

* Wed Oct 12 2011 Jerry James <loganjerry@gmail.com> - 4.4.12-1
- Initial RPM