#1 Update to 3.33.90.
Closed 2 months ago by kalev. Opened 2 months ago by kathenas.
rpms/ kathenas/gedit-plugins master  into  master

file modified
+1

@@ -57,3 +57,4 @@ 

  /gedit-plugins-3.31.90.tar.xz

  /gedit-plugins-3.32.0.tar.xz

  /gedit-plugins-3.32.2.tar.xz

+ /gedit-plugins-3.33.90.tar.xz

@@ -1,234 +0,0 @@ 

- --- gedit-plugins-3.8.1/plugins/bracketcompletion/bracketcompletion.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/bracketcompletion/bracketcompletion.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=bracketcompletion

-  IAge=3

-  _Name=Bracket Completion

- --- gedit-plugins-3.8.1/plugins/bracketcompletion/bracketcompletion.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/bracketcompletion/bracketcompletion.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=bracketcompletion

-  IAge=3

-  _Name=Bracket Completion

- --- gedit-plugins-3.8.1/plugins/charmap/charmap.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/charmap/charmap.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=charmap

-  IAge=3

-  _Name=Character Map

- --- gedit-plugins-3.8.1/plugins/charmap/charmap.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/charmap/charmap.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=charmap

-  IAge=3

-  _Name=Character Map

- --- gedit-plugins-3.8.1/plugins/codecomment/codecomment.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/codecomment/codecomment.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=codecomment

-  IAge=3

-  _Name=Code comment

- --- gedit-plugins-3.8.1/plugins/codecomment/codecomment.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/codecomment/codecomment.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=codecomment

-  IAge=3

-  _Name=Code comment

- --- gedit-plugins-3.8.1/plugins/colorpicker/colorpicker.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/colorpicker/colorpicker.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=colorpicker

-  IAge=3

-  _Name=Color Picker

- --- gedit-plugins-3.8.1/plugins/colorpicker/colorpicker.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/colorpicker/colorpicker.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=colorpicker

-  IAge=3

-  _Name=Color Picker

- --- gedit-plugins-3.8.1/plugins/colorschemer/colorschemer.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/colorschemer/colorschemer.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=colorschemer

-  IAge=3

-  _Name=Color Scheme Editor

- --- gedit-plugins-3.8.1/plugins/colorschemer/colorschemer.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/colorschemer/colorschemer.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=colorschemer

-  IAge=3

-  _Name=Color Scheme Editor

- --- gedit-plugins-3.8.1/plugins/commander/commander.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/commander/commander.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=commander

-  IAge=3

-  _Name=Commander

- --- gedit-plugins-3.8.1/plugins/commander/commander.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/commander/commander.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=commander

-  IAge=3

-  _Name=Commander

- --- gedit-plugins-3.8.1/plugins/dashboard/dashboard.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/dashboard/dashboard.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=dashboard

-  IAge=3

-  _Name=Dashboard

- --- gedit-plugins-3.8.1/plugins/dashboard/dashboard.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/dashboard/dashboard.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=dashboard

-  IAge=3

-  _Name=Dashboard

- --- gedit-plugins-3.8.1/plugins/joinlines/joinlines.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/joinlines/joinlines.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=joinlines

-  IAge=3

-  _Name=Join/Split Lines

- --- gedit-plugins-3.8.1/plugins/joinlines/joinlines.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/joinlines/joinlines.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=joinlines

-  IAge=3

-  _Name=Join/Split Lines

- --- gedit-plugins-3.8.1/plugins/multiedit/multiedit.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/multiedit/multiedit.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=multiedit

-  IAge=3

-  _Name=Multi Edit

- --- gedit-plugins-3.8.1/plugins/multiedit/multiedit.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/multiedit/multiedit.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=multiedit

-  IAge=3

-  _Name=Multi Edit

- --- gedit-plugins-3.8.1/plugins/smartspaces/smartspaces.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/smartspaces/smartspaces.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=smartspaces

-  IAge=3

-  _Name=Smart Spaces

- --- gedit-plugins-3.8.1/plugins/smartspaces/smartspaces.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/smartspaces/smartspaces.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=smartspaces

-  IAge=3

-  _Name=Smart Spaces

- --- gedit-plugins-3.8.1/plugins/synctex/synctex.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/synctex/synctex.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=synctex

-  IAge=3

-  _Name=SyncTeX

- --- gedit-plugins-3.8.1/plugins/synctex/synctex.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/synctex/synctex.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=synctex

-  IAge=3

-  _Name=SyncTeX

- --- gedit-plugins-3.8.1/plugins/terminal/terminal.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/terminal/terminal.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=terminal

-  IAge=3

-  _Name=Embedded Terminal

- --- gedit-plugins-3.8.1/plugins/terminal/terminal.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/terminal/terminal.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=terminal

-  IAge=3

-  _Name=Embedded Terminal

- --- gedit-plugins-3.8.1/plugins/textsize/textsize.plugin.desktop.in

- +++ gedit-plugins-3.8.1/plugins/textsize/textsize.plugin.desktop.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=textsize

-  IAge=3

-  _Name=Text Size

- --- gedit-plugins-3.8.1/plugins/textsize/textsize.plugin.desktop.in.in

- +++ gedit-plugins-3.8.1/plugins/textsize/textsize.plugin.desktop.in.in

- @@ -1,5 +1,5 @@

-  [Plugin]

- -Loader=python3

- +Loader=python

-  Module=textsize

-  IAge=3

-  _Name=Text Size

file modified
+33 -37

@@ -2,23 +2,18 @@ 

  # https://fedoraproject.org/wiki/Changes/No_more_automagic_Python_bytecompilation_phase_2

  %global _python_bytecompile_extra 1

  

- %if 0%{?fedora} > 12

- %global with_zeitgeist 1

- %else

- %global with_zeitgeist 0

- %endif

- 

  %global __python %{__python3}

  

  Name:           gedit-plugins

- Version:        3.32.2

- Release:        2%{?dist}

+ Version:        3.33.90

+ Release:        1%{?dist}

  Summary:        Plugins for gedit

  

  License:        GPLv2+

  URL:            https://wiki.gnome.org/Apps/Gedit

- Source0:        https://download.gnome.org/sources/%{name}/3.32/%{name}-%{version}.tar.xz

+ Source0:        https://download.gnome.org/sources/%{name}/3.33/%{name}-%{version}.tar.xz

  

+ BuildRequires:  meson

  BuildRequires:  gedit-devel

  BuildRequires:  gnome-doc-utils

  BuildRequires:  gtksourceview4-devel

@@ -38,7 +33,7 @@ 

  BuildRequires:  libgit2-glib-devel

  BuildRequires:  yelp-tools

  BuildRequires:  itstool

- %if %{with_zeitgeist}

+ %if 0%{?fedora}

  BuildRequires:  zeitgeist-devel

  %endif

  

@@ -55,13 +50,13 @@ 

  Requires:       gedit-plugin-git

  Requires:       gedit-plugin-joinlines

  Requires:       gedit-plugin-multiedit

+ Requires:       gedit-plugin-sessionsaver

  Requires:       gedit-plugin-smartspaces

- Requires:       gedit-plugin-synctex

  Requires:       gedit-plugin-terminal

  Requires:       gedit-plugin-textsize

  Requires:       gedit-plugin-translate

  Requires:       gedit-plugin-wordcompletion

- %if %{with_zeitgeist}

+ %if 0%{?fedora}

  Requires:       gedit-plugin-zeitgeist

  %endif

  

@@ -158,6 +153,13 @@ 

  %description -n gedit-plugin-multiedit

  The gedit multiedit plugin.

  

+ %package -n     gedit-plugin-sessionsaver

+ Summary:        gedit sessionsaver plugin

+ Requires:       %{name}-data = %{version}-%{release}

+ Requires:       libpeas-loader-python3%{?_isa}

+ %description -n gedit-plugin-sessionsaver

+ The gedit sessionsaver plugin.

+ 

  %package -n     gedit-plugin-smartspaces

  Summary:        gedit smartspaces plugin

  Requires:       %{name}-data = %{version}-%{release}

@@ -165,13 +167,6 @@ 

  %description -n gedit-plugin-smartspaces

  The gedit smartspaces plugin.

  

- %package -n     gedit-plugin-synctex

- Summary:        gedit synctex plugin

- Requires:       %{name}-data = %{version}-%{release}

- Requires:       libpeas-loader-python3%{?_isa}

- %description -n gedit-plugin-synctex

- The gedit synctex plugin.

- 

  %package -n     gedit-plugin-terminal

  Summary:        gedit terminal plugin

  Requires:       %{name}-data = %{version}-%{release}

@@ -200,7 +195,7 @@ 

  %description -n gedit-plugin-wordcompletion

  The gedit wordcompletion plugin.

  

- %if %{with_zeitgeist}

+ %if 0%{?fedora}

  %package -n     gedit-plugin-zeitgeist

  Summary:        gedit zeitgeist plugin

  Requires:       %{name}-data = %{version}-%{release}

@@ -211,28 +206,22 @@ 

  %endif

  

  %prep

- %setup -q

+ %autosetup -p1

  

  %build

- %if %{with_zeitgeist}

- %configure --enable-python

- %else

- %configure --enable-python --disable-zeitgeist

- %endif

- make %{?_smp_mflags}

- 

+ %meson

+ %meson_build

  

  %install

- %make_install

+ %meson_install

+ 

  %find_lang %{name} --with-gnome

  %find_lang gedit --with-gnome

  find $RPM_BUILD_ROOT/%{_libdir}/gedit/plugins -name "*.la" -exec rm {} \;

  

- 

  %check

  [ -f ${RPM_BUILD_ROOT}%{_libdir}/gedit/plugins/terminal.py ]

  

- 

  # Empty files section for the metapackage to make sure it's created

  %files

  

@@ -308,16 +297,16 @@ 

  %{_libdir}/gedit/plugins/multiedit.plugin

  %{_datadir}/metainfo/gedit-multiedit.metainfo.xml

  

+ %files -n gedit-plugin-sessionsaver

+ %{_datadir}/gedit/plugins/sessionsaver

+ %{_libdir}/gedit/plugins/sessionsaver

+ %{_libdir}/gedit/plugins/sessionsaver.plugin

+ 

  %files -n gedit-plugin-smartspaces

  %{_libdir}/gedit/plugins/__pycache__/smartspaces.*

  %{_libdir}/gedit/plugins/smartspaces.*

  %{_datadir}/metainfo/gedit-smartspaces.metainfo.xml

  

- %files -n gedit-plugin-synctex

- %{_libdir}/gedit/plugins/synctex

- %{_libdir}/gedit/plugins/synctex.plugin

- %{_datadir}/metainfo/gedit-synctex.metainfo.xml

- 

  %files -n gedit-plugin-terminal

  %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.terminal.gschema.xml

  %{_libdir}/gedit/plugins/__pycache__/terminal.*

@@ -342,7 +331,7 @@ 

  %{_libdir}/gedit/plugins/wordcompletion.plugin

  %{_datadir}/metainfo/gedit-wordcompletion.metainfo.xml

  

- %if %{with_zeitgeist}

+ %if 0%{?fedora}

  %files -n gedit-plugin-zeitgeist

  %{_libdir}/gedit/plugins/libzeitgeist.so

  %{_libdir}/gedit/plugins/zeitgeist.plugin

@@ -350,6 +339,13 @@ 

  %endif

  

  %changelog

+ * Thu Aug 08 2019 Phil Wyett <philwyett@kathenas.org> - 3.33.90-1

+ - Update to 3.33.90.

+ - This release removes 'synctex' plugin.

+ - This release adds new 'sessionsaver' plugin.

+ - Update 'zeitgeist' plugin conditonal. Fedora only, not in RHEL.

+ - Remove old patches.

+ 

  * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.32.2-2

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

  

file modified
+1 -1

@@ -1,1 +1,1 @@ 

- SHA512 (gedit-plugins-3.32.2.tar.xz) = 2767bc766daba5e1c81ef5a00bc3589a301c02e0286a6622cf11a03b5b391ecbcf9456187563dad4f2916610ee9ddca4414ff4beb639820954385ee3f8091d2a

+ SHA512 (gedit-plugins-3.33.90.tar.xz) = 495d07de2569cb93732074fbb14e7e10c2714f8c8e2ba4200e65af3e120b77973a3c3880bf3e05200939499a94bf055ecd31aa9915fb3e2689f834b15b3b5ce8

  • Update to 3.33.90.
  • This release removes 'synctex' plugin.
  • This release adds new 'sessionsaver' plugin.
  • Removed conditional for not building 'gedit-plugin-zeitgeist' on fedora < 13.
  • Remove old patches.

Note: tarball for this release has been uploaded.

Thanks for the PR. Just two small nits:

1) Can you add the zeitgeist conditional back, please? We don't have zeitgeist in RHEL and it's useful for keeping the spec files in sync. Feel free to remove the "< 13" part and just keep it conditionalized on fedora.

2) Instead of "%autosetup", please use "%autosetup -p1".

rebased onto 7e4657d

2 months ago

Thanks for the PR. Just two small nits:
1) Can you add the zeitgeist conditional back, please? We don't have zeitgeist in RHEL and it's useful for keeping the spec files in sync. Feel free to remove the "< 13" part and just keep it conditionalized on fedora.
2) Instead of "%autosetup", please use "%autosetup -p1".

Updated. Hope this is now OK.

Thanks, looks good to me!

I've merged this manually. The web interface didn't let me merge it for reasons unknown.

Pull-Request has been closed by kalev

2 months ago