Blob Blame History Raw
# Generated by go2rpm 1.9.0
%bcond_without check
%global debug_package %{nil}

# https://github.com/go-retry/retry
%global goipath         gopkg.in/retry.v1
%global forgeurl        https://github.com/go-retry/retry
Version:                1.0.3

%gometa

%global common_description %{expand:
Package retry provides a framework for retrying actions. It does not itself
invoke the action to be retried, but is intended to be used in a retry loop.}

%global golicenses      LICENSE
%global godocs          README.md

Name:           %{goname}
Release:        %autorelease
Summary:        Simple retry mechanism for Go

License:        LGPL-3.0-or-later WITH LGPL-3.0-linking-exception
URL:            %{gourl}
Source0:        %{gosource}

%description %{common_description}

%gopkg

%prep
%goprep
%autopatch -p1
sed -i "s|github.com/rogpeppe/clock|github.com/juju/clock|" $(find . -iname "*.go" -type f)
# Needs github.com/juju/clock which needs too many deps with no other use
rm -rfv retry_test.go

%generate_buildrequires
%go_generate_buildrequires

%install
%gopkginstall

%if %{with check}
%check
%gocheck
%endif

%gopkgfiles

%changelog
%autochangelog