#16 Drop one use of which and requirements on it
Closed 3 months ago by rharwood. Opened 5 months ago by zbyszek.
rpms/ zbyszek/grub2 drop-which  into  rawhide

@@ -263,7 +263,7 @@ 

  +}

  +

  +# Make BLS the default if GRUB_ENABLE_BLSCFG was not set and grubby is not installed.

- +if [ -z "${GRUB_ENABLE_BLSCFG}" ] && [ -z "$(which new-kernel-pkg 2> /dev/null)" ]; then

+ +if [ -z "${GRUB_ENABLE_BLSCFG}" ] && ! command -v new-kernel-pkg >/dev/null; then

  +	  GRUB_ENABLE_BLSCFG="true"

  +fi

  +

file modified
+8 -5
@@ -81,7 +81,9 @@ 

  Summary:	grub2 common layout

  BuildArch:	noarch

  Conflicts:	grubby < 8.40-18

- Requires(post): util-linux

+ Requires(posttrans): util-linux-core

+ Requires(posttrans): coreutils

+ Requires(posttrans): grep

  

  %description common

  This package provides some directories which are required by various grub2
@@ -91,9 +93,10 @@ 

  Summary:	Support tools for GRUB.

  Obsoletes:	%{name}-tools < %{evr}

  Requires:	%{name}-common = %{epoch}:%{version}-%{release}

- Requires:	gettext os-prober which file

+ Requires:	gettext os-prober file

  Requires(pre):	dracut

- Requires(post):	dracut

+ Requires(pre):	grep

+ Requires(pre):	sed

  

  %description tools

  %{desc}
@@ -102,7 +105,7 @@ 

  %ifarch x86_64

  %package tools-efi

  Summary:	Support tools for GRUB.

- Requires:	gettext os-prober which file

+ Requires:	gettext os-prober file

  Requires:	%{name}-common = %{epoch}:%{version}-%{release}

  Obsoletes:	%{name}-tools < %{evr}

  
@@ -123,7 +126,7 @@ 

  

  %package tools-extra

  Summary:	Support tools for GRUB.

- Requires:	gettext os-prober which file

+ Requires:	gettext os-prober file

  Requires:	%{name}-tools-minimal = %{epoch}:%{version}-%{release}

  Requires:	%{name}-common = %{epoch}:%{version}-%{release}

  Obsoletes:	%{name}-tools < %{evr}

Other uses were dropped in 46968b6.

grub2-tools is one of the few packages in the critical set that pulls
in which, a seperate package, see
https://bugzilla.redhat.com/show_bug.cgi?id=2018913.

Build failed. More information on how to proceed and troubleshoot errors available at https://fedoraproject.org/wiki/Zuul-based-ci

1 new commit added

  • Adjust requirements for scriptlets
5 months ago

Build failed. More information on how to proceed and troubleshoot errors available at https://fedoraproject.org/wiki/Zuul-based-ci

Just for transparency, I am planning to merge this before the end of the month. Since it changes one of the patches in series, there's some shuffling that I would prefer to land first.

Applied as 2e106f9 ; building as grub2-2.06-34.fc37

Pull-Request has been closed by rharwood

3 months ago