#7 Do not require systemd at runtime
Closed 2 years ago by jorton. Opened 2 years ago by tdawson.
rpms/ tdawson/httpd no-systemd  into  master

file modified
-3
@@ -100,9 +100,6 @@ 

  Requires: httpd-filesystem = %{version}-%{release}

  Requires: mod_http2

  Requires(pre): httpd-filesystem

- Requires(preun): systemd-units

- Requires(postun): systemd-units

- Requires(post): systemd-units

  Conflicts: apr < 1.5.0-1

  Provides: mod_proxy_uwsgi = %{version}-%{release}

  Obsoletes: mod_proxy_uwsgi < 2.0.17.1-2

Sometimes systemd is not wanted to start the httpd deamon. An example of this is in containers.
Forcing the package to install systemd when it isn't needed, or wanted, causes bloat in the Fedora containers.
https://pagure.io/minimization/issue/2

Has ownership of /usr/lib/systemd/... moved from systemd? Otherwise surely this dep is correct for packages which ship .service files.

Also /usr/sbin/apachectl requires/usr/bin/systemctl so this dep is required for that reason too. It may be possible to produce a systemd-independent httpd but simply dropping the dep is not correct.

Has ownership of /usr/lib/systemd/... moved from systemd? Otherwise surely this dep is correct for packages which ship .service files.

I has been determined that it's optional to require systemd with .service files. This is mainly due to containers.
https://pagure.io/packaging-committee/pull-request/890

Also /usr/sbin/apachectl requires/usr/bin/systemctl so this dep is required for that reason too. It may be possible to produce a systemd-independent httpd but simply dropping the dep is not correct.

You are correct. Because apachectl requires systemctl, we cannot simply drop systemd.

But the goal is the still there, to trim down the httpd container.

For avoidance of doubt we are not planning to drop systemd support from httpd, so I am closing this since there is no concrete proposal on how to "improve" things here.

Pull-Request has been closed by jorton

2 years ago

Understood.
Thank you for taking the time to look at it.