#1 update to version 1.18
Merged 4 months ago by decathorpe. Opened 4 months ago by decathorpe.

file modified
+4 -3

@@ -1,9 +1,10 @@

+ /results_*

+ /*.src.rpm

+ 

  /jansi-1.6.tar.xz

  /jansi-1.9.tar.xz

  /jansi-1.11.tar.xz

- /noarch

- /.build-*.log

- /*.src.rpm

  /jansi-project-1.16.tar.gz

  /jansi-project-1.17.tar.gz

  /jansi-project-1.17.1.tar.gz

+ /jansi-project-1.18.tar.gz

file modified
+5 -2

@@ -1,6 +1,6 @@

  Name:             jansi

- Version:          1.17.1

- Release:          3%{?dist}

+ Version:          1.18

+ Release:          1%{?dist}

  Summary:          Jansi is a java library for generating and interpreting ANSI escape sequences

  License:          ASL 2.0

  URL:              http://fusesource.github.io/jansi/

@@ -68,6 +68,9 @@

  %license license.txt

  

  %changelog

+ * Sat Jun 08 2019 Fabio Valentini <decathorpe@gmail.com> - 1.18-1

+ - Update to version 1.18.

+ 

  * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.17.1-3

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

  

file modified
+1 -1

@@ -1,1 +1,1 @@

- SHA512 (jansi-project-1.17.1.tar.gz) = 06b7b36fd655979c35df7b6a4a4f2451d343fb20c0b8b3e2bdaad7ad64b41a3af1c25d78d00e7e78b1ee17dafbe77b5d6f1c118c2d11e280d7aba8075e34a1f0

+ SHA512 (jansi-project-1.18.tar.gz) = d34f271853250d4b23987c0b4d2eeadd9fdb1211b2f5187258bb43e2741d8263312ee04c9a39812550eb658853668a5e941ff3978682cea47c059c6ba85d3e9d

Test rebuilds of all dependent packages happened here:
https://copr.fedorainfracloud.org/coprs/decathorpe/jansi-pr/monitor/

I checked all failures against koschei, and the packages are either already broken, or the build failure is unrelated to this update according to the build logs (probably caused by race conditions in the packages' test suites or something).

Looks good from packaging perspective; LGTM.

Just wondering where 1.18 comes from. I think 1.17.1 is the latest version according to the upstream link. Do you need to update the spec URL as well?

Interesting, I see now. Maven has 1.18 but the upstream website doesn't list it. Ah well, LGTM.

Pull-Request has been merged by decathorpe

4 months ago