Blob Blame Raw
Name:           javapackages-tools
Version:        0.7.2
Release:        1%{?dist}
Summary:        Fedora macros and scripts for Java packaging support

License:        BSD
URL:            https://fedorahosted.org/javapackages/
Source0:        https://fedorahosted.org/released/javapackages/javapackages-%{version}.tar.xz

BuildArch:      noarch
Requires:       libxslt
Requires:       python

Conflicts:      jpackage-utils < 1.7.5-17

%description
Fedora macros and scripts for Java packaging support


%prep
%setup -q -n javapackages-%{version}

%build

%install
install -m0755 -D depgenerators/maven.prov $RPM_BUILD_ROOT%{_rpmconfigdir}/maven.prov
install -m0755 -D depgenerators/osgi.prov $RPM_BUILD_ROOT%{_rpmconfigdir}/osgi.prov
install -m0755 -D depgenerators/osgi.req $RPM_BUILD_ROOT%{_rpmconfigdir}/osgi.req
# Add the maven poms file attribute entry (rpm >= 4.9.0)
install -m0644 -D depgenerators/fileattrs/maven.attr \
                  $RPM_BUILD_ROOT%{_rpmconfigdir}/fileattrs/maven.attr
install -m0644 -D depgenerators/fileattrs/osgi.attr \
                  $RPM_BUILD_ROOT%{_rpmconfigdir}/fileattrs/osgi.attr

install -pm 644 -D macros.fjava ${RPM_BUILD_ROOT}%{_sysconfdir}/rpm/macros.fjava
install -dm 755 $RPM_BUILD_ROOT%{_javadir}-utils/
install -pm 644 scripts/maven_depmap.py $RPM_BUILD_ROOT%{_javadir}-utils/
install -pm 644 scripts/pom_editor.sh $RPM_BUILD_ROOT%{_javadir}-utils/


%files
%doc LICENSE
%dir %{_rpmconfigdir}/fileattrs
%{_rpmconfigdir}/fileattrs/*.attr
%{_rpmconfigdir}/*.prov
%{_rpmconfigdir}/*.req
# The python file is compiled producing .pyc and .pyo, which we need to include
%{_javadir}-utils/maven_depmap.py*
%{_javadir}-utils/pom_editor.sh
%config(noreplace) %{_sysconfdir}/rpm/macros.fjava


%changelog
* Wed Oct 31 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.7.2-1
- Make sure add_maven_depmap fails when python tracebacks

* Wed Oct 31 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.7.1-1
- Fix problem with exception in default add_maven_depmap invocation

* Tue Oct 30 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.7.0-1
- Update to latest upstream
- Full support for compat depmap generation
- Generate maven-files-%%{name} with a list of files to package
- Add support for maven repo generation (alpha version)

* Mon Jul 30 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.6.0-1
- Update to upstream version 0.6.0
- Make maven provides versioned
- Add additional pom_ macros to simplify additional pom editing

* Wed Jul 25 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.5.0-1
- Update to upstream version 0.5.0 - add support for add_maven_depmap -v

* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

* Mon Jul  9 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.4.1-1
- Update to upstream version 0.4.1
- Fixes #837203

* Wed Jun 27 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0.4.0-1
- Update to upstream version 0.4.0

* Tue Mar  6 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.3.1-1
- Create maven provides from fragments instead of poms

* Thu Feb 16 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.3.0-3
- Fix maven_depmap installation

* Wed Feb 15 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.3.0-2
- Add conflicts with older jpackage-utils

* Wed Feb 15 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.3.0-1
- Initial version split from jpackage-utils