Blob Blame History Raw
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
# CONFIG_SMP is not set

# CONFIG_CMDLINE_FORCE is not set

CONFIG_CC_OPTIMIZE_FOR_SIZE=y

CONFIG_ARCH_VERSATILE=y
CONFIG_ARCH_VERSATILE_PB=y
CONFIG_MACH_VERSATILE_AB=y
CONFIG_MACH_VERSATILE_DT=y

CONFIG_HIGHMEM=y
# CONFIG_HIGHPTE is not set

# CONFIG_CPU_ICACHE_DISABLE is not set
# CONFIG_CPU_DCACHE_DISABLE is not set
# CONFIG_CPU_DCACHE_WRITETHROUGH is not set
# CONFIG_CPU_CACHE_ROUND_ROBIN is not set

CONFIG_ZBOOT_ROM_TEXT=0
CONFIG_ZBOOT_ROM_BSS=0

# CONFIG_XIP_KERNEL is not set

CONFIG_ATAGS_PROC=y

CONFIG_CPU_IDLE=y
# CONFIG_CPU_IDLE_GOV_LADDER is not set
ONFIG_CPU_IDLE_GOV_MENU=y

CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y

# CONFIG_FPE_NWFPE is not set
CONFIG_FPE_FASTFPE=y
CONFIG_VFP=y

CONFIG_PM=y
# CONFIG_PM_DEBUG is not set
# CONFIG_PM_TRACE is not set
CONFIG_SUSPEND=y
# CONFIG_PM_TEST_SUSPEND is not set
CONFIG_APM_EMULATION=y

CONFIG_ARM_THUMB=y

CONFIG_AEABI=y
CONFIG_OABI_COMPAT=y

CONFIG_HW_PERF_EVENTS=y

# CONFIG_UACCESS_WITH_MEMCPY is not set

CONFIG_CMDLINE="console=ttyAM0,115200 root=/dev/sda1 rootdelay=20"

CONFIG_LEDS=y
CONFIG_LEDS_CPU=y

CONFIG_MTD_AFS_PARTS=y
CONFIG_MTD_ARM_INTEGRATOR=y
CONFIG_MTD_IMPA7=y

CONFIG_AX88796=m
CONFIG_AX88796_93CX6=y
CONFIG_SMC91X=m
CONFIG_DM9000=m
CONFIG_DM9000_DEBUGLEVEL=4
# CONFIG_DM9000_FORCE_SIMPLE_PHY_POLL is not set
CONFIG_SMC911X=m
CONFIG_SMSC911X=m

CONFIG_SERIO_AMBAKMI=m

CONFIG_SERIAL_AMBA_PL011=y
CONFIG_SERIAL_AMBA_PL011_CONSOLE=y

CONFIG_I2C_VERSATILE=y

CONFIG_THERMAL=y

# CONFIG_MFD_T7L66XB is not set
# CONFIG_MFD_TC6387XB is not set

CONFIG_FB_ARMCLCD=m

CONFIG_SND_ARM=y
CONFIG_SND_ARMAACI=m
CONFIG_SND_SOC=m
# CONFIG_SND_SOC_CACHE_LZO is not set
# CONFIG_SND_SOC_ALL_CODECS is not set

CONFIG_USB_MUSB_HDRC=y
CONFIG_MUSB_PIO_ONLY=y
CONFIG_USB_TUSB6010=y
# CONFIG_USB_MUSB_DEBUG is not set

CONFIG_MMC_ARMMMCI=m
CONFIG_MMC_DW=m
# CONFIG_MMC_DW_IDMAC is not set

CONFIG_RTC_DRV_PL030=m
CONFIG_RTC_DRV_PL031=m

# CONFIG_SGI_IOC4 is not set

# CONFIG_DEBUG_USER is not set
# CONFIG_DEBUG_ERRORS is not set
# CONFIG_DEBUG_LL is not set

CONFIG_ARM_UNWIND=y

CONFIG_RCU_FANOUT=32

# CONFIG_USB_ULPI is not set
# CONFIG_OC_ETM is not set

# CONFIG_MTD_PISMO is not set

CONFIG_PERF_EVENTS=y
CONFIG_PERF_COUNTERS=y

# CONFIG_MG_DISK is not set
# CONFIG_GPIO_PL061 is not set

CONFIG_CC_STACKPROTECTOR=y

CONFIG_AUTO_ZRELADDR=y

# CONFIG_ARM_CHARLCD is not set
# CONFIG_DEPRECATED_PARAM_STRUCT is not set

# CONFIG_ARM_SP805_WATCHDOG is not set

CONFIG_PM_OPP=y

CONFIG_SECCOMP=y
CONFIG_STRICT_DEVMEM=y

# CONFIG_AMBA_PL08X is not set

# CONFIG_HVC_DCC is not set

CONFIG_SPARSE_IRQ=y

# CONFIG_ARM_PATCH_PHYS_VIRT is not set

CONFIG_HWSPINLOCK_OMAP=m

CONFIG_USE_OF=y
CONFIG_PROC_DEVICETREE=y
CONFIG_MTD_PHYSMAP_OF=m
CONFIG_SERIAL_OF_PLATFORM=m
CONFIG_MMC_SDHCI_OF=m
CONFIG_MMC_SDHCI_PXAV3=m
CONFIG_MMC_SDHCI_PXAV2=m

CONFIG_ARM_APPENDED_DTB=y
CONFIG_MTD_OF_PARTS=y
CONFIG_PL330_DMA=y
# CONFIG_ARM_KPROBES_TEST is not set
# CONFIG_ARM_ATAG_DTB_COMPAT is not set

# CONFIG_FTGMAC100 is not set
# CONFIG_FTMAC100 is not set
#
CONFIG_DEFAULT_MMAP_MIN_ADDR=32768
CONFIG_LSM_MMAP_MIN_ADDR=32768

# disable TPM on arm at least on the trimslices it causes havoc
# CONFIG_TCG_TPM is not set
# CONFIG_IMA is not set

# ERROR: "__bswapsi2" [drivers/staging/crystalhd/crystalhd.ko] undefined!
# CONFIG_CRYSTALHD is not set

# these modules all fail with missing __bad_udelay
# http://www.spinics.net/lists/arm/msg15615.html provides some background
# CONFIG_SUNGEM is not set
# CONFIG_FB_SAVAGE is not set
# CONFIG_FB_RADEON is not set
# CONFIG_DRM_RADEON is not set
# CONFIG_ATM_HE is not set
# CONFIG_SCSI_ACARD is not set
# CONFIG_SFC is not set

# these all currently fail due to missing symbols __bad_udelay or
# error: implicit declaration of function ‘iowrite32be’
# CONFIG_SND_ALI5451 is not set
# CONFIG_DRM_NOUVEAU is not set 
# CONFIG_MLX4_EN is not set

# drivers/input/touchscreen/eeti_ts.c:65:2: error: implicit declaration of function 'irq_to_gpio' [-Werror=implicit-function-declaration]
# CONFIG_TOUCHSCREEN_EETI is not set
# CONFIG_TOUCHSCREEN_EGALAX is not set 
# CONFIG_TOUCHSCREEN_AUO_PIXCIR is not set
#
# FIXME: Guesses, need checking
# CONFIG_MACH_EUKREA_CPUIMX35SD is not set
CONFIG_ARM_ERRATA_720789=y
CONFIG_ARM_ERRATA_751472=y
# CONFIG_FB_MX3 is not set
# CONFIG_MX3_IPU is not set
# CONFIG_MX3_IPU_IRQS is not set

# CONFIG_NET_VENDOR_CIRRUS is not set
# CONFIG_CS89x0 is not set

# CONFIG_OF_SELFTEST is not set
# CONFIG_MACH_IMX51_DT is not set
# CONFIG_MACH_IMX53_DT is not set
# CONFIG_MACH_MX53_EVK is not set
# CONFIG_MACH_MX53_SMD is not set
# CONFIG_MACH_MX53_LOCO is not set
# CONFIG_MACH_MX53_ARD is not set
# CONFIG_ARM_EXYNOS4210_CPUFREQ is not set

CONFIG_OF_GPIO=y