#31 armv7hl: enable the OLPC XO-1.75 embedded controller and battery
Closed 2 months ago by pbrobinson. Opened 2 months ago by lkundrak.
rpms/ lkundrak/kernel lr/olpc-xo175-ec  into  master

@@ -0,0 +1,1 @@ 

+ CONFIG_OLPC_XO175_EC=m

@@ -0,0 +1,1 @@ 

+ CONFIG_SPI_SLAVE=y

@@ -0,0 +1,1 @@ 

+ # CONFIG_SPI_SLAVE_SYSTEM_CONTROL is not set

@@ -0,0 +1,1 @@ 

+ # CONFIG_SPI_SLAVE_TIME is not set

file modified
+4 -1

@@ -4389,6 +4389,7 @@ 

  # CONFIG_OF_UNITTEST is not set

  CONFIG_OF=y

  CONFIG_OLPC_EC=y

+ CONFIG_OLPC_XO175_EC=m

  CONFIG_OLPC_XO175=y

  # CONFIG_OMAP2_DSS_DEBUGFS is not set

  # CONFIG_OMAP2_DSS_DEBUG is not set

@@ -6362,7 +6363,9 @@ 

  CONFIG_SPI_S3C64XX=m

  # CONFIG_SPI_SC18IS602 is not set

  # CONFIG_SPI_SIFIVE is not set

- # CONFIG_SPI_SLAVE is not set

+ # CONFIG_SPI_SLAVE_SYSTEM_CONTROL is not set

+ # CONFIG_SPI_SLAVE_TIME is not set

+ CONFIG_SPI_SLAVE=y

  CONFIG_SPI_SPIDEV=m

  CONFIG_SPI_STM32=m

  CONFIG_SPI_STM32_QSPI=m

file modified
+4 -1

@@ -4370,6 +4370,7 @@ 

  # CONFIG_OF_UNITTEST is not set

  CONFIG_OF=y

  CONFIG_OLPC_EC=y

+ CONFIG_OLPC_XO175_EC=m

  CONFIG_OLPC_XO175=y

  # CONFIG_OMAP2_DSS_DEBUGFS is not set

  # CONFIG_OMAP2_DSS_DEBUG is not set

@@ -6341,7 +6342,9 @@ 

  CONFIG_SPI_S3C64XX=m

  # CONFIG_SPI_SC18IS602 is not set

  # CONFIG_SPI_SIFIVE is not set

- # CONFIG_SPI_SLAVE is not set

+ # CONFIG_SPI_SLAVE_SYSTEM_CONTROL is not set

+ # CONFIG_SPI_SLAVE_TIME is not set

+ CONFIG_SPI_SLAVE=y

  CONFIG_SPI_SPIDEV=m

  CONFIG_SPI_STM32=m

  CONFIG_SPI_STM32_QSPI=m