Blame komikku.spec

5a1203d
%global appname Komikku
5a1203d
%global uuid    info.febvre.%{appname}
5a1203d
5a1203d
Name:           komikku
76621e2
Version:        0.16.0
32f2b35
Release:        1%{?dist}
5a1203d
Summary:        Online/offline manga reader for GNOME
5a1203d
5a1203d
License:        GPLv3+
5a1203d
URL:            https://gitlab.com/valos/Komikku
5a1203d
Source0:        %{url}/-/archive/v%{version}/%{appname}-v%{version}.tar.gz
75f9337
Source1:        https://gitlab.gnome.org/GNOME/libhandy/-/archive/v0.80.0/libhandy-v0.80.0.tar.gz
75f9337
75f9337
# Build arched temporary until libhandy-1 landed in Fedora
75f9337
#BuildArch:      noarch
5a1203d
5a1203d
BuildRequires:  desktop-file-utils
5a1203d
BuildRequires:  intltool
5a1203d
BuildRequires:  libappstream-glib
5a1203d
BuildRequires:  libhandy-devel >= 0.0.10
5a1203d
BuildRequires:  meson >= 0.50.0
5a1203d
BuildRequires:  python3-devel >= 3.6
5a1203d
BuildRequires:  pkgconfig(gobject-introspection-1.0)
5a1203d
BuildRequires:  pkgconfig(gtk+-3.0) >= 3.24.1
5a1203d
75f9337
# https://bugzilla.redhat.com/show_bug.cgi?id=1803912
75f9337
#BuildRequires:  pkgconfig(libhandy-1)
75f9337
75f9337
# For bundled libhandy-1
75f9337
BuildRequires:  pkgconfig(gladeui-2.0)
75f9337
BuildRequires:  vala
75f9337
5a1203d
Requires:       hicolor-icon-theme
5a1203d
Requires:       python3-beautifulsoup4
5a1203d
Requires:       python3-cloudscraper
5a1203d
Requires:       python3-dateparser
5a1203d
Requires:       python3-lxml
8c95e97
75f9337
Provides:       bundled(libhandy) = 0.80
75f9337
847fce2
# # This could help to build Komikku for current Fedora releases at least in Copr
847fce2
# # * https://bugzilla.redhat.com/show_bug.cgi?id=1790100#c9
847fce2
# Patch0 provides compatibility with the other magic package, solving a conflict
847fce2
# problem, opening komikku to f30, f31 and f32 and allowing users to use komikku,
847fce2
# rpmlint and other important packages simultaneously.
847fce2
#
847fce2
# The conflict between python-magic and python-file-magic should be brought to
847fce2
# FESCO.
a8b0b19
Requires:       python3dist(file-magic)
8c95e97
5a1203d
Requires:       python3-pillow
5a1203d
Requires:       python3-pure-protobuf
5a1203d
Requires:       python3-unidecode
5a1203d
5a1203d
%description
5a1203d
An online/offline manga reader for GNOME, developed with the aim of being used
5a1203d
with the Librem 5 phone.
5a1203d
5a1203d
5a1203d
%prep
a8b0b19
%autosetup -n %{appname}-v%{version} -p1
75f9337
%autosetup -n %{appname}-v%{version} -D -T -a1
5a1203d
5a1203d
5a1203d
%build
75f9337
# Build libhandy-1
75f9337
pushd libhandy-v0.80.0
75f9337
%meson \
75f9337
    -Dexamples=false \
75f9337
    -Dglade_catalog=disabled \
75f9337
    -Dgtk_doc=false \
75f9337
    -Dintrospection=enabled \
75f9337
    -Dvapi=false \
5a1203d
%meson_build
75f9337
%meson_install
75f9337
popd
5a1203d
75f9337
export PKG_CONFIG_PATH=%{buildroot}/usr/lib64/pkgconfig
75f9337
%meson
75f9337
%meson_build
5a1203d
%meson_install
5a1203d
%find_lang %{name}
5a1203d
75f9337
# Cleanup
75f9337
rm -rf %{buildroot}%{_includedir}/libhandy-1 \
75f9337
    %{buildroot}%{_libdir}/pkgconfig/ \
75f9337
    %{buildroot}/%{_datadir}/gir-1.0/
75f9337
5a1203d
5a1203d
%check
5a1203d
appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/*.xml
5a1203d
desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
5a1203d
5a1203d
5a1203d
%files -f %{name}.lang
5a1203d
%license LICENSE
5a1203d
%doc README.md
5a1203d
%{_bindir}/%{name}
5a1203d
%{_datadir}/%{name}/
5a1203d
%{_datadir}/applications/*.desktop
5a1203d
%{_datadir}/glib-2.0/schemas/*.gschema.xml
5a1203d
%{_datadir}/icons/hicolor/scalable/*/*.svg
5a1203d
%{_datadir}/icons/hicolor/symbolic/*/*.svg
5a1203d
%{_metainfodir}/*.xml
5a1203d
%{python3_sitelib}/%{name}/
5a1203d
75f9337
# Bundled libhandy-1
75f9337
%{_libdir}/girepository-1.0/Handy-1.typelib
75f9337
%{_libdir}/libhandy-1.so*
75f9337
5a1203d
5a1203d
%changelog
76621e2
* Sun May 24 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 0.16.0-1
76621e2
- Update to 0.16.0
75f9337
- Bundle libhandy-1
76621e2
32f2b35
* Fri Apr 24 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 0.15.0-1
32f2b35
- Update to 0.15.0
32f2b35
847fce2
* Tue Apr 14 2020 Lyes Saadi <fedora@lyes.eu> - 0.14.0-3
847fce2
- Compatibility with python3-file-magic
847fce2
8c95e97
* Thu Apr 02 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 0.14.0-2
8c95e97
- Specify required version of 'python3-magic' | RHBZ#1790100#c9
8c95e97
26455df
* Thu Apr 02 2020 Lyes Saadi <fedora@lyes.eu> - 0.14.0-1
26455df
- Update to 0.14.0
26455df
5a1203d
* Sun Mar 29 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 0.13.0-1
5a1203d
- Update to 0.13.0
5a1203d
5a1203d
* Fri Feb 21 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 0.11.1-1
5a1203d
- Initial package