#1 Update to 3.26.1
Closed 3 years ago by rishi. Opened 4 years ago by lkundrak.
rpms/ lkundrak/krb5-auth-dialog lr/libnm  into  master

file modified
+1
@@ -11,3 +11,4 @@ 

  /krb5-auth-dialog-3.15.1.tar.xz

  /krb5-auth-dialog-3.15.4.tar.xz

  /krb5-auth-dialog-3.20.0.tar.xz

+ /krb5-auth-dialog-3.26.1.tar.xz

file modified
+8 -4
@@ -1,11 +1,11 @@ 

  Summary: Kerberos 5 authentication dialog

  Name: krb5-auth-dialog

- Version: 3.20.0

- Release: 4%{?dist}

+ Version: 3.26.1

+ Release: 1%{?dist}

  License: GPLv2+

  Group: User Interface/X

  URL: https://honk.sigxcpu.org/piki/projects/krb5-auth-dialog/

- Source0: https://download.gnome.org/sources/%{name}/3.20/%{name}-%{version}.tar.xz

+ Source0: https://download.gnome.org/sources/%{name}/3.26/%{name}-%{version}.tar.xz

  

  # avoid annoying notifications

  Patch0: krb5-auth-dialog-autostart.patch
@@ -18,7 +18,7 @@ 

  BuildRequires: pkgconfig(gtk+-3.0)

  # libnotify support is required for configure, but not used.

  BuildRequires: pkgconfig(libnotify)

- BuildRequires: pkgconfig(libnm-glib)

+ BuildRequires: pkgconfig(libnm)

  BuildRequires: autoconf automake libtool

  

  %description
@@ -73,6 +73,10 @@ 

  

  

  %changelog

+ * Wed Nov 29 2017 Lubomir Rintel <lkundrak@v3.sk> - 3.26.1-1

+ - Update to 3.26.1

+ - Switch to libnm from libnm-glib

+ 

  * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.20.0-4

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

  

file modified
+1 -1
@@ -1,1 +1,1 @@ 

- 5eac2f521361e45c818aa9d695dd5902  krb5-auth-dialog-3.20.0.tar.xz

+ SHA512 (krb5-auth-dialog-3.26.1.tar.xz) = 8d0dd86cea8e354bb68db089a1d53ce9ef6c1e7a2330015cd615d0eeeeedd0cdd950e551e6a767bc29bf3706d2cccb1dd563bef186717a77e96e57dbc31f5957

krb5-auth-dialog is one of the few packages that keep using the long obsolete libnm-glib.
Update it to get rid of the dependency.

Sorry for the late response. Since then krb5-auth-dialog was updated to 3.26.1, but the NetworkManager dependency wasn't adjusted. Since libnm-glib support was dropped in 3.26.0, the lack of a BuildRequires on libnm meant that we actually lost the NetworkManager support.

Rebased and pushed to master:

commit 6a71c9e
Author: Lubomir Rintel lkundrak@v3.sk
Date: Wed Mar 21 11:17:30 2018 +0100

Restore NetworkManager support

Compatibility with libnm-glib was dropped in 3.26.0, and it only uses
libnm now.

https://src.fedoraproject.org/rpms/krb5-auth-dialog/pull-request/1

Pull-Request has been closed by rishi

3 years ago