#8 Fix FTBFS-Remove libpq-devel requirement, it conflicts with postgresql-server-devel dependencies
Closed 10 months ago by mkrupcale. Opened 11 months ago by fjanus.
rpms/ fjanus/libpqxx rawhide  into  rawhide

file modified
+5 -2
@@ -5,7 +5,7 @@ 

  Summary:        C++ client API for PostgreSQL

  Epoch:          1

  Version:        7.3.1

- Release:        5%{?dist}

+ Release:        6%{?dist}

  

  %global         forgeurl https://github.com/jtv/%{name}/

  %global         tag %{version}
@@ -19,7 +19,6 @@ 

  BuildRequires:  ninja-build

  BuildRequires:  cmake

  BuildRequires:  pkgconfig

- BuildRequires:  libpq-devel

  BuildRequires:  postgresql-server-devel

  %if %{with check}

  BuildRequires:  postgresql-test-rpm-macros
@@ -103,6 +102,10 @@ 

  %endif

  

  %changelog

+ * Tue Jul 27 2021 Filip Januš <fjanus@redhat.com> - 1:7.3.1-6

+ - Remove libpq-devel requirement, it conflicts with postgresql-server-devel

+   dependencies

+ 

  * Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:7.3.1-5

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

  

no initial comment

It looks like the CI failed due to a networking error, so I guess that can be ignored.

Regarding the change, I'm not actually sure libpqxx requires postgresql-server-devel instead of just the client library libpq-devel. So per [1], perhaps the change should be the reverse, but I'll have to do some testing (probably this weekend, maybe sometime this week).

[1] https://fedoraproject.org/wiki/Changes/PostgreSQL_13#Dependencies

Definitely is preferred to use libpq, but I am not sure what is for libpqxx necessary. If need both postgresql-server-devel and libpq-devel then there is only one option(remove libpq-devel) and use private verison of libpq-devel(postgresql-private-devel). If postgresql-server-devel is not necessary please use libpq-devel.

Pull-Request has been closed by mkrupcale

10 months ago
Metadata