#3 v.1.2.1
Closed 2 months ago by jcline. Opened 2 months ago by v02460.
https://pagure.io/matrix-synapse master  into  master

Update to v1.2.1
Kai A. Hiller • 2 months ago  
Update to v1.2.0
Kai A. Hiller • 2 months ago  
Update to v1.1.0
Kai A. Hiller • 2 months ago  
matrix-synapse.spec
file modified
+30 -25

@@ -3,7 +3,7 @@

  %{?python_enable_dependency_generator}

  

  Name:       matrix-%{srcname}

- Version:    1.0.0

+ Version:    1.2.1

  Release:    1%{?dist}

  Summary:    A Matrix reference homeserver written in Python using Twisted

  License:    ASL 2.0

@@ -11,54 +11,50 @@

  Source0:    %{url}/archive/v%{version}/%{srcname}-%{version}.tar.gz

  Source1:    synapse.sysconfig

  Source2:    synapse.service

- # The issues with prometheus_client compatibility are not resolved upstream yet:

- # https://github.com/matrix-org/synapse/issues/4221

- # but we can at least build and run with the newer version. That's better than

- # having a totally unusable matrix-synapse package...

- Patch1:     no-prometheus_client-pin.patch

  BuildArch:  noarch

  

  BuildRequires:  python3-devel

  BuildRequires:  python3-setuptools

  

  # Test dependencies

- BuildRequires:  python3-lxml

- BuildRequires:  python3-mock

+ BuildRequires:  python3-mock >= 2.0

  BuildRequires:  python3-parameterized

  BuildRequires:  /usr/bin/openssl

  

  # Package dependencies

  #BuildRequires:  python3-txacme >= 0.9.2

  BuildRequires:  python3-attrs >= 17.4.0

- BuildRequires:  python3-bcrypt

- BuildRequires:  python3-pyOpenSSL >= 0.15

+ BuildRequires:  python3-bcrypt >= 3.1.0

  BuildRequires:  python3-bleach >= 1.4.3

  BuildRequires:  python3-canonicaljson >= 1.1.3

- BuildRequires:  python3-daemonize

+ BuildRequires:  python3-daemonize >= 2.3.1

  BuildRequires:  python3-frozendict >= 1.0

- BuildRequires:  python3-idna >= 2

- BuildRequires:  python3-jinja2 >= 2.8

- BuildRequires:  python3-jsonschema

+ BuildRequires:  python3-idna >= 2.5

+ BuildRequires:  python3-jinja2 >= 2.9

+ BuildRequires:  python3-jsonschema >= 2.5.1

+ BuildRequires:  python3-lxml >= 3.5.0

  BuildRequires:  python3-matrix-synapse-ldap3 >= 0.1

- BuildRequires:  python3-msgpack >= 0.3.0

+ BuildRequires:  python3-msgpack >= 0.5.2

  BuildRequires:  python3-netaddr >= 0.7.18

  BuildRequires:  python3-phonenumbers >= 8.2.0

- BuildRequires:  python3-pillow

+ BuildRequires:  python3-pillow >= 4.3.0

+ BuildRequires:  python3-prometheus_client >= 0.0.18, python3-prometheus_client < 0.8.0

  BuildRequires:  python3-psutil >= 2.0.0

- BuildRequires:  python3-pyasn1

+ BuildRequires:  python3-pyOpenSSL >= 16.0.0

+ BuildRequires:  python3-pyasn1 >= 0.1.9

+ BuildRequires:  python3-pyasn1-modules >= 0.0.7

  BuildRequires:  python3-pymacaroons-pynacl >= 0.13.0

- BuildRequires:  python3-pynacl >= 1.2.0

- BuildRequires:  python3-pysaml2 >= 3.0.0

+ BuildRequires:  python3-pynacl >= 1.2.1

+ BuildRequires:  python3-pysaml2 >= 4.5.0

+ BuildRequires:  python3-pyyaml >= 3.11

  BuildRequires:  python3-service-identity >= 18.1.0

  BuildRequires:  python3-signedjson >= 1.0.0

- BuildRequires:  python3-six

- BuildRequires:  python3-sortedcontainers

- BuildRequires:  python3-systemd

+ BuildRequires:  python3-six >= 1.10

+ BuildRequires:  python3-sortedcontainers >= 1.4.4

+ BuildRequires:  python3-systemd >= 231

+ BuildRequires:  python3-treq >= 15.1

  BuildRequires:  python3-twisted >= 18.7.0

- BuildRequires:  python3-treq

  BuildRequires:  python3-unpaddedbase64 >= 1.1.0

- BuildRequires:  python3-prometheus_client

- BuildRequires:  python3-pyyaml

  BuildRequires:  systemd

  

  Requires(pre):  shadow-utils

@@ -129,6 +125,15 @@

  

  

  %changelog

+ * Fri Jul 26 2019 Kai A. Hiller <V02460@gmail.com> - 1.2.1-1

+ - Update to v1.2.1

+ 

+ * Thu Jul 25 2019 Kai A. Hiller <V02460@gmail.com> - 1.2.0-1

+ - Update to v1.2.0

+ 

+ * Wed Jul 17 2019 Kai A. Hiller <V02460@gmail.com> - 1.1.0-1

+ - Update to v1.1.0

+ 

  * Thu Jun 27 2019 Dan Callaghan <djc@djc.id.au> - 1.0.0-1

  - Update to v1.0.0 release, including new protocol-mandated TLS

    certificate verification logic. See:

no-prometheus_client-pin.patch
file removed
-12

@@ -1,12 +0,0 @@

- diff -ur synapse-0.99.5.2/synapse/python_dependencies.py synapse-0.99.5.2.patched/synapse/python_dependencies.py

- --- synapse-0.99.5.2/synapse/python_dependencies.py	2019-05-31 01:29:47.000000000 +1000

- +++ synapse-0.99.5.2.patched/synapse/python_dependencies.py	2019-06-08 16:21:33.986360990 +1000

- @@ -67,7 +67,7 @@

-      "six>=1.10",

-      # prometheus_client 0.4.0 changed the format of counter metrics

-      # (cf https://github.com/matrix-org/synapse/issues/4001)

- -    "prometheus_client>=0.0.18,<0.4.0",

- +    "prometheus_client>=0.0.18",

-  

-      # we use attr.s(slots), which arrived in 16.0.0

-      # Twisted 18.7.0 requires attrs>=17.4.0

sources
file modified
+1 -1

@@ -1,1 +1,1 @@

- SHA512 (synapse-1.0.0.tar.gz) = 1eda4834c9f6e6ac4b0c419e32f9bc287b485c6844c20608c83f622de27deca28e60e68e8448af0415410e7accd4fbbddf7578f1b1387db1b8a9b3c9e3b842f6

+ SHA512 (synapse-1.2.1.tar.gz) = 545bea5b0602add81b9344acd508585b78568395e57d189d62cd76618913183e79c6d543a28bc45c908bfc2b39b799418d4daf90e9cd7cf5b681c760feef0657

  • Raise synapse version to 1.1.0 1.2.1
  • Added min versions to dependencies as specified by upstream
  • Changed prometheus pin patch to work again

The build fails with "No matching package to install: 'python3-pymacaroons >= 0.13.0'", I believe because you renamed the dependency from python3-pymacaroons-pynacl to python3-pymacaroons.

rebased onto 3512bc5

2 months ago

1 new commit added

  • Update to v1.2.0
2 months ago

2 new commits added

  • Update to v1.2.0
  • Update to v1.1.0
2 months ago

1 new commit added

  • Update to v1.2.1
2 months ago

1.2.1 is a security update to Synapse.

Hi, thanks for the note and fixing the build issue. I've resolved the merge conflict locally and applied it, so I'm going to go ahead and close this. Builds should be arriving shortly.

Pull-Request has been closed by jcline

2 months ago