#1 [DO NOT MERGE] update to version 3.0.0
Closed a year ago by mizdebsk. Opened 2 years ago by decathorpe.
Unknown source master  into  rawhide

file modified
+7 -3
@@ -1,4 +1,8 @@

- maven-antrun-plugin-1.4.tar.xz

- maven-antrun-plugin-1.5-source-release.zip

- maven-antrun-plugin-1.7-source-release.zip

+ /results_*

+ /*.src.rpm

+ 

+ /maven-antrun-plugin-1.4.tar.xz

+ /maven-antrun-plugin-1.5-source-release.zip

+ /maven-antrun-plugin-1.7-source-release.zip

  /maven-antrun-plugin-1.8-source-release.zip

+ /maven-antrun-plugin-3.0.0-source-release.zip

file modified
+23 -8
@@ -1,42 +1,52 @@

  Name:           maven-antrun-plugin

- Version:        1.8

- Release:        12%{?dist}

+ Version:        3.0.0

+ Release:        1%{?dist}

  Summary:        Maven AntRun Plugin

- 

  License:        ASL 2.0

- URL:            http://maven.apache.org/plugins/maven-antrun-plugin/

- Source0:        http://repo2.maven.org/maven2/org/apache/maven/plugins/%{name}/%{version}/%{name}-%{version}-source-release.zip 

+ 

+ URL:            https://maven.apache.org/plugins/maven-antrun-plugin/

+ Source0:        https://repo1.maven.org/maven2/org/apache/maven/plugins/%{name}/%{version}/%{name}-%{version}-source-release.zip

  

  BuildArch:      noarch

  

  BuildRequires:  maven-local

+ BuildRequires:  mvn(junit:junit)

  BuildRequires:  mvn(org.apache.ant:ant)

+ BuildRequires:  mvn(org.apache.maven.plugin-tools:maven-plugin-annotations)

+ BuildRequires:  mvn(org.apache.maven.plugins:maven-plugin-plugin)

+ BuildRequires:  mvn(org.apache.maven.plugins:maven-plugins:pom:)

  BuildRequires:  mvn(org.apache.maven:maven-artifact)

+ BuildRequires:  mvn(org.apache.maven:maven-core)

  BuildRequires:  mvn(org.apache.maven:maven-plugin-api)

- BuildRequires:  mvn(org.apache.maven:maven-project)

- BuildRequires:  mvn(org.apache.maven.plugins:maven-plugins:pom:)

- BuildRequires:  mvn(org.apache.maven.plugin-tools:maven-plugin-annotations)

  BuildRequires:  mvn(org.codehaus.plexus:plexus-utils)

+ BuildRequires:  mvn(org.hamcrest:hamcrest-core)

+ BuildRequires:  mvn(org.xmlunit:xmlunit-core)

+ BuildRequires:  mvn(org.xmlunit:xmlunit-matchers)

  

  %description

  This plugin provides the ability to run Ant tasks from within Maven.

  It is even possible to embed Ant scripts in the POM.

  

+ 

  %package javadoc

  Summary:        Javadoc for %{name}

  

  %description javadoc

  This package contains the API documentation for %{name}.

  

+ 

  %prep

  %setup -q 

  

+ 

  %build

  %mvn_build

  

+ 

  %install

  %mvn_install

  

+ 

  %files -f .mfiles

  %dir %{_javadir}/%{name}

  %doc LICENSE NOTICE
@@ -44,7 +54,11 @@

  %files javadoc -f .mfiles-javadoc

  %doc LICENSE NOTICE

  

+ 

  %changelog

+ * Wed Aug 26 2020 Fabio Valentini <decathorpe@gmail.com> - 3.0.0-1

+ - Update to version 3.0.0.

+ 

  * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8-12

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

  
@@ -140,3 +154,4 @@

  

  * Thu May 27 2010 Alexander Kurtakov <akurtako@redhat.com> 1.4-1

  - Initial package.

+ 

file modified
+1 -1
@@ -1,1 +1,1 @@

- 43d36446386292876c4ad834027ac609  maven-antrun-plugin-1.8-source-release.zip

+ SHA512 (maven-antrun-plugin-3.0.0-source-release.zip) = 27976fb318c8481013ba89f90eba118f25bad72704b642185b5bae2d796a3f57af7eddb7f665f1db402b2351d34b7487bb28d32e01e9c0180967f64be4836725

  • update to latest version (1.8 → 3.0.0)
  • use HTTPS for URL and Source0
  • regenerate BuildRequires with xmvn-builddep
  • this drops some maven 2 dependencies in favor of maven 3

Note that this update currently causes some things to fail to build because they rely on deprecated functionality that's been removed with 3.0.0. Those packages will have to be ported to the non-deprecated equivalent of those functions:

You are using 'tasks' which has been removed from the maven-antrun-plugin.
Please use 'target' and refer to the >>Major Version Upgrade to version 3.0.0<< on the plugin site.

Test rebuilds in COPR:
https://copr.fedorainfracloud.org/coprs/decathorpe/maven-antrun-plugin-3.0.0-pr/monitor/

The following packages need to be adapted:

  • apache-commons-collections
  • apiviz
  • closure-compiler
  • javolution
  • jffi
  • jgroups
  • jnr-ffi
  • log4j12
  • slf4j
  • xsom

There's also a new test failure in maven-invoker.

rebased onto 8304612

2 years ago

rebased onto a861d74

2 years ago

Pull-Request has been closed by mizdebsk

a year ago