#2 Make it build after and before Python 3 is 3.6
Merged 4 months ago by tdawson. Opened 5 months ago by churchyard.
rpms/ churchyard/meson epel7_36  into  epel7

file modified
+12 -6

@@ -14,8 +14,14 @@ 

  BuildArch:      noarch

  Obsoletes:      %{name}-gui < 0.31.0-3

  

- BuildRequires:  python%{python3_other_pkgversion}-devel

- BuildRequires:  python%{python3_other_pkgversion}-setuptools

+ # this needs Python 3.5+

+ %if %{python3_pkgversion} < %{python3_other_pkgversion}

+ %global __python3 %__python3_other

+ %global python3_pkgversion %python3_other_pkgversion

+ %endif

+ 

+ BuildRequires:  python%{python3_pkgversion}-devel

+ BuildRequires:  python%{python3_pkgversion}-setuptools

  BuildRequires:  python3-rpm-macros

  BuildRequires:  ninja-build

  Requires:       ninja-build

@@ -33,10 +39,10 @@ 

  sed -i -e "/^%%__meson /s| .*$| %{_bindir}/%{name}|" data/macros.%{name}

  

  %build

- %py3_other_build

+ %py3_build

  

  %install

- %py3_other_install

+ %py3_install

  install -Dpm0644 data/macros.%{name} %{buildroot}%{rpmmacrodir}/macros.%{name}

  

  %files

@@ -46,8 +52,8 @@ 

  %{_bindir}/%{name}introspect

  %{_bindir}/%{name}test

  %{_bindir}/wraptool

- %{python3_other_sitelib}/%{libname}/

- %{python3_other_sitelib}/%{name}-*.egg-info/

+ %{python3_sitelib}/%{libname}/

+ %{python3_sitelib}/%{name}-*.egg-info/

  %{_mandir}/man1/%{name}.1*

  %{_mandir}/man1/%{name}conf.1*

  %{_mandir}/man1/%{name}introspect.1*

rebased onto 17f1893

4 months ago

The switch has been made from python 3.4 to 3.6.
Committing this patch

Pull-Request has been merged by tdawson

4 months ago
Metadata