#1 Fix requirement for %postun (instead of %preun) scriptlet
Merged 2 years ago by zdohnal. Opened 2 years ago by scfc.

file modified
+5 -2
@@ -8,7 +8,7 @@

  Summary: A getty replacement for use with data and fax modems

  Name: mgetty

  Version: 1.2.1

- Release: 1%{?dist}

+ Release: 2%{?dist}

  Source: ftp://mgetty.greenie.net/pub/mgetty/source/1.2/mgetty-%{version}.tar.gz

  Source1: ftp://mgetty.greenie.net/pub/mgetty/source/1.2/mgetty-%{version}.tar.gz.asc

  Source2: logrotate.mgetty
@@ -54,7 +54,7 @@

  BuildRequires: gcc

  Requires: coreutils, /usr/sbin/sendmail, uucp

  Requires(post): systemd

- Requires(preun): systemd

+ Requires(postun): systemd

  URL: http://mgetty.greenie.net/

  

  %package sendfax
@@ -351,6 +351,9 @@

  %{_mandir}/man1/viewfax.1*

  

  %changelog

+ * Fri Mar  8 2019 Tim Landscheidt <tim@tim-landscheidt.de> - 1.2.1-2

+ - Fix requirement for %%postun (instead of %%preun) scriptlet

+ 

  * Tue Feb 12 2019 Tomas Korbar <tkorbar@redhat.com> - 1.2.1-1

  - Rebase to 1.2.1

  - Resolve #1628754 #1628755 #1629971 #1629972

no initial comment

Hi Tim!
thank you for noticing the problem and the pull request! I'll merge it.

Pull-Request has been merged by zdohnal

2 years ago