Blob Blame History Raw
diff -rupN PyQt5_gpl-5.11.2/configure.py PyQt5_gpl-5.11.2-new/configure.py
--- PyQt5_gpl-5.11.2/configure.py	2018-06-29 13:48:34.000000000 +0200
+++ PyQt5_gpl-5.11.2-new/configure.py	2018-07-20 12:50:10.702603999 +0200
@@ -634,14 +634,6 @@ class TargetConfiguration:
     def from_introspection(self, verbose, debug):
         """ Initialise the configuration by introspecting the system. """
 
-        # Check that the enum module is available.
-        try:
-            import enum
-        except ImportError:
-            error(
-                    "Unable to import enum.  Please install the enum34 "
-                    "package from PyPI.")
-
         # Check there is a private copy of the sip module already installed.
         try:
             from PyQt5 import sip