#2 nemo-python: Add provides for python3-nemo
Merged 2 months ago by leigh123linux. Opened 2 months ago by ferdnyc.
rpms/ ferdnyc/nemo-extensions provide-python3-nemo  into  master

file modified
+6 -1

@@ -3,7 +3,7 @@ 

  

  Name:           nemo-extensions

  Version:        4.4.0

- Release:        3%{?dist}

+ Release:        4%{?dist}

  Summary:        Extensions for Nemo

  

  License:        GPLv2+ and LGPLv2

@@ -73,6 +73,7 @@ 

  License:     GPLv2+

  Obsoletes:   python2-nemo < %{version}-%{release}

  Obsoletes:   python3-nemo < %{version}-%{release}

+ Provides:    python3-nemo = %{version}-%{release}

  Requires:    nemo >= 4.0.0

  Requires:    python3-gobject-base

  

@@ -340,6 +341,10 @@ 

  %{_mandir}/man1/nemo-seahorse-tool.1.* 

  

  %changelog

+ * Fri Dec 13 2019 FeRD (Frank Dana) <ferdnyc@gmail.com> - 4.4.0-4

+ - nemo-python: Add provides for python3-nemo, required by some

+   legacy dependent packages

+ 

  * Fri Dec 13 2019 Leigh Scott <leigh123linux@googlemail.com> - 4.4.0-3

  - Add nemo-audio-tab

  

Weird, could've sworn I did this yesterday. Must've forgotten to hit "Submit".

This PR adds an explicit Provides: of python3-nemo back to nemo-python, as certain other packages still require it by that name:

$ sudo dnf repoquery --whatrequires python3-nemo
nemo-compare-0:4.2.0-2.fc31.noarch
nemo-emblems-0:4.2.0-2.fc31.noarch
nemo-gsconnect-0:26-1.fc31.noarch
nemo-gsconnect-0:30-1.fc31.noarch
nemo-pastebin-0:4.2.0-2.fc31.noarch
nemo-terminal-0:4.2.0-2.fc31.noarch
owncloud-client-nemo-0:2.5.4-2.fc31.x86_64
owncloud-client-nemo-0:2.6.0-1.fc31.x86_64
python3-nemo-devel-0:4.2.0-2.fc31.i686
python3-nemo-devel-0:4.2.0-2.fc31.x86_64
rabbitvcs-nemo-0:0.17.1-11.fc31.noarch

(At least rabbitvcs-nemo and owncloud-client-nemo still need a python3-nemo.)

Can you update this pr with master please?

rebased onto 6221388

2 months ago

Pull-Request has been merged by leigh123linux

2 months ago