Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

%global packagename camelcase
%global enable_tests 0
# tests disabled until we get 'ava' packaged into Fedora

Name:		nodejs-camelcase
Version:	3.0.0
Release:	3%{?dist}
Summary:	Convert a dash/dot/underscore/space separated string to camelCase

License:	MIT
URL:		https://github.com/sindresorhus/camelcase
Source0:	https://registry.npmjs.org/%{packagename}/-/%{packagename}-%{version}.tgz
Source1:	https://raw.githubusercontent.com/sindresorhus/camelcase/v%{version}/test.js


ExclusiveArch:	%{nodejs_arches} noarch
BuildArch:	noarch

BuildRequires:	nodejs-packaging
%if 0%{?enable_tests}
BuildRequires:	mocha
BuildRequires:	npm(ava)
%endif

Requires:	nodejs

%description
Convert a dash/dot/underscore/space separated string to camelCase:
foo-bar → fooBar


%prep
%setup -q -n package
# setup the tests
cp -r %{SOURCE1} .


%build
# nothing to do!

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{packagename}
cp -pr package.json index.js \
	%{buildroot}%{nodejs_sitelib}/%{packagename}

%nodejs_symlink_deps

%check
%nodejs_symlink_deps --check
%{__nodejs} -e 'require("./")'
%if 0%{?enable_tests}
%{_bindir}/mocha -R spec
/usr/bin/mocha -R spec
%else
%{_bindir}/echo -e "\e[101m -=#=- Tests disabled -=#=- \e[0m"
%endif


%files
%{!?_licensedir:%global license %doc}
%doc *.md
%license license
%{nodejs_sitelib}/%{packagename}



%changelog
* Thu Aug 04 2016 Jared Smith <jsmith@fedoraproject.org> - 3.0.0-3
- Update test.js to latest version

* Thu Aug 04 2016 Jared Smith <jsmith@fedoraproject.org> - 3.0.0-2
- Fix test.js

* Wed Jul 13 2016 Jared Smith <jsmith@fedoraproject.org> - 3.0.0-1
- Update to upstream 3.0.0 release

* Fri Oct 23 2015 Jared Smith <jsmith@fedoraproject.org> - 1.2.1-1
- Initial packaging