Blame obs-service-set_version.spec

05b791
05b791
%global service set_version
05b791
05b791
Name:           obs-service-%{service}
05b791
Version:        0.5.10
65db95
Release:        3%{?dist}
05b791
Summary:        An OBS source service: Update spec file version
05b791
License:        GPLv2+
05b791
URL:            https://github.com/openSUSE/obs-service-%{service}
05b791
Source:         %{url}/archive/%{version}/%{name}-%{version}.tar.gz
05b791
BuildRequires:  sed
05b791
BuildRequires:  python3-devel
05b791
BuildRequires:  python3dist(ddt)
05b791
BuildRequires:  python3dist(packaging)
05b791
Recommends:     python3dist(packaging)
05b791
Requires:       python3
05b791
BuildArch:      noarch
05b791
05b791
%description
05b791
This is a source service for openSUSE Build Service.
05b791
05b791
Very simply script to update the version in .spec or .dsc files according to
05b791
a given version or to the existing files.
05b791
05b791
%prep
05b791
%autosetup
05b791
05b791
%build
05b791
sed -i -e "1 s,#!/usr/bin/python$,#!%{__python3}," set_version
05b791
05b791
%install
05b791
mkdir -p %{buildroot}%{_prefix}/lib/obs/service
05b791
install -m 0755 set_version %{buildroot}%{_prefix}/lib/obs/service
05b791
install -m 0644 set_version.service %{buildroot}%{_prefix}/lib/obs/service
05b791
05b791
%check
05b791
%{__python3} -m unittest discover tests/
05b791
05b791
%files
05b791
# In lieu of a proper license file: https://github.com/openSUSE/obs-service-set_version/issues/57
05b791
%license debian/copyright
05b791
%dir %{_prefix}/lib/obs
05b791
%{_prefix}/lib/obs/service
05b791
05b791
%changelog
65db95
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.10-3
65db95
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
65db95
e3da78
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.10-2
e3da78
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
e3da78
05b791
* Tue Oct 02 2018 Neal Gompa <ngompa13@gmail.com> - 0.5.10-1
05b791
- Update to 0.5.10
05b791
- Run unit tests
05b791
- Set sed properly as a build dependency
05b791
05b791
* Sat Mar 24 2018 Neal Gompa <ngompa13@gmail.com> - 0.5.8-1
05b791
- Initial packaging
05b791