#1 Update Python 2 dependency declarations to new packaging standards
Merged 4 years ago by smani. Opened 4 years ago by ishcherb.
rpms/ ishcherb/openambit pyambiguous  into  master

file modified
+6 -2
@@ -3,7 +3,7 @@ 

  

  Name:           openambit

  Version:        0.4

- Release:        7%{?commit:.git%shortcommit}%{?dist}

+ Release:        8%{?commit:.git%shortcommit}%{?dist}

  Summary:        Open software for the Suunto Ambit(2)

  

  License:        GPLv3+
@@ -23,7 +23,7 @@ 

  BuildRequires:  systemd-devel

  BuildRequires:  wireshark-devel

  BuildRequires:  hidapi-devel

- BuildRequires:  python

+ BuildRequires:  python2

  BuildRequires:  zlib-devel

  

  Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
@@ -117,6 +117,10 @@ 

  

  

  %changelog

+ * Mon Mar 19 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.4-8

+ - Update Python 2 dependency declarations to new packaging standards

+   (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)

+ 

  * Mon Feb 19 2018 Sandro Mani <manisandro@gmail.com> - 0.4-7

  - Add missing BR: gcc-c++, make

  

This package uses names with ambiguous python- prefix in requirements.

According to Fedora Packaging guidelines for Python, packages must use names with either python2- or python3- prefix in requirements where available.
We are aiming to rename python-* dependencies to python2-*, so we can later switch the python-* namespace to Python 3.

This PR is part of Fedora's Switch to Python 3 effort.

Note that, although this PR was created automatically, we will respond to any comments or issues which you might find with it. We will keep the PR open for review for a week, and if there's no feedback we'll merge it. There is no need to build the package right after merge, this change can wait for the next package rebuild.
The local mock build passed, for Koji scratch build please see simple-koji-ci result.

This PR was opened automatically, for source code see here

Pull-Request has been merged by smani

4 years ago