#1 Require java-1.8.0-openjdk-openjfx to fix rhbz#1539929
Closed 8 months ago by deamn. Opened a year ago by genodeftest.
rpms/ genodeftest/openjfx master  into  master

file modified
+3 -1

@@ -21,7 +21,9 @@ 

  

  Requires:       javapackages-tools

  Requires:       java

+ Requires:       java-1.8.0-openjdk-openjfx

  

+ BuildRequires:  gcc-c++

  BuildRequires:  gradle-local

  BuildRequires:  mvn(antlr:antlr)

  BuildRequires:  mvn(junit:junit)

@@ -100,7 +102,7 @@ 

  %build

  #Tests do not run by default, tests in web fails and one test in graphics fail:

  #UnsatisfiedLinkError: libjavafx_iio.so: undefined symbol: jpeg_resync_to_restart

- gradle-local --no-daemon --offline

+ gradle-local --stacktrace --info --no-daemon --offline

  

  

  %install

Without installing java-1.8.0-openjdk-openjfx, this package is rendered useless as it causes fatal exceptions on start of any JavaFX-based application (see https://bugzilla.redhat.com/show_bug.cgi?id=1539929 and https://bugzilla.redhat.com/show_bug.cgi?id=1557787).

rebased onto 06f3c88

10 months ago

rebased onto b494180

10 months ago

rebased onto 6bd9d1b

10 months ago

rebased onto 898b6f7

10 months ago

rebased onto 2812b49

10 months ago

The requirement on java-1.8.0-openjdk-fx is wrong. It canbe added, otherwise cyclic depndency arise.
This package provides fx implementation, but java-1.8.0-openjdk-fx is just set of links integrating it with JDK.

Next.. the fx currently donot build, and if ti will its sources are so outdated that it is full ov CVEs.
If this shod be merged, new maintainer should be found

Pull-Request has been closed by deamn

8 months ago