Blob Blame History Raw
Name:           perl-Long-Jump
Version:        0.000001
Release:        6%{?dist}
Summary:        Mechanism for returning to a specific point from a deeply nested stack
License:        GPL+ or Artistic
URL:            https://metacpan.org/release/Long-Jump
Source0:        https://cpan.metacpan.org/authors/id/E/EX/EXODIST/Long-Jump-%{version}.tar.gz
BuildArch:      noarch
BuildRequires:  make
BuildRequires:  perl-generators
BuildRequires:  perl-interpreter
BuildRequires:  perl(:VERSION) >= 5.8.1
BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires:  perl(strict)
BuildRequires:  perl(warnings)
# Run-time:
BuildRequires:  perl(Carp)
BuildRequires:  perl(Importer)
# Tests:
# Test2::V0 version from Test2::Suite in META
BuildRequires:  perl(Test2::V0) >= 0.000126
Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))

%description
This Perl module essentially provides a multi-level return. You can mark
a spot with setjump() and then unwind the stack back to that point from any
nested stack frame by name using longjump(). You can also provide a list of
return values. It is safer than C language jump in that it only lets you
escape frames by going up the stack, you cannot jump in other ways.

%prep
%setup -q -n Long-Jump-%{version}

%build
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
%{make_build}

%install
%{make_install}
%{_fixperms} $RPM_BUILD_ROOT/*

%check
make test

%files
%license LICENSE
%doc Changes README
%{perl_vendorlib}/*
%{_mandir}/man3/*

%changelog
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.000001-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Fri May 21 2021 Jitka Plesnikova <jplesnik@redhat.com> - 0.000001-5
- Perl 5.34 rebuild

* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.000001-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.000001-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Tue Jun 23 2020 Jitka Plesnikova <jplesnik@redhat.com> - 0.000001-2
- Perl 5.32 rebuild

* Mon Mar 02 2020 Petr Pisar <ppisar@redhat.com> 0.000001-1
- Specfile autogenerated by cpanspec 1.78.