Blob Blame History Raw
Name:		perl-Object-ID
Version:	0.1.2
Release:	2%{?dist}
Summary:	A unique identifier for any object
License:	GPL+ or Artistic
Group:		Development/Libraries
URL:		https://metacpan.org/release/Object-ID
Source0:	http://cpan.metacpan.org/authors/id/M/MS/MSCHWERN/Object-ID-v%{version}.tar.gz
BuildArch:	noarch
BuildRequires:	perl(Carp)
BuildRequires:	perl(Data::UUID) >= 1.148
BuildRequires:	perl(Hash::FieldHash) >= 0.10
BuildRequires:	perl(lib)
BuildRequires:	perl(Module::Build)
BuildRequires:	perl(namespace::autoclean)
BuildRequires:	perl(strict)
BuildRequires:	perl(Sub::Name) >= 0.03
BuildRequires:	perl(Test::More) >= 0.88
BuildRequires:	perl(threads)
BuildRequires:	perl(version) >= 0.77
BuildRequires:	perl(warnings)
Requires:	perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires:	perl(Data::UUID) >= 1.148

# Don't provide perl(UNIVERSAL)
%{?perl_default_filter}

%description
This is a unique identifier for any object, regardless of its type, structure
or contents. Its features are:

 * Works on ANY object of any type
 * Does not modify the object in any way
 * Does not change with the object's contents
 * Is O(1) to calculate (i.e. doesn't matter how big the object is)
 * The id is unique for the life of the process
 * The id is always a true value

%prep
%setup -q -n Object-ID-v%{version}

%build
perl Build.PL installdirs=vendor
./Build

%install
./Build install destdir=%{buildroot} create_packlist=0
%{_fixperms} %{buildroot}

%check
./Build test

%files
%doc Changes LICENSE README
%{perl_vendorlib}/Object/
%{perl_vendorlib}/UNIVERSAL/
%{_mandir}/man3/Object::ID.3pm*
%{_mandir}/man3/Object::ID::ConfigData.3pm*
%{_mandir}/man3/UNIVERSAL::Object::ID.3pm*

%changelog
* Sun Aug 18 2013 Paul Howarth <paul@city-fan.org> - 0.1.2-2
- Sanitize for Fedora submission

* Thu Aug 15 2013 Paul Howarth <paul@city-fan.org> - 0.1.2-1
- Initial RPM version