Blame perl-Test2-Tools-Explain.spec

dc261f9
Name:		perl-Test2-Tools-Explain
dc261f9
Version:	0.02
dc261f9
Release:	1%{?dist}
dc261f9
Summary:	Explain tools for Perl's Test2 framework
dc261f9
License:	Artistic 2.0
dc261f9
URL:		https://metacpan.org/release/Test2-Tools-Explain
dc261f9
Source0:	https://cpan.metacpan.org/authors/id/P/PE/PETDANCE/Test2-Tools-Explain-%{version}.tar.gz
dc261f9
BuildArch:	noarch
dc261f9
# Build
dc261f9
BuildRequires:	coreutils
dc261f9
BuildRequires:	make
dc261f9
BuildRequires:	perl-generators
dc261f9
BuildRequires:	perl-interpreter
dc261f9
BuildRequires:	perl(ExtUtils::MakeMaker) >= 6.76
dc261f9
# Module Runtime
dc261f9
BuildRequires:	perl(Data::Dumper)
dc261f9
BuildRequires:	perl(Exporter)
dc261f9
BuildRequires:	perl(parent)
dc261f9
BuildRequires:	perl(strict)
dc261f9
BuildRequires:	perl(warnings)
dc261f9
# Test Suite
dc261f9
BuildRequires:	perl(Test2::Bundle::Extended)
dc261f9
BuildRequires:	perl(Test::More)
dc261f9
# Dependencies
dc261f9
Requires:	perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
dc261f9
Requires:	perl(Data::Dumper)
dc261f9
dc261f9
%description
dc261f9
Test2::Suite dropped the explain() function that had been part of Test::More.
dc261f9
For those who miss it in Test2, you can use Test2::Tools::Explain.
dc261f9
dc261f9
%prep
dc261f9
%setup -q -n Test2-Tools-Explain-%{version}
dc261f9
dc261f9
%build
dc261f9
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
dc261f9
%{make_build}
dc261f9
dc261f9
%install
dc261f9
%{make_install}
dc261f9
%{_fixperms} -c %{buildroot}
dc261f9
dc261f9
%check
dc261f9
make test
dc261f9
dc261f9
%files
dc261f9
%doc Changes README.md
dc261f9
%{perl_vendorlib}/Test2/
dc261f9
%{_mandir}/man3/Test2::Tools::Explain.3*
dc261f9
dc261f9
%changelog
dc261f9
* Mon Nov 25 2019 Paul Howarth <paul@city-fan.org> - 0.02-1
dc261f9
- Initial RPM version