Blob Blame History Raw
%global commit bb7120f3ffa47ad47be8f679202d7203b1c6d7c4
%global shortcommit %(c=%{commit}; echo ${c:0:7})

Name:           podman-compose
Version:        0.1.5
Release:        1.git20191030%{?dist}
Summary:        Run docker-compose.yml using podman
License:        GPLv2
URL:            https://github.com/containers/podman-compose
Source0:        https://github.com/containers/podman-compose/archive/%{commit}/%{name}-%{shortcommit}.tar.gz

BuildArch:      noarch
BuildRequires:  python3-devel
BuildRequires:  python3-setuptools
BuildRequires:  python3-pyyaml
Requires:       python3-pyyaml
Requires:       podman

%description
An implementation of docker-compose with podman backend.
The main objective of this project is to be able to run docker-compose.yml
unmodified and rootless.

%prep
%autosetup -n %{name}-%{commit}

%build
%py3_build
 
%install
%py3_install 

#Drop spurious shebang
sed -i /python3/d %{buildroot}%{python3_sitelib}/podman_compose.py


%files
%doc README.md CONTRIBUTING.md docs/ examples
%license LICENSE
%{_bindir}/podman-compose
%{python3_sitelib}/__pycache__/podman_compose*pyc
%{python3_sitelib}/podman_compose*

%changelog
* Mon Oct 28 2019 Gwyn Ciesla <gwync@protonmail.com> - 0.1.5-1.git20191030
- Initial build.