Blame 00-setup-requirements-fixes.patch

0a6ee47
diff --git a/setup.py b/setup.py
a6c3880
index a270104..da84fba 100644
0a6ee47
--- a/setup.py
0a6ee47
+++ b/setup.py
a6c3880
@@ -50,14 +50,14 @@ install_requires = \
0a6ee47
  'pexpect>=4.7.0,<5.0.0',
0a6ee47
  'pkginfo>=1.4,<2.0',
0a6ee47
  'pyparsing>=2.2,<3.0',
0a6ee47
- 'pyrsistent>=0.14.2,<0.15.0',
0a6ee47
- 'requests-toolbelt>=0.8.0,<0.9.0',
0a6ee47
+ 'pyrsistent>=0.14.2',
0a6ee47
+ 'requests-toolbelt>=0.8.0',
0a6ee47
  'requests>=2.18,<3.0',
0a6ee47
  'shellingham>=1.1,<2.0',
a6c3880
  'tomlkit>=0.5.10,<0.6.0']
15be892
 
15be892
 extras_require = \
15be892
-{':python_version < "3.8"': ['importlib-metadata>=1.1.3,<1.2.0'],
15be892
+{':python_version < "3.8"': ['importlib-metadata'],
15be892
  ':python_version >= "2.7" and python_version < "2.8"': ['virtualenv>=16.7.9,<17.0.0',
15be892
                                                          'functools32>=3.2.3,<4.0.0'],
15be892
  ':python_version >= "2.7" and python_version < "2.8" or python_version >= "3.4" and python_version < "3.5"': ['typing>=3.6,<4.0',
a6c3880
@@ -65,7 +65,7 @@ extras_require = \
15be892
                                                                                                                'subprocess32>=3.5,<4.0',
15be892
                                                                                                                'glob2>=0.6,<0.7',
a6c3880
                                                                                                                'keyring>=18.0.1,<19.0.0'],
15be892
- ':python_version >= "3.5" and python_version < "4.0"': ['keyring>=20.0.1,<21.0.0']}
15be892
+ ':python_version >= "3.5" and python_version < "4.0"': ['keyring']}
15be892
 
15be892
 entry_points = \
15be892
 {'console_scripts': ['poetry = poetry.console:main']}