#2 Drop unused Python 2 dependencies
Merged 5 years ago by churchyard. Opened 5 years ago by churchyard.
rpms/ churchyard/pogo py2  into  master

file modified
+6 -3
@@ -1,6 +1,6 @@ 

  Name:		pogo

  Version:	1.0

- Release:	1%{?dist}

+ Release:	2%{?dist}

  Summary:	Probably the simplest and fastest audio player for Linux

  Summary(de):	Möglicherweise der einfachste und schnellste Audioplayer für Linux

  
@@ -13,12 +13,12 @@ 

  BuildRequires:	desktop-file-utils

  BuildRequires:	python3-devel

  BuildRequires:	libappstream-glib

- Requires:	pygtk2-libglade

- Requires:	python2-cddb

+ Requires:	python3-cddb

  Requires:	python3-dbus

  Requires:	python3-mutagen

  Requires:	python3-pillow

  Requires:	python3-inotify

+ Requires:	python3-gobject

  Requires:	python3-gstreamer1

  Obsoletes: pogo < %{version}

  Obsoletes: pogo-zeitgeist < %{version}
@@ -64,6 +64,9 @@ 

  

  

  %changelog

+ * Sun Dec 09 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0-2

+ - Drop unused Python 2 dependencies

+ 

  * Sat Aug 25 2018 Filipe Rosset <rosset.filipe@gmail.com> - 1.0-1

  - new upstream version 1.0 + spec cleanup and modernization

  

no initial comment

Pull-Request has been merged by churchyard

5 years ago

cannot install the best update candidate for package pogo-1.0-1.fc30.noarch
- nothing provides python3-cddb needed by pogo-1.0-2.fc30.noarch

Oh. Sorry about that. It seems that we only have python2-cdd, yet I don't understand why it was required from a Python 3 program.

Was about to send a fix, but I see https://src.fedoraproject.org/rpms/pogo/c/36ed15bb4eedf308999a910951fc9524d989d5a0?branch=master thank you and sorry about this again. I thought I've checked that.

no problem, patches are always welcomed :)