Blob Blame History Raw
%global pypi_name admesh

Name:           python-%{pypi_name}
Version:        0.98.7
Release:        1%{?dist}
Summary:        Python bindings for ADMesh, STL manipulation library

License:        GPLv2+
URL:            https://github.com/admesh/python-admesh
Source0:        https://files.pythonhosted.org/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
 
BuildRequires:  admesh-devel >= 0.98

BuildRequires:  python2-devel
BuildRequires:  python2-setuptools
BuildRequires:  python2-pytest
BuildRequires:  python2-Cython
BuildRequires:  python2-pytest-runner
 
BuildRequires:  python3-devel
BuildRequires:  python3-pytest
BuildRequires:  python3-setuptools
BuildRequires:  python3-Cython
BuildRequires:  python3-pytest-runner

%description
This module provides bindings for the ADMesh library.
It lets you manipulate 3D models in binary or ASCII STL
format and partially repair them if necessary.


%package -n     python2-%{pypi_name}
Summary:        Python 2 bindings for ADMesh, STL manipulation library
%{?python_provide:%python_provide python2-%{pypi_name}}

%description -n python2-%{pypi_name}
This module provides bindings for the ADMesh library.
It lets you manipulate 3D models in binary or ASCII STL
format and partially repair them if necessary.


%package -n     python3-%{pypi_name}
Summary:        Python 3 bindings for ADMesh, STL manipulation library
%{?python_provide:%python_provide python3-%{pypi_name}}

%description -n python3-%{pypi_name}
This module provides bindings for the ADMesh library.
It lets you manipulate 3D models in binary or ASCII STL
format and partially repair them if necessary.


%prep
%setup -q -n %{pypi_name}-%{version}


%build
%py2_build
%py3_build


%install
%py2_install
%py3_install

%check
PYTHONPATH=%{buildroot}%{python2_sitearch} py.test-2 -v
PYTHONPATH=%{buildroot}%{python3_sitearch} py.test-3 -v

%files -n python2-%{pypi_name}
%doc README.rst
%license COPYING
%attr(0755,root,root) %{python2_sitearch}/%{pypi_name}.so
%{python2_sitearch}/%{pypi_name}-%{version}-py?.?.egg-info

%files -n python3-%{pypi_name}
%doc README.rst
%license COPYING
%attr(0755,root,root) %{python3_sitearch}/%{pypi_name}.*.so
%{python3_sitearch}/%{pypi_name}-%{version}-py?.?.egg-info


%changelog
* Thu Apr 13 2017 Miro Hrončok <mhroncok@redhat.com> - 0.98.7-1
- Updated to new version 0.98.7
- Updated to the new naming scheme

* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.98.5-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.98.5-4
- Rebuild for Python 3.6

* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98.5-3
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages

* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.98.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

* Tue Dec 08 2015 Miro Hrončok <mhroncok@redhat.com> - 0.98.5-1
- New version 0.98.5, fix FTBFS

* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98.3-3
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5

* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Wed Feb 25 2015 Miro Hrončok <mhroncok@redhat.com> - 0.98.3-1
- New version 0.98.3

* Wed Sep 03 2014 Miro Hrončok <mhroncok@redhat.com> - 0.98.1-1
- New version
- Run tests, add BR pytest

* Wed Sep 03 2014 Miro Hrončok <mhroncok@redhat.com> - 0.98-3
- Set correct executable permissions
- Typo in summary

* Thu Jul 31 2014 Miro Hrončok <mhroncok@redhat.com> - 0.98-2
- Require setuptools.

* Tue Jul 29 2014 Miro Hrončok <mhroncok@redhat.com> - 0.98-1
- Initial package.