# No tests in the package at all
%bcond_with tests
%global pypi_name cypy
%global _description %{expand:
Useful utilities for Python.}
Name: python-%{pypi_name}
Version: 0.2.0
Release: 12%{?dist}
Summary: Useful utilities for Python
License: MIT
URL: https://pypi.org/pypi/%{pypi_name}
Source0: %pypi_source
# Not included in pypi tar
Source1: https://raw.githubusercontent.com/cyrus-/%{pypi_name}/master/LICENSE
# Update for py3.10
# Sent upstream: https://github.com/cyrus-/cypy/pull/3
Patch1: 0001-fix-py3.10-update-collections-to-collections.abc.patch
BuildArch: noarch
BuildRequires: git-core
%{?python_enable_dependency_generator}
%description %_description
%package -n python3-%{pypi_name}
Summary: %{summary}
BuildRequires: python3-devel
# Not mentioned in setup.py
Requires: %{py3_dist matplotlib}
Requires: %{py3_dist numpy}
%description -n python3-%{pypi_name} %_description
%prep
%autosetup -n %{pypi_name}-%{version} -S git
rm -rf %{pypi_name}.egg-info
cp %{SOURCE1} . -v
# Comment out to remove /usr/bin/env shebangs
# Can use something similar to correct/remove /usr/bin/python shebangs also
# find . -type f -name "*.py" -exec sed -i '/^#![ ]*\/usr\/bin\/env.*$/ d' {} 2>/dev/null ';'
%build
%py3_build
%install
%py3_install
%check
%if %{with tests}
%{__python3} setup.py test
%endif
%files -n python3-%{pypi_name}
%license LICENSE
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info
%{python3_sitelib}/%{pypi_name}
%changelog
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 0.2.0-10
- Rebuilt for Python 3.11
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 0.2.0-7
- Rebuilt for Python 3.10
* Wed Apr 21 2021 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.2.0-6
- Fix build for py310
- https://bugzilla.redhat.com/show_bug.cgi?id=1926356
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue May 26 2020 Miro HronĨok <mhroncok@redhat.com> - 0.2.0-3
- Rebuilt for Python 3.9
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Sat Dec 07 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.2.0-1
- Initial build