Blob Blame Raw
diff --git a/setup.py b/setup.py
index 94fbdf4..466f7a0 100644
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,7 @@ from __future__ import print_function
 
 import codecs
 import os
+import sys
 
 from setuptools import setup, find_packages
 
@@ -14,38 +15,19 @@ requirements = [
     'websocket-client >= 0.32.0',
     'docker-pycreds >= 0.4.0',
     'requests >= 2.14.2, != 2.18.0',
+    'pyOpenSSL>=17.5.0',
+    'cryptography>=1.3.4',
+    'idna>=2.0.0',
+    'paramiko>=2.4.2',
 ]
 
-extras_require = {
-    ':python_version < "3.5"': 'backports.ssl_match_hostname >= 3.5',
-    # While not imported explicitly, the ipaddress module is required for
-    # ssl_match_hostname to verify hosts match with certificates via
-    # ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname
-    ':python_version < "3.3"': 'ipaddress >= 1.0.16',
-
-    # win32 APIs if on Windows (required for npipe support)
-    # Python 3.6 is only compatible with v220 ; Python < 3.5 is not supported
-    # on v220 ; ALL versions are broken for v222 (as of 2018-01-26)
-    ':sys_platform == "win32" and python_version < "3.6"': 'pypiwin32==219',
-    ':sys_platform == "win32" and python_version >= "3.6"': 'pypiwin32==223',
-
-    # urllib3 drops support for Python 3.3 in 1.23
-    ':python_version == "3.3"': 'urllib3 < 1.23',
-
-    # If using docker-py over TLS, highly recommend this option is
-    # pip-installed or pinned.
-
-    # TODO: if pip installing both "requests" and "requests[security]", the
-    # extra package from the "security" option are not installed (see
-    # https://github.com/pypa/pip/issues/4391).  Once that's fixed, instead of
-    # installing the extra dependencies, install the following instead:
-    # 'requests[security] >= 2.5.2, != 2.11.0, != 2.12.2'
-    'tls': ['pyOpenSSL>=17.5.0', 'cryptography>=1.3.4', 'idna>=2.0.0'],
-
-    # Only required when connecting using the ssh:// protocol
-    'ssh': ['paramiko>=2.4.2'],
-
-}
+if sys.version_info[:2] < (3, 5):
+    requirements.append('backports.ssl_match_hostname >= 3.5')
+# While not imported explicitly, the ipaddress module is required for
+# ssl_match_hostname to verify hosts match with certificates via
+# ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname
+if sys.version_info[:2] < (3, 3):
+    requirements.append('ipaddress >= 1.0.16')
 
 version = None
 exec(open('docker/version.py').read())
@@ -74,8 +56,6 @@ setup(
     packages=find_packages(exclude=["tests.*", "tests"]),
     install_requires=requirements,
     tests_require=test_requirements,
-    extras_require=extras_require,
-    python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*',
     zip_safe=False,
     test_suite='tests',
     classifiers=[